summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjörn Bidar2024-03-03 03:53:09 +0200
committerBjörn Bidar2024-03-03 03:53:09 +0200
commit1356e95ae7d80c82b8364f8f7ec382249dc27fff (patch)
tree4cff3a3f0441ab478b867d63f66f61ab4814b7fe
parent33e3776d44eb5ef6eb5c30d82af8e0117775b38b (diff)
downloadaur-1356e95ae7d80c82b8364f8f7ec382249dc27fff.tar.gz
Update to 3.6.2-1
- New upstream release - Cleanup of packaging - depend on quazip-qt5 - Remove rpath from ts3client - General cleanup - The package now works against the latest version of libc++ Signed-off-by: Björn Bidar <bjorn.bidar@thaodan.de>
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD39
2 files changed, 27 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb2ae6d3c903..c03a7b078087 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
-# Generated by mksrcinfo v8
-# Sun Dec 27 14:42:04 UTC 2020
pkgbase = teamspeak3-wbundled
pkgdesc = TeamSpeak is software for quality voice communication via the Internet
- pkgver = 3.5.6
+ pkgver = 3.6.2
pkgrel = 1
url = http://www.teamspeak.com
arch = x86_64
license = custom
makedepends = patchelf
- depends = quazip
+ depends = quazip-qt5
depends = libc++
depends = qt5-svg
depends = qt5-webengine
@@ -20,11 +18,10 @@ pkgbase = teamspeak3-wbundled
source = teamspeak3.desktop
source = teamspeak3.png
source = LICENSE
- source = https://files.teamspeak-services.com/releases/client/3.5.6/TeamSpeak3-Client-linux_amd64-3.5.6.run
+ source = https://files.teamspeak-services.com/releases/client/3.6.2/TeamSpeak3-Client-linux_amd64-3.6.2.run
sha512sums = 4cac0b7446dc3e728b232fdd6c6d75be1d2a5530635eab5918a4e7dd6a4a3fc21d6a75055da919b56e5cf849f4c5ba26ece56759a45bc4850eba3eb73853759d
sha512sums = af18ed36a3c8de90b60a7205ebf91a35d4b517f22f97d541c82debdb12697882469d9771fdf3fb8b081aeb74a01237f3afd4732daccf4b374dc6d39e7df5d444
sha512sums = d6d03f1bda86c90390ce0032e4d30e889977f80ff76ba1e5c443109e93cbedbee92c6fc2759f58d23659c15dba4f2ac718861571239ba117dcfe11f136f556dc
- sha512sums = fe1b41773d2b2de8198fdaf189c6665994eeaf6a0255485f7d342a3e77702f5515d5c5c685410a0b5844b4ad5c395d57b68e57c7b1f46bd1211ef813ce1e0030
+ sha512sums = 09448086ed3322ba5a37905c5b893fdf0860e5e80852da2713a2d3aceddc071ff6cd7bc213f494759b9448615a027130579da7292f59447b3c31553e151d35eb
pkgname = teamspeak3-wbundled
-
diff --git a/PKGBUILD b/PKGBUILD
index e7746a844e09..7e036c53be10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,12 @@
_pkgname=teamspeak3
pkgname=$_pkgname-wbundled
-pkgver=3.5.6
+pkgver=3.6.2
pkgrel=1
pkgdesc="TeamSpeak is software for quality voice communication via the Internet"
url="http://www.teamspeak.com"
license=('custom')
-depends=('quazip'
+depends=('quazip-qt5'
'libc++'
'qt5-svg'
'qt5-webengine'
@@ -31,30 +31,38 @@ source=('teamspeak3.desktop'
sha512sums=('4cac0b7446dc3e728b232fdd6c6d75be1d2a5530635eab5918a4e7dd6a4a3fc21d6a75055da919b56e5cf849f4c5ba26ece56759a45bc4850eba3eb73853759d'
'af18ed36a3c8de90b60a7205ebf91a35d4b517f22f97d541c82debdb12697882469d9771fdf3fb8b081aeb74a01237f3afd4732daccf4b374dc6d39e7df5d444'
'd6d03f1bda86c90390ce0032e4d30e889977f80ff76ba1e5c443109e93cbedbee92c6fc2759f58d23659c15dba4f2ac718861571239ba117dcfe11f136f556dc'
- 'fe1b41773d2b2de8198fdaf189c6665994eeaf6a0255485f7d342a3e77702f5515d5c5c685410a0b5844b4ad5c395d57b68e57c7b1f46bd1211ef813ce1e0030')
+ '09448086ed3322ba5a37905c5b893fdf0860e5e80852da2713a2d3aceddc071ff6cd7bc213f494759b9448615a027130579da7292f59447b3c31553e151d35eb')
prepare() {
mkdir archive && cd archive
sh "${srcdir}"/TeamSpeak3-Client-linux_amd64-${pkgver}.run --tar -xf \
2>/dev/null
+ libquazip=$(cd /usr/lib;echo libquazip1-qt5.so*|cut -f2 -d " ")
+
+
# Remove bundled libraries..
- rm -rf qt.conf *.so* \
- platforms xcbglintegrations \
- iconengines imageformats \
- qtwebengine_locales \
- sqldrivers \
- ts3client_runscript.sh
+ rm -rf -- qt.conf *.so* \
+ platforms xcbglintegrations \
+ iconengines imageformats \
+ qtwebengine_locales \
+ sqldrivers \
+ ts3client_runscript.sh
+
# Fix libquazip1-qt5.so name
- patchelf --replace-needed libquazip.so libquazip1-qt5.so ts3client_linux_amd64
+ patchelf --replace-needed libquazip.so \
+ $libquazip ts3client_linux_amd64
+ patchelf --remove-rpath ts3client_linux_amd64
+
# Fix permissions
- find -type d | xargs chmod 755
- find -type f | xargs chmod 644
- find -name *.so | xargs chmod 755
- chmod +x ts3client*
- chmod +x package_inst
+ find . -type d -exec chmod 755 {} \;
+ find . -type f -exec chmod 644 {} \;
+ find \( -name \*.so -o \
+ -name package_inst \
+ -o -name ts3client\* \)\
+ -exec chmod 755 {} \;
}
package() {
@@ -66,6 +74,5 @@ package() {
install -D -m644 "${srcdir}"/teamspeak3.png "${pkgdir}"/usr/share/pixmaps/teamspeak3.png
install -D -m644 "${srcdir}"/LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
ln -s /opt/teamspeak3/ts3client_linux_amd64 "${pkgdir}"/usr/bin/teamspeak3
- chmod +x "$pkgdir"/opt/teamspeak3/ts3client_linux_amd64
}
# vim:set ts=2 sw=2 et: