summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPitBall2015-07-13 13:51:24 +0200
committerPitBall2015-07-13 13:51:24 +0200
commit902f95d3b2d51174e6956a37170b68b2f520e7d3 (patch)
treeef5e4add64c5e0845afb936a4577e1dadfeae251
downloadaur-902f95d3b2d51174e6956a37170b68b2f520e7d3.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
-rw-r--r--install15
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3edf214ac28a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = teamspeak3-xosd-overlay
+ pkgdesc = Teamspeak3 overlay for Linux, which uses lua and xosd to output
+ pkgver = 0.1
+ pkgrel = 2
+ url = https://bitbucket.org/l0ser140/teamspeak3-xosd-overlay
+ install = install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = lua
+ depends = teamspeak3
+ depends = xosd
+ source = git+https://bitbucket.org/l0ser140/teamspeak3-xosd-overlay.git
+ md5sums = SKIP
+
+pkgname = teamspeak3-xosd-overlay
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cf320cd7b07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: PitBall
+
+pkgname=teamspeak3-xosd-overlay
+pkgver=0.1
+pkgrel=2
+pkgdesc="Teamspeak3 overlay for Linux, which uses lua and xosd to output"
+arch=('any')
+url="https://bitbucket.org/l0ser140/teamspeak3-xosd-overlay"
+license=('GPL')
+depends=('lua' 'teamspeak3' 'xosd')
+makedepends=('git')
+source=("git+${url}.git")
+#backup=('opt/teamspeak3/plugins/lua_plugin/osd/init.lua')
+md5sums=('SKIP')
+install=install
+
+package() {
+ cd "${pkgname}/osd"
+ install -D -m666 init.lua $pkgdir/opt/teamspeak3/plugins/lua_plugin/osd/init.lua
+}
diff --git a/install b/install
new file mode 100644
index 000000000000..0ca57d68b69d
--- /dev/null
+++ b/install
@@ -0,0 +1,15 @@
+
+post_install() {
+cat << "EOF"
+
+ Activate lua_plugin in teamspeak: Settings->Plugins.
+ Turn off testmodule in settings of lua_plugin. It is not necessary.
+ You can configure font, color, position of overlay by
+ editing /opt/teamspeak3/plugins/lua_plugin/osd/init.lua
+
+EOF
+}
+
+post_upgrade() {
+ post_install
+}