summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-11-17 14:17:01 +0100
committerChristian Hesse2015-11-17 14:17:01 +0100
commit270b7d1c52968830aeeaf1de32b45840500156af (patch)
tree7a24aeaed5511b66f0b5ffa1e855c342abf4f47e
downloadaur-270b7d1c52968830aeeaf1de32b45840500156af.tar.gz
initial import of teamviewer-beta 11.0.50678-1
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD57
-rw-r--r--teamviewer.install14
3 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d921954192c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = teamviewer-beta
+ pkgdesc = All-In-One Software for Remote Support and Online Meetings - beta version
+ pkgver = 11.0.50678
+ pkgrel = 1
+ url = http://www.teamviewer.com
+ install = teamviewer.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ provides = teamviewer
+ conflicts = teamviewer
+ options = !strip
+ source_i686 = http://download.teamviewer.com/download/version_11x/teamviewer_11.0.50678_i386.deb
+ depends_i686 = lib32-gcc-libs
+ depends_i686 = lib32-alsa-lib
+ depends_i686 = lib32-freetype2
+ depends_i686 = lib32-libice
+ depends_i686 = lib32-libsm
+ depends_i686 = lib32-libxdamage
+ depends_i686 = lib32-libxinerama
+ depends_i686 = lib32-libxrandr
+ depends_i686 = lib32-libxtst
+ depends_i686 = lib32-zlib
+ sha256sums_i686 = 1d2a4f3cb4516dda831dee841d5c024bd49a85d31e0c0b63020e433558ce9ce0
+ source_x86_64 = http://download.teamviewer.com/download/version_11x/teamviewer_11.0.50678_amd64.deb
+ depends_x86_64 = gcc-libs
+ depends_x86_64 = alsa-lib
+ depends_x86_64 = freetype2
+ depends_x86_64 = libice
+ depends_x86_64 = libsm
+ depends_x86_64 = libxdamage
+ depends_x86_64 = libxinerama
+ depends_x86_64 = libxrandr
+ depends_x86_64 = libxtst
+ depends_x86_64 = zlib
+ sha256sums_x86_64 = b43a953ada4aef5228f0a49c75593beb997b256b5e24e525eb5cff56d7ad9abf
+
+pkgname = teamviewer-beta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9dd09c4d03bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Yakir Sitbon <kingyes1 at gmail dot com>
+# Contributor: Alucryd <alucryd at gmail dot com>
+# Contributor: Stas S <whats_up at tut dot by>
+# Contributor: Hilinus <itahilinus at hotmail dot it>
+
+pkgname=teamviewer-beta
+pkgver=11.0.50678
+pkgrel=1
+pkgdesc="All-In-One Software for Remote Support and Online Meetings - beta version"
+arch=('i686' 'x86_64')
+url="http://www.teamviewer.com"
+license=('custom')
+options=('!strip')
+provides=('teamviewer')
+conflicts=('teamviewer')
+depends_x86_64=('gcc-libs'
+ 'alsa-lib'
+ 'freetype2'
+ 'libice'
+ 'libsm'
+ 'libxdamage'
+ 'libxinerama'
+ 'libxrandr'
+ 'libxtst'
+ 'zlib')
+depends_i686=('lib32-gcc-libs'
+ 'lib32-alsa-lib'
+ 'lib32-freetype2'
+ 'lib32-libice'
+ 'lib32-libsm'
+ 'lib32-libxdamage'
+ 'lib32-libxinerama'
+ 'lib32-libxrandr'
+ 'lib32-libxtst'
+ 'lib32-zlib')
+install=teamviewer.install
+source_x86_64=("http://download.teamviewer.com/download/version_${pkgver%%.*}x/teamviewer_${pkgver}_amd64.deb")
+source_i686=("http://download.teamviewer.com/download/version_${pkgver%%.*}x/teamviewer_${pkgver}_i386.deb")
+sha256sums_x86_64=('b43a953ada4aef5228f0a49c75593beb997b256b5e24e525eb5cff56d7ad9abf')
+sha256sums_i686=('1d2a4f3cb4516dda831dee841d5c024bd49a85d31e0c0b63020e433558ce9ce0')
+
+prepare() {
+ tar -xf data.tar.bz2
+}
+
+package() {
+ # Install
+ cp -dr --no-preserve=ownership {etc,opt,usr,var} "${pkgdir}"/
+
+ # Additional files
+ rm "${pkgdir}"/opt/teamviewer/tv_bin/xdg-utils/xdg-email
+ install -D -m0644 "${pkgdir}"/opt/teamviewer/tv_bin/script/teamviewerd.service "${pkgdir}"/usr/lib/systemd/system/teamviewerd.service
+ install -d -m0755 "${pkgdir}"/usr/{share/applications,share/licenses/teamviewer}
+ ln -s /opt/teamviewer/tv_bin/desktop/teamviewer-teamviewer${pkgver%%.*}.desktop "${pkgdir}"/usr/share/applications/teamviewer.desktop
+ ln -s /opt/teamviewer/License.txt "${pkgdir}"/usr/share/licenses/teamviewer/LICENSE
+}
+
diff --git a/teamviewer.install b/teamviewer.install
new file mode 100644
index 000000000000..49abca3a723d
--- /dev/null
+++ b/teamviewer.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo "The Teamviewer daemon must be running for Teamviewer to work."
+ echo "Execute 'systemctl enable teamviewerd' in a terminal."
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ rm -rf /opt/teamviewer
+}
+
+# vim: ts=2 sw=2 et: