summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-05-05 04:36:42 +0200
committerMarcell Meszaros2022-05-07 00:27:47 +0200
commit7f2d6a423a2837cb5f4f78fd1646303b5f61996b (patch)
tree5eedf6def710792bcd60c3282ab1605653d2807f
parentc271dc0ed4f58a9229a00bd175361dab923c1321 (diff)
downloadaur-7f2d6a423a2837cb5f4f78fd1646303b5f61996b.tar.gz
updpkg 15.29.4
-rw-r--r--.SRCINFO49
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD78
3 files changed, 70 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6b3da7cdd62..393bac52f841 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,33 @@
pkgbase = teamviewer-quicksupport
pkgdesc = Teamviewer Quicksupport - All-In-One Software for Remote Support and Online Meetings
- pkgver = 11.0.95210
- pkgrel = 2
+ pkgver = 15.29.4
+ pkgrel = 1
url = http://www.teamviewer.com/
- arch = i686
arch = x86_64
license = custom
depends = bash
+ depends = dbus
+ depends = gcc-libs
+ depends = glib2
+ depends = glibc
+ depends = hicolor-icon-theme
+ depends = libcap
+ depends = libgcrypt
+ depends = libgpg-error
+ depends = libglvnd
+ depends = libx11
+ depends = libxcb
+ depends = lz4
+ depends = qt5-quickcontrols
+ depends = qt5-x11extras
+ depends = pcre
+ depends = systemd-libs
+ depends = xz
+ depends = zlib
+ depends = zstd
conflicts = teamviewer
options = !strip
- source = teamviewer_qs-11.0.95210.tar.gz::http://download.teamviewer.com/download/version_11x/teamviewer_qs.tar.gz
- sha256sums = 57e4c5c40315e52307a2737021d6dfd02b0c8e01dfedecb805a0cdff7d09e323
- depends_i686 = alsa-lib
- depends_i686 = dbus
- depends_i686 = fontconfig
- depends_i686 = libpng12
- depends_i686 = libsm
- depends_i686 = libxdamage
- depends_i686 = libxinerama
- depends_i686 = libxrandr
- depends_i686 = libxrender
- depends_i686 = libxtst
- depends_x86_64 = lib32-alsa-lib
- depends_x86_64 = lib32-dbus
- depends_x86_64 = lib32-fontconfig
- depends_x86_64 = lib32-libpng12
- depends_x86_64 = lib32-libsm
- depends_x86_64 = lib32-libxdamage
- depends_x86_64 = lib32-libxinerama
- depends_x86_64 = lib32-libxrandr
- depends_x86_64 = lib32-libxrender
- depends_x86_64 = lib32-libxtst
+ source = teamviewer_qs-15.29.4.tar.gz::https://download.teamviewer.com/download/teamviewer_qs.tar.gz
+ sha256sums = f90eb384e8e2b040cc3c93fcdc130688b5b41127b3857b344e9c937ccf381807
pkgname = teamviewer-quicksupport
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 8d56028a4608..081e54e87c67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,42 @@
# Maintainer: Christian Hesse <mail@eworm.de>
pkgname=teamviewer-quicksupport
-pkgver=11.0.95210
-_pkgver_major=${pkgver%%.*}
-pkgrel=2
+pkgver=15.29.4
+pkgrel=1
pkgdesc='Teamviewer Quicksupport - All-In-One Software for Remote Support and Online Meetings'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://www.teamviewer.com/'
-depends=('bash')
options=('!strip')
-depends_x86_64=(
- 'lib32-alsa-lib'
- 'lib32-dbus'
- 'lib32-fontconfig'
- 'lib32-libpng12'
- 'lib32-libsm'
- 'lib32-libxdamage'
- 'lib32-libxinerama'
- 'lib32-libxrandr'
- 'lib32-libxrender'
- 'lib32-libxtst')
-depends_i686=(
- 'alsa-lib'
+depends=(
+ 'bash'
'dbus'
- 'fontconfig'
- 'libpng12'
- 'libsm'
- 'libxdamage'
- 'libxinerama'
- 'libxrandr'
- 'libxrender'
- 'libxtst')
+ 'gcc-libs'
+ 'glib2'
+ 'glibc'
+ 'hicolor-icon-theme'
+ 'libcap'
+ 'libgcrypt'
+ 'libgpg-error'
+ 'libglvnd'
+ 'libx11'
+ 'libxcb'
+ 'lz4'
+ 'qt5-quickcontrols'
+ 'qt5-x11extras'
+ 'pcre'
+ 'systemd-libs'
+ 'xz'
+ 'zlib'
+ 'zstd')
conflicts=('teamviewer')
license=('custom')
-source=("teamviewer_qs-${pkgver}.tar.gz::http://download.teamviewer.com/download/version_${_pkgver_major}x/teamviewer_qs.tar.gz")
-sha256sums=('57e4c5c40315e52307a2737021d6dfd02b0c8e01dfedecb805a0cdff7d09e323')
+source=("teamviewer_qs-${pkgver}.tar.gz::https://download.teamviewer.com/download/teamviewer_qs.tar.gz")
+sha256sums=('f90eb384e8e2b040cc3c93fcdc130688b5b41127b3857b344e9c937ccf381807')
prepare() {
cd teamviewerqs/
- if ! grep -q "^TV_VERSION=\"${pkgver/\~/ }\"\$" tv_bin/script/tvw_config; then
+ if ! grep -q "^TV_VERSION='${pkgver}'\$" tv_bin/script/tvw_config; then
msg "Version does not match!"
exit 1
fi
@@ -49,7 +46,7 @@ prepare() {
cd tv_bin/
- bsdtar xf archive.tar.xz
+ tar -xf archive.tar.xz
rm -rf RTlib/
rm -f xdg-utils/xdg-email
@@ -61,15 +58,22 @@ build() {
# set correct pathes in desktop file
sed -e "/^Exec=/c Exec=/opt/teamviewer/tv_bin/script/teamviewer" \
- -e "/^Icon=/c Icon=/opt/teamviewer/tv_bin/desktop/teamviewer.png" \
+ -e "/^Icon=/c Icon=teamviewer.png" \
< tv_bin/desktop/teamviewer.desktop.template \
> "${srcdir}"/teamviewer.desktop
+ rm -f tv_bin/desktop/teamviewer.desktop.template
- # duh?!
- sed -i '/UpdateBinaries/s/^/#/' tv_bin/script/tvw_main
+ # Don't try to extract tar archive during application runtime
+ sed -i '/ExtractBinaries/s/^/#/' tv_bin/script/tvw_main
+
+ # Don't clear LD_PRELOAD before running application
+ sed -i '/ CheckEnvironment/s/^/#/' tv_bin/script/tvw_main
# Yes, this is QuickSupport... But we want to use user's home directory.
sed -i '/function isInstalledTV/,/^}$/c function isInstalledTV() { return 0; }' tv_bin/script/tvw_aux
+
+ # Fix check for Qt5 XCB in libcheck script
+ sed -i '/local -r qtxcb/c local -r qtxcb="/usr/lib/qt/plugins/platforms/libqxcb.so"' tv_bin/script/tvw_libcheck
}
package() {
@@ -78,16 +82,20 @@ package() {
install -d -m0755 "${pkgdir}"/opt/teamviewer/
cp -a --no-preserve=ownership * "${pkgdir}"/opt/teamviewer/
- install -d -m0755 "${pkgdir}"/usr/{bin,share/applications,share/licenses/${pkgname}}
+ install -d -m0755 "${pkgdir}"/usr/{bin,share/applications,share/icons/hicolor,share/licenses/${pkgname}}
ln -s /opt/teamviewer/tv_bin/script/teamviewer "${pkgdir}"/usr/bin/teamviewer
ln -s /opt/teamviewer/tv_bin/script/teamviewer "${pkgdir}"/usr/bin/quicksupport
ln -s /opt/teamviewer/doc/License.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ ln -s /opt/teamviewer/doc/{EULA_en.txt,DPA_en.txt} "${pkgdir}"/usr/share/licenses/${pkgname}/
install -D -m0755 "${srcdir}"/teamviewer.desktop "${pkgdir}"/usr/share/applications/teamviewer.desktop
+
+ for iconsize in 16 20 24 32 48 256; do
+ install -Dm644 "tv_bin/desktop/teamviewer_${iconsize}.png" "${pkgdir}/usr/share/icons/hicolor/${iconsize}x${iconsize}/apps/teamviewer.png"
+ done
install -d -m1777 "${pkgdir}"/var/lib/teamviewer
ln -s /var/lib/teamviewer "${pkgdir}"/opt/teamviewer/config
install -d -m1777 "${pkgdir}"/var/log/teamviewer
ln -s /var/log/teamviewer "${pkgdir}"/opt/teamviewer/logfiles
}
-