summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122022-01-02 09:18:06 +0100
committerwillemw122022-01-02 10:01:44 +0100
commita0bb7527aa093b3a957f75ac77e99627fcc0f4a6 (patch)
tree9fb40714f5ccf7cb3d852167fcea4b71beafde28
parent00a4ad6f2f40c06606ebc6bd91043dc5a9326f6f (diff)
downloadaur-a0bb7527aa093b3a957f75ac77e99627fcc0f4a6.tar.gz
Run make jobs sequentially (make -j1)
See tedPackage/arch-PKGBUILD.in
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5866523ed16..4254ed82e8e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ted
pkgdesc = Lightweight RTF text processor
pkgver = 2.23
- pkgrel = 10
+ pkgrel = 11
url = https://www.nllgg.nl/Ted/
arch = x86_64
license = GPL
@@ -17,7 +17,7 @@ pkgbase = ted
depends = libxpm
depends = pcre
depends = zlib
- options = !buildflags
+ options = !makeflags
source = https://ftp.nluug.nl/pub/editors/ted/ted-2.23.src.tar.gz
source = https://ftp.nluug.nl/pub/editors/ted/ted_nl_NL.tar.gz
source = https://ftp.nluug.nl/pub/editors/ted/ted_en_GB.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 012e5af27fe8..6f25358e8342 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
pkgname=ted
pkgver=2.23
-pkgrel=10
+pkgrel=11
pkgdesc="Lightweight RTF text processor"
arch=('x86_64')
url="https://www.nllgg.nl/Ted/"
depends=('freetype2' 'ghostscript' 'gtk2' 'libjpeg' 'libpaper' 'libpng' 'libtiff' 'libxpm' 'pcre' 'zlib')
license=('GPL')
makedepends=('inetutils' 'lsb-release') # hostname and lsb_release commands
-options=(!buildflags)
+options=(!makeflags)
source=(https://ftp.nluug.nl/pub/editors/$pkgname/$pkgname-$pkgver.src.tar.gz
https://ftp.nluug.nl/pub/editors/ted/ted_nl_NL.tar.gz
https://ftp.nluug.nl/pub/editors/ted/ted_en_GB.tar.gz
@@ -65,16 +65,16 @@ md5sums=('4199df0deb82a90450135ec3f2b7d915'
build() {
cd Ted-$pkgver
- make
- make package
+ make -j1
+ make package -j1
}
package() {
- install -dm755 "$pkgdir/usr/share/Ted"
- install -m644 TedDocument-*_*.rtf "$pkgdir/usr/share/Ted/"
+ install -dm755 "$pkgdir/usr/share/Ted"
+ install -m644 TedDocument-*_*.rtf "$pkgdir/usr/share/Ted"
cd Ted-$pkgver/tedPackage
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" make -j1 install
cd "$pkgdir"
for _file in "$srcdir/"ted_*_*.tar.gz; do