summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2016-07-30 08:01:01 -0300
committerRafael Fontenelle2016-07-30 08:01:01 -0300
commit1eccc1800a2421b634ba09b8778a9abd318fc8e5 (patch)
tree4090591502669a946eabe53d71eb5cc29988897a
parent5f17feef95b4f9650f8626b6bb3b7455d7d872e0 (diff)
downloadaur-1eccc1800a2421b634ba09b8778a9abd318fc8e5.tar.gz
Add bam 0.5 compat patch
-rw-r--r--.SRCINFO6
-rw-r--r--0001-updated-build-files-for-bam-0.5.patch49
-rw-r--r--PKGBUILD14
3 files changed, 63 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55973ec7ba9b..f62b0c65c9f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri May 6 15:33:05 UTC 2016
+# Sat Jul 30 10:59:49 UTC 2016
pkgbase = teeworlds-ddnet-git
pkgdesc = A customized version by DDRaceNetwork of this 2D shooting game
- pkgver = 10.0.1.r6578.939f213
+ pkgver = 10.2.1.r6728.3b4381c
pkgrel = 1
url = https://ddnet.tw
arch = i686
@@ -23,7 +23,9 @@ pkgbase = teeworlds-ddnet-git
provides = teeworlds
conflicts = teeworlds
source = teeworlds-ddnet-git::git+https://github.com/ddnet/ddnet
+ source = 0001-updated-build-files-for-bam-0.5.patch
md5sums = SKIP
+ md5sums = caf0f0c06ff54672e12829b1cbedd5f6
source_i686 = https://ddnet.tw/downloads/GraphicsTools-linux_x86.tar.gz
md5sums_i686 = 566354c3b4510b032af7d891381ee711
source_x86_64 = https://ddnet.tw/downloads/GraphicsTools-linux_x86_64.tar.gz
diff --git a/0001-updated-build-files-for-bam-0.5.patch b/0001-updated-build-files-for-bam-0.5.patch
new file mode 100644
index 000000000000..b74031190e10
--- /dev/null
+++ b/0001-updated-build-files-for-bam-0.5.patch
@@ -0,0 +1,49 @@
+From a0388c3ced59db0a9362e1a20a66c9c0fe5269d6 Mon Sep 17 00:00:00 2001
+From: m!nus <minus+github@mnus.de>
+Date: Sun, 19 Jun 2016 00:14:13 +0200
+Subject: [PATCH] updated build files for bam 0.5
+
+changes makes them incompatible with bam 0.4
+---
+ bam.lua | 2 +-
+ configure.lua | 5 ++---
+ 2 files changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/bam.lua b/bam.lua
+index 9daebfb..581987e 100644
+--- a/bam.lua
++++ b/bam.lua
+@@ -1,4 +1,4 @@
+-CheckVersion("0.4")
++CheckVersion("0.5")
+
+ target_family = os.getenv("TARGET_FAMILY")
+ if target_family then
+diff --git a/configure.lua b/configure.lua
+index f06b77d..a4b832f 100644
+--- a/configure.lua
++++ b/configure.lua
+@@ -72,13 +72,13 @@ function NewConfig(on_configured_callback)
+ end
+
+ config.Load = function(self, filename)
+- local options_func = loadfile(filename)
+ local options_table = {}
++ local options_func = loadfile(filename, nil, options_table)
+
+ if not options_func then
+ print("auto configuration")
+ self:Config(filename)
+- options_func = loadfile(filename)
++ options_func = loadfile(filename, nil, options_table)
+ end
+
+ if options_func then
+@@ -86,7 +86,6 @@ function NewConfig(on_configured_callback)
+ for k,v in pairs(self.options) do
+ options_table[v.name] = {}
+ end
+- setfenv(options_func, options_table)
+
+ -- this is to make sure that we get nice error messages when
+ -- someone sets an option that isn't valid.
diff --git a/PKGBUILD b/PKGBUILD
index d94879ffeb3a..05addfdde2b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=teeworlds-ddnet
pkgname=${_name}-git
-pkgver=10.0.1.r6578.939f213
+pkgver=10.2.1.r6728.3b4381c
pkgrel=1
pkgdesc="A customized version by DDRaceNetwork of this 2D shooting game"
arch=('i686' 'x86_64')
@@ -14,10 +14,12 @@ optdepends=('teeworlds-ddnet-skins: more skins for your tee'
'teeworlds-ddnet-maps-git: mainly important for DDNet Server')
provides=('teeworlds')
conflicts=('teeworlds')
-source=("$pkgname::git+https://github.com/ddnet/ddnet")
+source=("$pkgname::git+https://github.com/ddnet/ddnet"
+ '0001-updated-build-files-for-bam-0.5.patch')
source_i686=("https://ddnet.tw/downloads/GraphicsTools-linux_x86.tar.gz")
source_x86_64=("https://ddnet.tw/downloads/GraphicsTools-linux_x86_64.tar.gz")
-md5sums=('SKIP')
+md5sums=('SKIP'
+ 'caf0f0c06ff54672e12829b1cbedd5f6')
md5sums_i686=('566354c3b4510b032af7d891381ee711')
md5sums_x86_64=('fc32ca52ae9be02f68b6c257153dbd37')
@@ -39,7 +41,11 @@ prepare() {
# run DDNet Server with all votes, maps etc. -- no score/ranking, though
gendesk -f -n --pkgname "${_name}_srv" --pkgdesc "DDNet Server" --terminal=true \
--exec='sh -c "cd /usr/share/teeworlds/data && teeworlds-ddnet_srv"' \
- --name 'DDNet Server' --categories 'Game;ArcadeGame'
+ --name 'DDNet Server' --categories 'Game;ArcadeGame'
+
+ # Fixes https://github.com/ddnet/ddnet/issues/506
+ cd $pkgname
+ patch -p1 -i "$srcdir/0001-updated-build-files-for-bam-0.5.patch"
}
build() {