summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2017-07-21 14:16:02 -0300
committerRafael Fontenelle2017-07-21 14:16:02 -0300
commit61dbee0b36ca52901e7ed8bf004fb6f842a00ef3 (patch)
tree13e63fc52801f5778f6b91fe01b25c1e23b648e4
parent0cb199a086f80bce79a1e77b17c75a4fe6956b6d (diff)
downloadaur-61dbee0b36ca52901e7ed8bf004fb6f842a00ef3.tar.gz
Add submodule ddnet-libs
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29e63459ba3e..2371da16c626 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Jul 17 00:14:04 UTC 2017
+# Fri Jul 21 17:15:37 UTC 2017
pkgbase = teeworlds-ddnet-git
pkgdesc = A customized version by DDRaceNetwork of this 2D shooting game
- pkgver = 10.6.7.r4.97fdc8313
+ pkgver = 10.6.7.r17.b8e997f99
pkgrel = 1
url = https://ddnet.tw
arch = i686
@@ -23,9 +23,10 @@ pkgbase = teeworlds-ddnet-git
provides = teeworlds
conflicts = teeworlds
source = teeworlds-ddnet-git::git+https://github.com/ddnet/ddnet
+ source = git+https://github.com/ddnet/ddnet-libs
+ md5sums = SKIP
md5sums = SKIP
source_i686 = https://ddnet.tw/downloads/GraphicsTools-linux_x86.tar.gz
- md5sums_i686 = 566354c3b4510b032af7d891381ee711
source_x86_64 = https://ddnet.tw/downloads/GraphicsTools-linux_x86_64.tar.gz
md5sums_x86_64 = fc32ca52ae9be02f68b6c257153dbd37
diff --git a/PKGBUILD b/PKGBUILD
index 0c08584b1846..668d2db4d4d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=teeworlds-ddnet
pkgname=${_name}-git
-pkgver=10.6.7.r4.97fdc8313
+pkgver=10.6.7.r17.b8e997f99
pkgrel=1
pkgdesc="A customized version by DDRaceNetwork of this 2D shooting game"
arch=('i686' 'x86_64')
@@ -14,11 +14,12 @@ optdepends=('teeworlds-ddnet-skins: more skins for your tee'
'teeworlds-ddnet-maps-git: mainly important for DDNet Server')
provides=('teeworlds')
conflicts=('teeworlds')
-source=("$pkgname::git+https://github.com/ddnet/ddnet")
+source=("$pkgname::git+https://github.com/ddnet/ddnet"
+ "git+https://github.com/ddnet/ddnet-libs")
source_i686=("https://ddnet.tw/downloads/GraphicsTools-linux_x86.tar.gz")
source_x86_64=("https://ddnet.tw/downloads/GraphicsTools-linux_x86_64.tar.gz")
-md5sums=('SKIP')
-md5sums_i686=('566354c3b4510b032af7d891381ee711')
+md5sums=('SKIP' 'SKIP')
+md5sums_x86_64=('fc32ca52ae9be02f68b6c257153dbd37')
md5sums_x86_64=('fc32ca52ae9be02f68b6c257153dbd37')
pkgver() {
@@ -35,7 +36,7 @@ prepare() {
convert "$pkgname/other/icons/DDNet.ico" "$srcdir/$_name.png"
gendesk -f -n --pkgname "$_name" --pkgdesc "$pkgdesc" \
--name 'Teeworlds' --categories 'Game;ArcadeGame'
-
+
# Server
convert "$pkgname/other/icons/DDNet-Server.ico" "$srcdir/${_name}_srv.png"
# This desktop file, combined with 'teeworlds-ddnet-maps-git' pkg will
@@ -43,6 +44,11 @@ prepare() {
gendesk -f -n --pkgname "${_name}_srv" --pkgdesc "DDNet Server" \
--name 'DDNet Server' --categories 'Game;ArcadeGame' --terminal=true \
--exec='sh -c "cd /usr/share/teeworlds/data && teeworlds-ddnet_srv"'
+
+ cd $pkgname
+ git submodule init
+ git config submodule.ddnet-libs.url "$srcdir/ddnet-libs"
+ git submodule update
}
build() {