summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2016-05-05 20:06:25 -0300
committerRafael Fontenelle2016-05-05 20:06:25 -0300
commitad950c2766df9721326f733b073507f9096099b4 (patch)
treee29a89d89460a28eb71875ccc8778d2662463149
parent9afc30a3154743bd67dadfb1be09a53946d1d850 (diff)
downloadaur-ad950c2766df9721326f733b073507f9096099b4.tar.gz
Updated to 10.0.1.r6578.939f213
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD75
2 files changed, 59 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec984f53c232..b54c1dcd78b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,32 @@
+# Generated by mksrcinfo v8
+# Thu May 5 23:05:53 UTC 2016
pkgbase = teeworlds-ddnet-git
- pkgdesc = A customized version by DDRaceNetwork of this 2D shooting game (Git)
- pkgver = 9.0.2.r6228.96f2a38
+ pkgdesc = A customized version by DDRaceNetwork of this 2D shooting game
+ pkgver = 10.0.1.r6578.939f213
pkgrel = 1
- url = http://ddnet.tw
+ url = https://ddnet.tw
arch = i686
arch = x86_64
license = custom
makedepends = git
makedepends = bam
- makedepends = gendesk
makedepends = imagemagick
+ makedepends = gendesk
depends = alsa-lib
depends = glu
- depends = sdl
+ depends = sdl2
depends = freetype2
depends = openssl098
- optdepends = teeworlds-ddnet-skins: extra skins
+ optdepends = teeworlds-ddnet-skins: more skins for your tee
+ optdepends = teeworlds-ddnet-maps-git: mainly important for DDNet Server
provides = teeworlds
- provides = teeworlds-ddnet
- provides = teeworlds-ddnet-skins
conflicts = teeworlds
- conflicts = teeworlds-ddnet-skins
source = teeworlds-ddnet-git::git+https://github.com/ddnet/ddnet
- sha256sums = SKIP
+ md5sums = SKIP
+ source_i686 = https://ddnet.tw/downloads/GraphicsTools-linux_x86.tar.gz
+ md5sums_i686 = 566354c3b4510b032af7d891381ee711
+ source_x86_64 = https://ddnet.tw/downloads/GraphicsTools-linux_x86_64.tar.gz
+ md5sums_x86_64 = fc32ca52ae9be02f68b6c257153dbd37
pkgname = teeworlds-ddnet-git
diff --git a/PKGBUILD b/PKGBUILD
index 7420a3808225..793978f9158c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,25 @@
-# Maintainer: josephgbr <rafael.f.f1@gmail.com>
+# Maintainer: rafaelff <rafaelff@gnome.org>
-pkgname=teeworlds-ddnet-git
_name=teeworlds-ddnet
-pkgver=9.0.2.r6228.96f2a38
+pkgname=${_name}-git
+pkgver=10.0.1.r6578.939f213
pkgrel=1
-pkgdesc="A customized version by DDRaceNetwork of this 2D shooting game (Git)"
+pkgdesc="A customized version by DDRaceNetwork of this 2D shooting game"
arch=('i686' 'x86_64')
-url="http://ddnet.tw"
+url="https://ddnet.tw"
license=('custom')
-depends=('alsa-lib' 'glu' 'sdl' 'freetype2' 'openssl098')
-makedepends=('git' 'bam' 'gendesk' 'imagemagick')
-optdepends=('teeworlds-ddnet-skins: extra skins')
-provides=('teeworlds' 'teeworlds-ddnet' 'teeworlds-ddnet-skins')
-conflicts=('teeworlds' 'teeworlds-ddnet-skins')
-source=($pkgname::git+https://github.com/ddnet/ddnet)
-sha256sums=('SKIP')
+depends=('alsa-lib' 'glu' 'sdl2' 'freetype2' 'openssl098')
+makedepends=('git' 'bam' 'imagemagick' 'gendesk')
+optdepends=('teeworlds-ddnet-skins: more skins for your tee'
+ 'teeworlds-ddnet-maps-git: mainly important for DDNet Server')
+provides=('teeworlds')
+conflicts=('teeworlds')
+source=("$pkgname::git+https://github.com/ddnet/ddnet")
+source_i686=("https://ddnet.tw/downloads/GraphicsTools-linux_x86.tar.gz")
+source_x86_64=("https://ddnet.tw/downloads/GraphicsTools-linux_x86_64.tar.gz")
+md5sums=('SKIP')
+md5sums_i686=('566354c3b4510b032af7d891381ee711')
+md5sums_x86_64=('fc32ca52ae9be02f68b6c257153dbd37')
pkgver() {
cd $pkgname
@@ -23,15 +28,18 @@ pkgver() {
}
prepare() {
- convert "$pkgname/other/icons/DDNet.ico" "$srcdir/$pkgname.png"
- gendesk -f -n --pkgname "$_name" --pkgdesc "$pkgdesc" \
- --name 'Teeworlds' --categories 'Game;ArcadeGame'
-
- # Download latest collection of the Skin Database from DDNet site
- # See: http://ddnet.tw/skins/
- rm -fR database.dir database.zip
- curl -O http://ddnet.tw/skins/zip/database.zip
- unzip -q database.zip
+ # Client
+ convert "$pkgname/other/icons/DDNet.ico" "$srcdir/$_name.png"
+ gendesk -f -n --pkgname "$_name" --pkgdesc "$pkgdesc" \
+ --name 'Teeworlds' --categories 'Game;ArcadeGame'
+
+ # Server
+ convert "$pkgname/other/icons/DDNet-Server.ico" "$srcdir/${_name}_srv.png"
+ # This desktop file, combined with 'teeworlds-ddnet-maps-git' pkg will
+ # run DDNet Server with all votes, maps etc. -- no score/ranking, though
+ gendesk -f -n --pkgname "${_name}_srv" --pkgdesc "DDNet Server" --terminal=true \
+ --exec='sh -c "cd /usr/share/teeworlds/data && teeworlds-ddnet_srv"' \
+ --name 'DDNet Server' --categories 'Game;ArcadeGame'
}
build() {
@@ -41,22 +49,29 @@ build() {
package() {
cd $pkgname
-
- # install binaries
+
+ # Install DDNet client/server binaries
install -Dm755 DDNet "$pkgdir"/usr/bin/teeworlds-ddnet
install -Dm755 DDNet-Server "$pkgdir"/usr/bin/teeworlds-ddnet_srv
- install -Dm755 dilate "$pkgdir"/usr/bin/dilate
+ install -Dm755 config_store "$pkgdir"/usr/bin/ddnet-config_store
+ install -Dm755 config_retrieve "$pkgdir"/usr/bin/ddnet-config_retrieve
+ # Install Graphic Tools binaries
+ install -Dm755 ../dilate "$pkgdir"/usr/bin/dilate
+ install -Dm755 ../tileset_borderadd "$pkgdir"/usr/bin/tileset_borderadd
+ install -Dm755 ../tileset_borderfix "$pkgdir"/usr/bin/tileset_borderfix
+ install -Dm755 ../tileset_borderrem "$pkgdir"/usr/bin/tileset_borderrem
+ install -Dm755 ../tileset_borderset "$pkgdir"/usr/bin/tileset_borderset
# Install data files
mkdir -p "$pkgdir"/usr/share/teeworlds/data
cp -r data/* "$pkgdir"/usr/share/teeworlds/data
- # Install skins provided by Skins Database
- cp "$srcdir"/database.dir/* "$pkgdir"/usr/share/teeworlds/data/skins/
-
- install -Dm644 "$srcdir/$_name.desktop" "$pkgdir/usr/share/applications/$_name.desktop"
- install -Dm644 "$srcdir/$pkgname-0.png" "$pkgdir/usr/share/pixmaps/$_name.png"
+ # Install desktop and icon files
+ install -Dm644 ../teeworlds-ddnet.desktop "$pkgdir"/usr/share/applications/teeworlds-ddnet.desktop
+ install -Dm644 ../teeworlds-ddnet_srv.desktop "$pkgdir"/usr/share/applications/teeworlds-ddnet_srv.desktop
+ install -Dm644 ../teeworlds-ddnet-5.png "$pkgdir"/usr/share/pixmaps/teeworlds-ddnet.png
+ install -Dm644 ../teeworlds-ddnet_srv-8.png "$pkgdir"/usr/share/pixmaps/teeworlds-ddnet_srv.png
# Install license files
- install -Dm644 "license.txt" "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+ install -Dm644 license.txt "$pkgdir"/usr/share/licenses/$pkgname/license.txt
}