summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2021-05-10 00:31:34 -0300
committerRafael Fontenelle2021-05-10 00:31:34 -0300
commit1113eb4f4a75aa0a12284f0c5c9cc074d7e3912a (patch)
treec3fc86b4f12a3ee3ceed69630071a0577557f9ab
parent780b2cbbc3a8af32dacd0ad6119cd1f81c072591 (diff)
downloadaur-1113eb4f4a75aa0a12284f0c5c9cc074d7e3912a.tar.gz
Update to 0.7.5
- move bam to cmake with ninja - add check() function - add wavpack, openssl and gtest - remove mesa and gcc-libs (already satisfied) - fix icon installation (use identify instead of file binary)
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD51
2 files changed, 31 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b09a15ed02b1..c48e2be61b1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
pkgbase = teeworlds-git
pkgdesc = Multiplayer 2D shooter
- pkgver = 0.7.3.4706.65c1d46f5
+ pkgver = 0.7.5.5677.d8a4c0e2b
pkgrel = 1
url = https://teeworlds.com
arch = x86_64
license = custom
makedepends = python
makedepends = git
- makedepends = bam
+ makedepends = cmake
+ makedepends = ninja
makedepends = imagemagick
+ makedepends = gtest
depends = alsa-lib
depends = glu
- depends = mesa
- depends = gcc-libs
depends = sdl2
depends = freetype2
+ depends = pnglite
+ depends = wavpack
+ depends = openssl
provides = teeworlds
conflicts = teeworlds
source = git+https://github.com/teeworlds/teeworlds.git
diff --git a/PKGBUILD b/PKGBUILD
index b2a821f9ac5d..75e1a53eeb9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
pkgname=teeworlds-git
-pkgver=0.7.3.4706.65c1d46f5
+pkgver=0.7.5.5677.d8a4c0e2b
pkgrel=1
-pkgdesc='Multiplayer 2D shooter'
+pkgdesc='Fast-paced multiplayer 2D shooter game'
arch=('x86_64')
url="https://teeworlds.com"
-license=('custom')
-depends=('alsa-lib' 'glu' 'mesa' 'gcc-libs' 'sdl2' 'freetype2')
-makedepends=('python' 'git' 'bam' 'imagemagick')
+license=('custom' 'CCPL:by-nc-sa')
+depends=('alsa-lib' 'glu' 'sdl2' 'freetype2' 'pnglite' 'wavpack' 'openssl')
+makedepends=('python' 'git' 'cmake' 'ninja' 'imagemagick' 'gtest')
provides=('teeworlds')
conflicts=('teeworlds')
source=('git+https://github.com/teeworlds/teeworlds.git'
@@ -36,33 +36,30 @@ prepare() {
}
build() {
- cd teeworlds
- bam client server
+ mkdir -p build
+ cd build
+ cmake ../teeworlds \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -GNinja
+ ninja
+}
+
+check() {
+ ninja run_tests -C build
}
package() {
- cd teeworlds
+ DESTDIR="$pkgdir" ninja install -C build
- install -dm755 "$pkgdir"/usr/bin \
- "$pkgdir"/usr/share/{applications,metainfo} \
- "$pkgdir"/usr/share/{licenses/teeworlds,teeworlds/data}
-
- # Install data files
- cp -r datasrc/* "$pkgdir"/usr/share/teeworlds/data
-
- install -m755 build/$CARCH/debug/teeworlds "$pkgdir"/usr/bin/
- install -m755 build/$CARCH/debug/teeworlds_srv "$pkgdir"/usr/bin/
-
- install -m644 license.txt "$pkgdir/usr/share/licenses/teeworlds/"
- install -m644 other/teeworlds.appdata.xml "$pkgdir/usr/share/metainfo/"
- install -m644 other/teeworlds.desktop "$pkgdir/usr/share/applications/"
+ install -dm755 "$pkgdir/usr/share/"{licenses/$pkgname,metainfo,applications}
+ install -m644 teeworlds/license.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -m644 teeworlds/other/teeworlds.appdata.xml -t "$pkgdir/usr/share/metainfo/"
+ install -m644 teeworlds/other/teeworlds.desktop -t "$pkgdir/usr/share/applications/"
# Install client and server icon files according to the image size
- for num in 0 1 2 3 4 5; do
- _s=$(file "$srcdir/teeworlds-$num.png" | cut -d' ' -f5)
- [[ $_s == ?(-)+([0-9]) ]] # is it a number?
- _s=${_s}x${_s}
- install -Dm644 "$srcdir/teeworlds-$num.png" \
- "$pkgdir/usr/share/icons/hicolor/$_s/apps/teeworlds.png"
+ for _icon in $(ls -1 "$srcdir"/teeworlds-*.png); do
+ _s=$(identify $_icon | awk '{print $3}')
+ [[ $_s =~ ([0-9])+x([0-9])+ ]] || ( echo "Not a NUMxNUM: '$_s'"; exit 1; )
+ install -Dm644 "$_icon" "$pkgdir/usr/share/icons/hicolor/$_s/apps/teeworlds.png"
done
}