summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsamedamci2020-05-25 22:10:18 +0200
committersamedamci2020-05-25 22:10:18 +0200
commit56c397ed0aa12c03152146d3ab0adf8986e6aafb (patch)
treefd363193d2e140d75b482a24e1f35c9bac6c9e4e
downloadaur-56c397ed0aa12c03152146d3ab0adf8986e6aafb.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ccbfcefda126
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tekstowo-git
+ pkgdesc = Find lyrics and translation for a song using tekstowo.pl
+ pkgver = 0.1.r0.54eb87b
+ pkgrel = 1
+ url = https://github.com/samedamci/tekstowo
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python3
+ provides = tekstowo
+ conflicts = tekstowo
+ replaces = tekstowo
+ source = git+https://github.com/samedamci/tekstowo.git
+ md5sums = SKIP
+
+pkgname = tekstowo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8eaaeb2d7ea0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: samedamci <samedamci@disroot.org>
+pkgname=tekstowo-git
+pkgver=0.1.r0.54eb87b
+pkgrel=1
+pkgdesc="Find lyrics and translation for a song using tekstowo.pl"
+arch=('any')
+url="https://github.com/samedamci/tekstowo"
+license=('MIT')
+depends=('python3')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=("${pkgname%-git}")
+source=("git+https://github.com/samedamci/${pkgname%-git}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g' | cut -b 2-)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}" || exit 1
+ local doc_path="$pkgdir/usr/share/doc/${pkgname%-git}"
+
+ install -Dm755 "tekstowo.py" "$pkgdir/usr/bin/${pkgname%-git}"
+
+ install -Dm755 -d "$pkgdir/usr/share/doc/${pkgname%-git}"
+
+ install -Dm644 "README.md" "${doc_path}/README.md"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
+}