summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobosky2018-12-16 12:50:28 +0800
committerRobosky2018-12-16 12:50:28 +0800
commit2773f58fb875c2005d7afc327c0f20d233c6a901 (patch)
treebe813b004db1484123bcc023b4ab93446b16ec85
downloadaur-2773f58fb875c2005d7afc327c0f20d233c6a901.tar.gz
init
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eaef33031570
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = tela-icon-theme-git
+ pkgdesc = A flat colorful Design icon theme.
+ pkgver = 7.c7c6739
+ pkgrel = 1
+ url = https://github.com/vinceliuice/Tela-icon-theme
+ arch = any
+ license = GPL3
+ source = git+https://github.com/vinceliuice/Tela-icon-theme.git
+ sha256sums = SKIP
+
+pkgname = tela-icon-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fb72e8b1d30
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Robosky <fangyuhao0612@gmail.com>
+
+pkgname=tela-icon-theme-git
+_gitname=Tela-icon-theme
+pkgdesc="A flat colorful Design icon theme."
+pkgver=7.c7c6739
+pkgrel=1
+arch=('any')
+url="https://github.com/vinceliuice/Tela-icon-theme"
+license=('GPL3')
+source=("git+https://github.com/vinceliuice/Tela-icon-theme.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ install -dm755 "${pkgdir}/"usr/share/icons/Tela
+
+ cd Tela
+ cp -r . "${pkgdir}/"usr/share/icons/Tela
+}
+