summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-11-06 09:09:41 -0700
committerMark Wagie2022-11-06 09:09:41 -0700
commitb9c305231e073b885115ebcd66cf851377464de6 (patch)
treeb7623b8ef390aa6744eec05d5bd4d47de11de08a
parenta841856ceaf756fdf3aaf8dc41221230d27e6c21 (diff)
downloadaur-b9c305231e073b885115ebcd66cf851377464de6.tar.gz
Disable running gtk-update-icon-cache
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9963dbeed5e0..a00e3bf48eec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tela-icon-theme-git
pkgdesc = A flat colorful design icon theme.
- pkgver = 2021.12.25.r4.g651b107f
+ pkgver = 2022.08.28.r32.geb13dc39
pkgrel = 1
url = https://www.pling.com/p/1279924
arch = any
@@ -11,7 +11,7 @@ pkgbase = tela-icon-theme-git
provides = tela-icon-theme
conflicts = tela-icon-theme
options = !strip
- source = tela-icon-theme::git+https://github.com/vinceliuice/Tela-icon-theme.git
+ source = git+https://github.com/vinceliuice/Tela-icon-theme.git
sha256sums = SKIP
pkgname = tela-icon-theme-git
diff --git a/PKGBUILD b/PKGBUILD
index 93f5c0fffa84..3aaaae57228f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Robosky <fangyuhao0612@gmail.com>
pkgname=tela-icon-theme-git
-pkgver=2021.12.25.r4.g651b107f
+pkgver=2022.08.28.r32.geb13dc39
pkgrel=1
pkgdesc="A flat colorful design icon theme."
arch=('any')
@@ -12,16 +12,23 @@ makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
options=('!strip')
-source=("${pkgname%-git}::git+https://github.com/vinceliuice/Tela-icon-theme.git")
+source=('git+https://github.com/vinceliuice/Tela-icon-theme.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/Tela-icon-theme"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/Tela-icon-theme"
+
+ # Disable running gtk-update-icon-cache
+ sed -i '/gtk-update-icon-cache/d' install.sh
+}
+
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/Tela-icon-theme"
install -d "$pkgdir/usr/share/icons"
./install.sh -a -d "$pkgdir/usr/share/icons"
}