summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRubixDev2022-06-09 18:03:07 +0200
committerRubixDev2022-06-09 18:03:07 +0200
commit66a3e63841635052ff086bd4150b6950eea05571 (patch)
tree2feb34196d72ec0953640075d21bc91a8ced3fdb
downloadaur-66a3e63841635052ff086bd4150b6950eea05571.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f06084c17593
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tela-icon-theme-green-git
+ pkgdesc = A flat colorful design icon theme (only green variant)
+ pkgver = 2022.02.21.r14.g47b82d4c
+ pkgrel = 1
+ url = https://github.com/vinceliuice/Tela-icon-theme
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ conflicts = tela-icon-theme
+ options = !strip
+ source = tela-icon-theme::git+https://github.com/vinceliuice/Tela-icon-theme.git
+ sha256sums = SKIP
+
+pkgname = tela-icon-theme-green-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..791b5731d104
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: RubixDev <silas dot groh at t-online dot de>
+_color=green
+pkgname=tela-icon-theme-$_color-git
+pkgver=2022.02.21.r14.g47b82d4c
+pkgrel=1
+pkgdesc="A flat colorful design icon theme (only $_color variant)"
+arch=('any')
+url="https://github.com/vinceliuice/Tela-icon-theme"
+license=('GPL3')
+depends=('hicolor-icon-theme' 'gtk-update-icon-cache')
+makedepends=('git')
+conflicts=("tela-icon-theme")
+options=('!strip')
+source=("${pkgname%-$_color-git}::git+https://github.com/vinceliuice/Tela-icon-theme.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-$_color-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/${pkgname%-$_color-git}"
+ install -d "$pkgdir/usr/share/icons"
+ ./install.sh -d "$pkgdir/usr/share/icons" $_color
+}
+