summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRubixDev2022-06-05 21:58:52 +0200
committerRubixDev2022-06-05 21:58:52 +0200
commitec36f5cfe6ab1d09366aa9eabe378405535fb5ae (patch)
treecb670cc864f80a6934a45a2a77ef001998a5ead3
downloadaur-ec36f5cfe6ab1d09366aa9eabe378405535fb5ae.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c637b654a02d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tela-icon-theme-purple-git
+ pkgdesc = A flat colorful design icon theme (only purple variant)
+ pkgver = 2022.02.21.r14.g47b82d4c
+ pkgrel = 1
+ url = https://github.com/vinceliuice/Tela-icon-theme
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ conflicts = tela-icon-theme
+ options = !strip
+ source = tela-icon-theme-purple::git+https://github.com/vinceliuice/Tela-icon-theme.git
+ sha256sums = SKIP
+
+pkgname = tela-icon-theme-purple-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05c055aa8b83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: RubixDev <silas dot groh at t-online dot de>
+_color=purple
+pkgname=tela-icon-theme-$_color-git
+pkgver=2022.02.21.r14.g47b82d4c
+pkgrel=1
+pkgdesc="A flat colorful design icon theme (only purple variant)"
+arch=('any')
+url="https://github.com/vinceliuice/Tela-icon-theme"
+license=('GPL3')
+depends=('hicolor-icon-theme' 'gtk-update-icon-cache')
+makedepends=('git')
+conflicts=("tela-icon-theme")
+options=('!strip')
+source=("${pkgname%-git}::git+https://github.com/vinceliuice/Tela-icon-theme.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -d "$pkgdir/usr/share/icons"
+ ./install.sh -d "$pkgdir/usr/share/icons" $_color
+}
+