summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmanuele 'Lele aka eldios' Calo2018-08-22 16:33:16 +0200
committerEmanuele 'Lele aka eldios' Calo2018-08-22 16:33:16 +0200
commit365e31c957fd33f5efd8a7fcc5e4e33dd65f7d25 (patch)
treea96a4f51b03022c2b7e4f757f74f180d61559339
parent75e55f5730c2c7d50a28efbc51921a35c0d10270 (diff)
downloadaur-365e31c957fd33f5efd8a7fcc5e4e33dd65f7d25.tar.gz
Updated to 0.4.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 22 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eae9f45ec5d8..810988aec9ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,17 @@
pkgbase = teleconsole-bin
pkgdesc = Command line tool to share your UNIX terminal and forward local TCP ports to people you trust.
- pkgver = 0.3.1
+ pkgver = 0.4.0
pkgrel = 1
url = https://github.com/gravitational/teleconsole/
arch = x86_64
+ arch = arm
license = Apache
depends = glibc
- source = https://github.com/gravitational/teleconsole/releases/download/0.3.1/teleconsole-v0.3.1-linux-amd64.tar.gz
- sha256sums = bcc08d8ea2c8a7ad01fb7a336c5f9ebd75b7b2624db9b0cc88c5f60b5c3e533b
+ options = !strip
+ source_x86_64 = https://github.com/gravitational/teleconsole/releases/download/0.4.0/teleconsole-v0.4.0-linux-amd64.tar.gz
+ sha256sums_x86_64 = f444828117f2aa8555ec33abd03ef1caadbc72d0f5bc273c48334c55318aafeb
+ source_arm = https://github.com/gravitational/teleconsole/releases/download/0.4.0/teleconsole-v0.4.0-linux-arm.tar.gz
+ sha256sums_arm = f39244db0d04ee42efb9e6a0a98a861b69e448b10b4eecd52923d1c870337ff5
pkgname = teleconsole-bin
diff --git a/PKGBUILD b/PKGBUILD
index 5471e1aab3f6..bfb2cffd8cf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,26 @@
# Maintainer: Emanuele 'Lele aka eldios' Calo' <xeldiosx@gmail.com>
pkgname=teleconsole-bin
-pkgver=0.3.1
+pkgver=0.4.0
pkgrel=1
pkgdesc="Command line tool to share your UNIX terminal and forward local TCP ports to people you trust."
-arch=('x86_64')
+arch=('x86_64' 'arm')
url="https://github.com/gravitational/teleconsole/"
license=('Apache')
depends=('glibc')
-source=("https://github.com/gravitational/teleconsole/releases/download/${pkgver}/teleconsole-v${pkgver}-linux-amd64.tar.gz")
-sha256sums=('bcc08d8ea2c8a7ad01fb7a336c5f9ebd75b7b2624db9b0cc88c5f60b5c3e533b')
+source_x86_64=(
+ "https://github.com/gravitational/teleconsole/releases/download/${pkgver}/teleconsole-v${pkgver}-linux-amd64.tar.gz"
+ )
+sha256sums_x86_64=(
+ 'f444828117f2aa8555ec33abd03ef1caadbc72d0f5bc273c48334c55318aafeb'
+ )
+source_arm=(
+ "https://github.com/gravitational/teleconsole/releases/download/${pkgver}/teleconsole-v${pkgver}-linux-arm.tar.gz"
+ )
+sha256sums_arm=(
+ 'f39244db0d04ee42efb9e6a0a98a861b69e448b10b4eecd52923d1c870337ff5'
+ )
+options=(!strip)
package() {
mkdir -p "${pkgdir}/usr/bin"