summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmanuele 'Lele aka eldios' Calo2017-06-16 03:48:27 +0200
committerEmanuele 'Lele aka eldios' Calo2017-06-16 03:48:27 +0200
commit75e55f5730c2c7d50a28efbc51921a35c0d10270 (patch)
treef4d0c5ae5f8e8c4acc2026d465bab8d52e02037b
downloadaur-75e55f5730c2c7d50a28efbc51921a35c0d10270.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
3 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eae9f45ec5d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = teleconsole-bin
+ pkgdesc = Command line tool to share your UNIX terminal and forward local TCP ports to people you trust.
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/gravitational/teleconsole/
+ arch = x86_64
+ license = Apache
+ depends = glibc
+ source = https://github.com/gravitational/teleconsole/releases/download/0.3.1/teleconsole-v0.3.1-linux-amd64.tar.gz
+ sha256sums = bcc08d8ea2c8a7ad01fb7a336c5f9ebd75b7b2624db9b0cc88c5f60b5c3e533b
+
+pkgname = teleconsole-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..93f5d9f2777e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5471e1aab3f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Emanuele 'Lele aka eldios' Calo' <xeldiosx@gmail.com>
+
+pkgname=teleconsole-bin
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="Command line tool to share your UNIX terminal and forward local TCP ports to people you trust."
+arch=('x86_64')
+url="https://github.com/gravitational/teleconsole/"
+license=('Apache')
+depends=('glibc')
+source=("https://github.com/gravitational/teleconsole/releases/download/${pkgver}/teleconsole-v${pkgver}-linux-amd64.tar.gz")
+sha256sums=('bcc08d8ea2c8a7ad01fb7a336c5f9ebd75b7b2624db9b0cc88c5f60b5c3e533b')
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ install -Dm755 -t "$pkgdir/usr/bin" teleconsole
+ # no man pages, docs or web assets in release tarball
+}