summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam S Levy2017-08-19 09:10:02 -0800
committerAdam S Levy2017-08-19 09:10:02 -0800
commita6646e07217ee362d04b76ca2766a61aece84b3c (patch)
tree2db9a9a804255faeb11f40990ebd63a020194d67
parent1f94e2e9413c6deb5a0d799a71f8bab76d63ef3b (diff)
downloadaur-a6646e07217ee362d04b76ca2766a61aece84b3c.tar.gz
Added quotes to paths in PKGBUILD to allow for spaces in build dir
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD30
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e332a9137746..653c602ba8f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = telegraf
pkgdesc = Server-level metric gathering agent for InfluxDB
pkgver = 1.3.5
- pkgrel = 1
+ pkgrel = 2
url = http://influxdb.org/
install = telegraf.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 6d7750b4bbb1..958d7ccbafd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname='telegraf'
pkgver='1.3.5'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Server-level metric gathering agent for InfluxDB'
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url='http://influxdb.org/'
@@ -26,8 +26,8 @@ build()
export GOPATH="$srcdir"
export GOBIN="$GOPATH/bin"
export PATH="$GOBIN:$PATH"
- mkdir -p $GOPATH/src/github.com/influxdata
- mv -f $srcdir/telegraf $GOPATH/src/github.com/influxdata/
+ mkdir -p "$GOPATH/src/github.com/influxdata"
+ mv -f "$srcdir/telegraf" "$GOPATH/src/github.com/influxdata/"
cd "$GOPATH/src/github.com/influxdata/telegraf"
@@ -44,16 +44,16 @@ build()
package()
{
- cd $srcdir
- install -Dm644 telegraf.sysusers $pkgdir/usr/lib/sysusers.d/telegraf.conf
- install -Dm644 telegraf.tmpfiles $pkgdir/usr/lib/tmpfiles.d/telegraf.conf
-
- cd $GOBIN
- install -Dsm755 telegraf $pkgdir/usr/bin/telegraf
-
- cd $GOPATH/src/github.com/influxdata/telegraf
- install -d $pkgdir/etc/telegraf/telegraf.d/
- install -Dm644 scripts/telegraf.service $pkgdir/usr/lib/systemd/system/telegraf.service
- install -Dm644 etc/telegraf.conf $pkgdir/etc/telegraf/telegraf.conf
- install -Dm644 LICENSE $pkgdir/usr/share/licenses/telegraf/LICENSE
+ cd "$srcdir"
+ install -Dm644 telegraf.sysusers "$pkgdir/usr/lib/sysusers.d/telegraf.conf"
+ install -Dm644 telegraf.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/telegraf.conf"
+
+ cd "$GOBIN"
+ install -Dsm755 telegraf "$pkgdir/usr/bin/telegraf"
+
+ cd "$GOPATH/src/github.com/influxdata/telegraf"
+ install -d "$pkgdir/etc/telegraf/telegraf.d/"
+ install -Dm644 scripts/telegraf.service "$pkgdir/usr/lib/systemd/system/telegraf.service"
+ install -Dm644 etc/telegraf.conf "$pkgdir/etc/telegraf/telegraf.conf"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/telegraf/LICENSE"
}