summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThor772017-01-16 21:31:58 +0100
committerThor772017-01-21 23:43:15 +0100
commit8106ee0488bb55b3fb897dbcd8dd4c6e3a28299c (patch)
tree9c79d1ee35db994706388cb9ec3428da7fcee092
parent2ec8d0d9b63e7bda182d96d1ecd0f5d7f21041fb (diff)
downloadaur-8106ee0488bb55b3fb897dbcd8dd4c6e3a28299c.tar.gz
Merge patch from @KingCrunch
* Add missing LICENSE-file * Add .gitignore * Fix supported arm-architectures placed arm woth armv6h and amv7h. arm refers to ARM5, which doesn't support hardfloat, thus the armhf-package provided by upstream will probably not work. * Add provided LICENSE to PKGBUILD * Add conflict with `telegraf` because it makes use of the same files and folders * Create /var/log/telegraf because it is "somehow suggested" by the upstream package * Add logrotate-configuration makes sense to use when we expect log files * Use service-file provided by upstream-package * Copy provided LICENSE to correct location * Don't use removed service-file * Credit @KingCrunch for patch * Increase pkgrel to 2 * Generate .SRCINFO
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD24
-rw-r--r--telegraf.service13
5 files changed, 54 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb9bdb08274d..be5d15944638 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,32 @@
# Generated by mksrcinfo v8
-# Tue Jan 10 13:53:22 UTC 2017
+# Sat Jan 21 22:35:55 UTC 2017
pkgbase = telegraf-bin
pkgdesc = An open source agent for collecting metrics and data on the system; Binary release
pkgver = 1.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.influxdata.com/time-series-platform/telegraf/
install = telegraf.install
arch = i686
arch = x86_64
- arch = arm
+ arch = armv6h
+ arch = armv7h
license = MIT
+ conflicts = telegraf
backup = etc/telegraf/telegraf.conf
- source = telegraf.service
source = telegraf.sysusers
source = telegraf.tmpfiles
- md5sums = 35beb49d2b02153ec6691f41e3f9557c
+ source = LICENSE
md5sums = 58cc9edf8fbf07e7d3a0357db78121b1
md5sums = 9c7a4df3556cab94837c432f5e46cf04
+ md5sums = 10a23e7a514f23f0930e1a4254936534
source_i686 = telegraf.tar.gz::https://dl.influxdata.com/telegraf/releases/telegraf-1.1.2_linux_i386.tar.gz
md5sums_i686 = bd9d1fab4e288fb854ebcc4afd5f6be3
source_x86_64 = telegraf.tar.gz::https://dl.influxdata.com/telegraf/releases/telegraf-1.1.2_linux_amd64.tar.gz
md5sums_x86_64 = 3eb83eff90905722f5ef74c090fb203e
- source_arm = telegraf.tar.gz::https://dl.influxdata.com/telegraf/releases/telegraf-1.1.2_linux_armhf.tar.gz
- md5sums_arm = 1a4953bc88195db180d9a518bc5846bf
+ source_armv6h = telegraf.tar.gz::https://dl.influxdata.com/telegraf/releases/telegraf-1.1.2_linux_armhf.tar.gz
+ md5sums_armv6h = 1a4953bc88195db180d9a518bc5846bf
+ source_armv7h = telegraf.tar.gz::https://dl.influxdata.com/telegraf/releases/telegraf-1.1.2_linux_armhf.tar.gz
+ md5sums_armv7h = 1a4953bc88195db180d9a518bc5846bf
pkgname = telegraf-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f52b2f5a9940
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.xz
+*.tar.gz
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..1393544bbad4
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+The MIT License (MIT)
+
+Copyright (c) 2015 InfluxDB
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
+
diff --git a/PKGBUILD b/PKGBUILD
index 4f3b43d402f5..8be65f7fd443 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,14 @@
# Maintainer: Thor77 <thor77 at thor77 dot org>
+# Contributor: Sebastian Krebs <sebastian[at]krebs[dot]one>
pkgname=telegraf-bin
pkgver=1.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="An open source agent for collecting metrics and data on the system; Binary release"
-arch=('i686' 'x86_64' 'arm')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="https://www.influxdata.com/time-series-platform/telegraf/"
license=('MIT')
+conflicts=('telegraf')
backup=('etc/telegraf/telegraf.conf')
install=telegraf.install
@@ -14,18 +16,26 @@ source_i686=(telegraf.tar.gz::"https://dl.influxdata.com/telegraf/releases/teleg
md5sums_i686=('bd9d1fab4e288fb854ebcc4afd5f6be3')
source_x86_64=(telegraf.tar.gz::"https://dl.influxdata.com/telegraf/releases/telegraf-${pkgver}_linux_amd64.tar.gz")
md5sums_x86_64=('3eb83eff90905722f5ef74c090fb203e')
-source_arm=(telegraf.tar.gz::"https://dl.influxdata.com/telegraf/releases/telegraf-${pkgver}_linux_armhf.tar.gz")
-md5sums_arm=('1a4953bc88195db180d9a518bc5846bf')
-source=('telegraf.service' 'telegraf.sysusers' 'telegraf.tmpfiles')
-md5sums=('35beb49d2b02153ec6691f41e3f9557c' '58cc9edf8fbf07e7d3a0357db78121b1' '9c7a4df3556cab94837c432f5e46cf04')
+source=('telegraf.sysusers' 'telegraf.tmpfiles')
+md5sums=('58cc9edf8fbf07e7d3a0357db78121b1' '9c7a4df3556cab94837c432f5e46cf04')
+source_armv6h=(telegraf.tar.gz::"https://dl.influxdata.com/telegraf/releases/telegraf-${pkgver}_linux_armhf.tar.gz")
+md5sums_armv6h=('1a4953bc88195db180d9a518bc5846bf')
+source_armv7h=(telegraf.tar.gz::"https://dl.influxdata.com/telegraf/releases/telegraf-${pkgver}_linux_armhf.tar.gz")
+md5sums_armv7h=('1a4953bc88195db180d9a518bc5846bf')
+source=('telegraf.sysusers' 'telegraf.tmpfiles' 'LICENSE')
+md5sums=('58cc9edf8fbf07e7d3a0357db78121b1' '9c7a4df3556cab94837c432f5e46cf04' '10a23e7a514f23f0930e1a4254936534')
package() {
+ install -d -m 755 -o telegraf -g telegraf ${pkgdir}/var/log/telegraf
+
cd $srcdir
install -Dm644 telegraf.sysusers "$pkgdir/usr/lib/sysusers.d/telegraf.conf"
install -Dm644 telegraf.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/telegraf.conf"
- install -Dm644 telegraf.service "$pkgdir/usr/lib/systemd/system/telegraf.service"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/telegraf/LICENSE"
cd telegraf
install -Dm755 usr/bin/telegraf "$pkgdir/usr/bin/telegraf"
+ install -Dm644 usr/lib/telegraf/scripts/telegraf.service "$pkgdir/usr/lib/systemd/system/telegraf.service"
install -Dm644 etc/telegraf/telegraf.conf "$pkgdir/etc/telegraf/telegraf.conf"
+ install -Dm644 etc/logrotate.d/telegraf "$pkgdir/etc/logrotate.d/telegraf"
}
diff --git a/telegraf.service b/telegraf.service
deleted file mode 100644
index 94ffc0e728be..000000000000
--- a/telegraf.service
+++ /dev/null
@@ -1,13 +0,0 @@
-[Unit]
-Description=The plugin-driven server agent for reporting metrics into InfluxDB
-Documentation=https://github.com/influxdata/telegraf
-After=network.target
-
-[Service]
-User=telegraf
-Group=telegraf
-ExecStart=/usr/bin/telegraf -config /etc/telegraf/telegraf.conf
-ExecReload=/bin/kill -HUP $MAINPID
-
-[Install]
-WantedBy=multi-user.target