summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralesar12023-08-17 18:17:24 +0200
committeralesar12023-08-17 18:17:24 +0200
commit01e1725abf0de1178f50e092e61779d6bab2aa94 (patch)
treee69fe447d800812f27a42fe98529e451e7c739cc
downloadaur-01e1725abf0de1178f50e092e61779d6bab2aa94.tar.gz
upgpkg: telegram-a-appimage 10.0.1-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD55
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..367706544c25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = telegram-a-appimage
+ pkgdesc = Official Telegram Web client version A AppImage version
+ pkgver = 10.0.1
+ pkgrel = 1
+ url = https://web.telegram.org/a/get/
+ arch = x86_64
+ license = GPL3
+ depends = zlib
+ depends = hicolor-icon-theme
+ noextract = telegram-a-appimage-10.0.1.AppImage
+ options = !strip
+ source_x86_64 = telegram-a-appimage-10.0.1.AppImage::https://github.com/Ajaxy/telegram-tt/releases/download/v10.0.1/Telegram-A-x86_64.AppImage
+ source_x86_64 = https://github.com/Ajaxy/telegram-tt/raw/v10.0.1/LICENSE
+ sha256sums_x86_64 = 7ac6450193779f2b7690a538a2f5008901ec2877e7582288f1e70f26d1ad7ec8
+ sha256sums_x86_64 = e1c0ad728983d8a57335e52cf1064f1affd1d454173d8cebd3ed8b4a72b48704
+
+pkgname = telegram-a-appimage
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e878e61eefee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Alesar1
+
+_pkgname=telegram-a
+realname=telegram-t
+
+pkgname="${_pkgname}"-appimage
+pkgver=10.0.1
+pkgrel=1
+pkgdesc="Official Telegram Web client version A AppImage version"
+arch=('x86_64')
+url="https://web.telegram.org/a/get/"
+license=('GPL3')
+depends=('zlib' 'hicolor-icon-theme')
+options=(!strip)
+_appimage="${pkgname}-${pkgver}.AppImage"
+source_x86_64=("${_appimage}::https://github.com/Ajaxy/telegram-tt/releases/download/v${pkgver}/Telegram-A-x86_64.AppImage"
+ "https://github.com/Ajaxy/telegram-tt/raw/v${pkgver}/LICENSE")
+noextract=("${_appimage}")
+sha256sums_x86_64=('7ac6450193779f2b7690a538a2f5008901ec2877e7582288f1e70f26d1ad7ec8'
+ 'e1c0ad728983d8a57335e52cf1064f1affd1d454173d8cebd3ed8b4a72b48704')
+
+prepare() {
+ chmod +x "${_appimage}"
+ ./"${_appimage}" --appimage-extract
+}
+
+build() {
+ # Adjust .desktop so it will work outside of AppImage container
+ sed -i -E "s|Exec=AppRun|Exec=env DESKTOPINTEGRATION=false /usr/bin/${_pkgname}|"\
+ "squashfs-root/${realname}.desktop"
+ # Fix permissions; .AppImage permissions are 700 for all directories
+ chmod -R a-x+rX squashfs-root/usr
+}
+
+package() {
+ # AppImage
+ install -Dm755 "${srcdir}/${_appimage}" "${pkgdir}/opt/${pkgname}/${pkgname}.AppImage"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/opt/${pkgname}/LICENSE"
+
+ # Desktop file
+ install -Dm644 "${srcdir}/squashfs-root/${realname}.desktop"\
+ "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+
+ # Icon images
+ install -dm755 "${pkgdir}/usr/share/"
+ cp -a "${srcdir}/squashfs-root/usr/share/icons" "${pkgdir}/usr/share/"
+
+ # Symlink executable
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s "/opt/${pkgname}/${pkgname}.AppImage" "${pkgdir}/usr/bin/${_pkgname}"
+
+ # Symlink license
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ ln -s "/opt/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+}