summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSarisan2022-01-27 04:17:24 +0000
committerSarisan2022-01-27 04:17:24 +0000
commit5793cd7ea4fdec3510545f7da2e3b5fab9bcc7dd (patch)
tree59287f775047e7f73c116469bfffc9c4867366be
downloadaur-5793cd7ea4fdec3510545f7da2e3b5fab9bcc7dd.tar.gz
telegram-bot-api
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD39
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0eabb0203dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = telegram-bot-api
+ pkgdesc = Telegram Bot API server
+ pkgver = 5.6.1
+ pkgrel = 1
+ url = https://core.telegram.org/bots
+ arch = x86_64
+ license = BSL-1.0
+ makedepends = git
+ makedepends = gcc>=4.9
+ makedepends = gperf
+ makedepends = cmake>=3.0.2
+ depends = openssl
+ depends = zlib
+ provides = telegram-bot-api
+ conflicts = telegram-bot-api-git
+ source = git+https://github.com/tdlib/telegram-bot-api.git#commit=93ccd2a145926612dc45c5e095560e43fbd94d2a
+ source = git+https://github.com/tdlib/td.git#commit=14637caa64c2c992c1cde7c92cadb43a83d4435e
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = telegram-bot-api
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..241fc08bd842
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Sarisan Sekoohaka <sekoohaka.sarisan@gmail.com>
+
+pkgname=telegram-bot-api
+pkgver=5.6.1
+pkgrel=1
+pkgdesc="Telegram Bot API server"
+arch=('x86_64')
+url="https://core.telegram.org/bots"
+license=('BSL-1.0')
+depends=('openssl' 'zlib')
+makedepends=('git' 'gcc>=4.9' 'gperf' 'cmake>=3.0.2')
+provides=('telegram-bot-api')
+conflicts=('telegram-bot-api-git')
+_commit=93ccd2a145926612dc45c5e095560e43fbd94d2a
+_commit1=14637caa64c2c992c1cde7c92cadb43a83d4435e
+source=("git+https://github.com/tdlib/telegram-bot-api.git#commit=$_commit"
+ "git+https://github.com/tdlib/td.git#commit=$_commit1")
+sha256sums=('SKIP'
+ 'SKIP')
+
+prepare() {
+ cd telegram-bot-api
+ git submodule init
+ git config submodule.td.url ../td
+ git submodule update
+}
+
+build() {
+ mkdir -p telegram-bot-api/build
+ cd telegram-bot-api/build
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/usr" ..
+ cmake --build .
+}
+
+package() {
+ cd telegram-bot-api/build
+ mkdir -p "$pkgdir/usr"
+ cmake --build . --target install
+}