summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrumeet2020-11-04 18:40:05 -0800
committerTrumeet2020-11-04 18:40:05 -0800
commit75007721250fd639d79c06772b972241c2bf076c (patch)
treec17a32eda12aa5dbcc8a4191a87ba388a6deb8ed
downloadaur-75007721250fd639d79c06772b972241c2bf076c.tar.gz
First Commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD54
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ab9cdd70b2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = telegram-bot-api-git
+ pkgdesc = Provides an HTTP API for creating Telegram Bots.
+ pkgver = r3.551103b
+ pkgrel = 1
+ url = https://github.com/tdlib/telegram-bot-api
+ arch = x86_64
+ license = cusotm
+ makedepends = git
+ makedepends = zlib
+ makedepends = gperf
+ depends = openssl
+ depends = zlib
+ provides = telegram-bot-api
+ conflicts = telegram-bot-api
+ source = telegram-bot-api::git+https://github.com/tdlib/telegram-bot-api.git
+ source = td::git+https://github.com/tdlib/td.git
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = telegram-bot-api-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..609b9ef5697d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.zst
+td/
+telegram-bot-api/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a96abbf878bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: YuutaW <trumeetc@trumeet.com>
+pkgname='telegram-bot-api-git'
+pkgver=r3.551103b
+pkgrel=1
+pkgdesc="Provides an HTTP API for creating Telegram Bots."
+arch=('x86_64')
+url="https://github.com/tdlib/telegram-bot-api"
+license=('cusotm')
+groups=()
+depends=('openssl' 'zlib')
+makedepends=('git' 'zlib' 'gperf')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('telegram-bot-api::git+https://github.com/tdlib/telegram-bot-api.git'
+'td::git+https://github.com/tdlib/td.git')
+noextract=()
+md5sums=('SKIP'
+'SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ git submodule init
+ git config submodule.td.url $srcdir/td
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/usr" ..
+ cmake --build .
+}
+
+check() {
+ cd "$srcdir/${pkgname%-git}"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir -p "$pkgdir/usr/share/licenses/${pkgname%-git}/"
+ install -Dm644 "./LICENSE_1_0.txt" "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE_1_0.txt"
+ cd build
+ cmake --build . --target install
+}