summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordrrossum2020-02-13 11:52:11 +0100
committerdrrossum2020-02-13 11:52:11 +0100
commitc03679df0a5f1c770f21af213cf33a35ca53dd05 (patch)
tree83686ad44e138fedbdbde9edb8b57f4cb27d74cb
parentb894ccaf22ed86874eae8a0d80f08d895a6e0d17 (diff)
downloadaur-c03679df0a5f1c770f21af213cf33a35ca53dd05.tar.gz
Switch source to fork by kenorb-contrib
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
-rw-r--r--telegram-cli-git.patch90
3 files changed, 7 insertions, 103 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6df1434efb0..d9e1c8d85348 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Aug 21 09:58:47 UTC 2018
pkgbase = telegram-cli-git
pkgdesc = Telegram messenger CLI
- pkgver = r1128.6547c0b
+ pkgver = r1352.e35dc1a
pkgrel = 1
url = https://github.com/vysheng/tg
arch = i686
@@ -14,12 +12,11 @@ pkgbase = telegram-cli-git
depends = libevent
depends = lua
depends = jansson
+ depends = zlib
provides = telegram-cli
conflicts = telegram-cli
- source = telegram-cli-git::git+https://github.com/vysheng/tg
- source = telegram-cli-git.patch
+ source = telegram-cli-git::git+https://github.com/kenorb-contrib/tg
sha256sums = SKIP
- sha256sums = 720550515339552641cc5b01fffe63167634a22d2f7b2fe935d28183031d82f2
pkgname = telegram-cli-git
diff --git a/PKGBUILD b/PKGBUILD
index 827fc37f7264..75a701f6f955 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,19 @@
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=telegram-cli-git
-pkgver=r1128.6547c0b
+pkgver=r1352.e35dc1a
pkgrel=1
pkgdesc="Telegram messenger CLI"
arch=('i686' 'x86_64' 'armv7h')
url="https://github.com/vysheng/tg"
license=('GPL2')
-depends=('libconfig' 'libevent' 'lua' 'jansson')
+depends=('libconfig' 'libevent' 'lua' 'jansson' 'zlib')
makedepends=('git')
conflicts=('telegram-cli')
provides=('telegram-cli')
-source=("$pkgname"::'git+https://github.com/vysheng/tg'
- "$pkgname.patch")
-sha256sums=('SKIP'
- '720550515339552641cc5b01fffe63167634a22d2f7b2fe935d28183031d82f2')
+source=("$pkgname"::'git+https://github.com/kenorb-contrib/tg')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
@@ -26,7 +24,6 @@ pkgver() {
prepare() {
cd "$srcdir/$pkgname"
git submodule update --init --recursive --force
- patch -p1 < "$srcdir/$pkgname.patch"
}
build() {
diff --git a/telegram-cli-git.patch b/telegram-cli-git.patch
deleted file mode 100644
index 2d2b7b04e7e5..000000000000
--- a/telegram-cli-git.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-diff --git a/tgl/crypto/rsa_pem_openssl.c b/tgl/crypto/rsa_pem_openssl.c
-index db653f2..5e6a697 100644
---- a/tgl/crypto/rsa_pem_openssl.c
-+++ b/tgl/crypto/rsa_pem_openssl.c
-@@ -36,6 +36,12 @@ TGLC_WRAPPER_ASSOC(rsa,RSA)
- // TODO: Refactor crucial struct-identity into its own header.
- TGLC_WRAPPER_ASSOC(bn,BIGNUM)
-
-+/*
-+ * Since OpenSSL version 1.1.0 the RSA struct (rsa_st) is opaque,
-+ * see also https://wiki.openssl.org/index.php/OpenSSL_1.1.0_Changes
-+ */
-+#if (OPENSSL_VERSION_NUMBER < 0x10100000L)
-+
- TGLC_rsa *TGLC_rsa_new (unsigned long e, int n_bytes, const unsigned char *n) {
- RSA *ret = RSA_new ();
- ret->e = unwrap_bn (TGLC_bn_new ());
-@@ -47,7 +53,30 @@ TGLC_rsa *TGLC_rsa_new (unsigned long e, int n_bytes, const unsigned char *n) {
- #define RSA_GETTER(M) \
- TGLC_bn *TGLC_rsa_ ## M (TGLC_rsa *key) { \
- return wrap_bn (unwrap_rsa (key)->M); \
-- } \
-+ }
-+
-+#else // OPENSSL_VERSION_NUMBER
-+
-+TGLC_rsa *TGLC_rsa_new (unsigned long e, int n_bytes, const unsigned char *n) {
-+ RSA *ret = RSA_new ();
-+ BIGNUM *ret_e = unwrap_bn (TGLC_bn_new ());
-+ BIGNUM *ret_n = unwrap_bn (TGLC_bn_bin2bn (n, n_bytes, NULL));
-+ RSA_set0_key (ret, ret_n, ret_e, NULL);
-+ TGLC_bn_set_word (wrap_bn (ret_e), e);
-+ return wrap_rsa (ret);
-+}
-+
-+#define RSA_GETTER(M) \
-+TGLC_bn *TGLC_rsa_ ## M (TGLC_rsa *key) { \
-+ BIGNUM *rsa_n, *rsa_e, *rsa_d; \
-+ RSA_get0_key(unwrap_rsa (key), \
-+ (const BIGNUM **) &rsa_n, \
-+ (const BIGNUM **) &rsa_e, \
-+ (const BIGNUM **) &rsa_d); \
-+ return wrap_bn (rsa_ ## M); \
-+}
-+
-+#endif // OPENSSL_VERSION_NUMBER
-
- RSA_GETTER(n);
- RSA_GETTER(e);
-@@ -60,4 +89,4 @@ TGLC_rsa *TGLC_pem_read_RSAPublicKey (FILE *fp) {
- return wrap_rsa (PEM_read_RSAPublicKey (fp, NULL, NULL, NULL));
- }
-
--#endif
-+#endif // TGL_AVOID_OPENSSL
-diff --git a/tgl/mtproto-utils.c b/tgl/mtproto-utils.c
-index 0948bc8..cfdb216 100644
---- a/tgl/mtproto-utils.c
-+++ b/tgl/mtproto-utils.c
-@@ -98,7 +98,7 @@ static unsigned long long BN2ull (TGLC_bn *b) {
- if (sizeof (unsigned long) == 8) {
- return TGLC_bn_get_word (b);
- } else if (sizeof (unsigned long long) == 8) {
-- assert (0); // As long as nobody ever uses this code, assume it is broken.
-+// assert (0); // As long as nobody ever uses this code, assume it is broken.
- unsigned long long tmp;
- /* Here be dragons, but it should be okay due to be64toh */
- TGLC_bn_bn2bin (b, (unsigned char *) &tmp);
-@@ -112,7 +112,7 @@ static void ull2BN (TGLC_bn *b, unsigned long long val) {
- if (sizeof (unsigned long) == 8 || val < (1ll << 32)) {
- TGLC_bn_set_word (b, val);
- } else if (sizeof (unsigned long long) == 8) {
-- assert (0); // As long as nobody ever uses this code, assume it is broken.
-+// assert (0); // As long as nobody ever uses this code, assume it is broken.
- htobe64(val);
- /* Here be dragons, but it should be okay due to htobe64 */
- TGLC_bn_bin2bn ((unsigned char *) &val, 8, b);
-diff --git a/tgl/tl-parser/tl-parser.c b/tgl/tl-parser/tl-parser.c
-index 524b196..aeadbd2 100644
---- a/tgl/tl-parser/tl-parser.c
-+++ b/tgl/tl-parser/tl-parser.c
-@@ -1903,7 +1903,7 @@ struct tl_combinator_tree *tl_parse_args134 (struct tree *T) {
- //assert (S->data);
- char *name = S->data;
- if (!name) {
-- static char s[20];
-+ static char s[21];
- sprintf (s, "%lld", lrand48 () * (1ll << 32) + lrand48 ());
- name = s;
- }