summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Sánchez Muñoz2016-10-21 12:49:28 +0200
committerEduardo Sánchez Muñoz2016-10-21 12:49:28 +0200
commit78b33c60d327fae98c33fb5e83358dcccfc63559 (patch)
treedb121e3fc93b8a1c1434f669edc31384c1190cc2
parent82b56e6feec800aa2d03bf0a8c2cb800f6dd9fd3 (diff)
downloadaur-78b33c60d327fae98c33fb5e83358dcccfc63559.tar.gz
Add back experimental wayland support.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
-rw-r--r--aur-fixes.diff15
3 files changed, 25 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4757e9c1364..f9aa7f7f318d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Oct 20 20:07:32 UTC 2016
+# Fri Oct 21 10:49:15 UTC 2016
pkgbase = telegram-desktop
pkgdesc = Official desktop version of Telegram messaging app.
pkgver = 0.10.16
- pkgrel = 1
+ pkgrel = 2
url = https://desktop.telegram.org/
arch = i686
arch = x86_64
@@ -38,6 +38,7 @@ pkgbase = telegram-desktop
makedepends = libtiff
makedepends = libmng
makedepends = libwebp
+ makedepends = wayland
depends = ffmpeg
depends = icu
depends = jasper
@@ -55,6 +56,7 @@ pkgbase = telegram-desktop
source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v0.10.16
source = https://download.qt.io/official_releases/qt/5.6/5.6.2/submodules/qtbase-opensource-src-5.6.2.tar.xz
source = https://download.qt.io/official_releases/qt/5.6/5.6.2/submodules/qtimageformats-opensource-src-5.6.2.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.6/5.6.2/submodules/qtwayland-opensource-src-5.6.2.tar.xz
source = git+https://chromium.googlesource.com/external/gyp
source = telegramdesktop.desktop
source = tg.protocol
@@ -62,10 +64,11 @@ pkgbase = telegram-desktop
sha256sums = SKIP
sha256sums = 2f6eae93c5d982fe0a387a01aeb3435571433e23e9d9d9246741faf51f1ee787
sha256sums = 4fb153be62dac393cbcebab65040b3b9d6edecd1ebbe5e543401b0e45bd147e4
+ sha256sums = 035c3199f4719627b64b7020f0f4574da2b4cb78c6981aba75f27b872d8e6c86
sha256sums = SKIP
sha256sums = 41c22fae6ae757936741e63aec3d0f17cafe86b2d6153cdd1d01a5581e871f17
sha256sums = d4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb
- sha256sums = SKIP
+ sha256sums = 2380e467c4424d896179ea12e21a5c2d820050b18f00b0bcdc77c2a538479ec3
pkgname = telegram-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 5861f242e3e4..6ca3d98b39ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=telegram-desktop
pkgver=0.10.16
-pkgrel=1
+pkgrel=2
pkgdesc='Official desktop version of Telegram messaging app.'
arch=('i686' 'x86_64')
url="https://desktop.telegram.org/"
@@ -55,13 +55,15 @@ makedepends=(
'libtiff'
'libmng'
'libwebp'
+ # For qtwayland
+ 'wayland'
)
qt_version=5.6.2
source=(
"tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v$pkgver"
"https://download.qt.io/official_releases/qt/${qt_version%.*}/$qt_version/submodules/qtbase-opensource-src-$qt_version.tar.xz"
"https://download.qt.io/official_releases/qt/${qt_version%.*}/$qt_version/submodules/qtimageformats-opensource-src-$qt_version.tar.xz"
- #"https://download.qt.io/official_releases/qt/${qt_version%.*}/$qt_version/submodules/qtwayland-opensource-src-$qt_version.tar.xz"
+ "https://download.qt.io/official_releases/qt/${qt_version%.*}/$qt_version/submodules/qtwayland-opensource-src-$qt_version.tar.xz"
"git+https://chromium.googlesource.com/external/gyp"
"telegramdesktop.desktop"
"tg.protocol"
@@ -71,11 +73,11 @@ sha256sums=(
'SKIP'
'2f6eae93c5d982fe0a387a01aeb3435571433e23e9d9d9246741faf51f1ee787'
'4fb153be62dac393cbcebab65040b3b9d6edecd1ebbe5e543401b0e45bd147e4'
- #'035c3199f4719627b64b7020f0f4574da2b4cb78c6981aba75f27b872d8e6c86'
+ '035c3199f4719627b64b7020f0f4574da2b4cb78c6981aba75f27b872d8e6c86'
'SKIP'
'41c22fae6ae757936741e63aec3d0f17cafe86b2d6153cdd1d01a5581e871f17'
'd4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb'
- 'SKIP'
+ '2380e467c4424d896179ea12e21a5c2d820050b18f00b0bcdc77c2a538479ec3'
)
prepare() {
@@ -91,7 +93,7 @@ prepare() {
mv "$srcdir/qtbase-opensource-src-$qt_version" "$qt_src_dir/qtbase"
mv "$srcdir/qtimageformats-opensource-src-$qt_version" "$qt_src_dir/qtimageformats"
- #mv "$srcdir/qtwayland-opensource-src-$qt_version" "$qt_src_dir/qtwayland"
+ mv "$srcdir/qtwayland-opensource-src-$qt_version" "$qt_src_dir/qtwayland"
cd "$qt_src_dir/qtbase"
patch -p1 -i "$qt_patch_file"
@@ -142,10 +144,10 @@ build() {
make
make install
- #cd "$qt_src_dir/qtwayland"
- #qmake .
- #make
- #make install
+ cd "$qt_src_dir/qtwayland"
+ qmake .
+ make
+ make install
# Build Telegram Desktop
rm -rf "$srcdir/tdesktop/out"
diff --git a/aur-fixes.diff b/aur-fixes.diff
index 163aadc9ab39..2769acf40f95 100644
--- a/aur-fixes.diff
+++ b/aur-fixes.diff
@@ -44,14 +44,14 @@ index bc3dce6..07c5042 100644
extern f_gtk_init_check gtk_init_check;
diff --git a/Telegram/SourceFiles/stdafx.cpp b/Telegram/SourceFiles/stdafx.cpp
-index 06bd4af..173721b 100644
+index 06bd4af..755d97f 100644
--- a/Telegram/SourceFiles/stdafx.cpp
+++ b/Telegram/SourceFiles/stdafx.cpp
@@ -34,6 +34,7 @@ Q_IMPORT_PLUGIN(QGenericEnginePlugin)
#elif defined Q_OS_LINUX // Q_OS_LINUX
Q_IMPORT_PLUGIN(QWebpPlugin)
Q_IMPORT_PLUGIN(QXcbIntegrationPlugin)
-+//Q_IMPORT_PLUGIN(QWaylandIntegrationPlugin)
++Q_IMPORT_PLUGIN(QWaylandIntegrationPlugin)
Q_IMPORT_PLUGIN(QConnmanEnginePlugin)
Q_IMPORT_PLUGIN(QGenericEnginePlugin)
Q_IMPORT_PLUGIN(QNetworkManagerEnginePlugin)
@@ -86,7 +86,7 @@ index 5a49cd2..7cb3e88 100644
'sources': [
'<@(qrc_files)',
diff --git a/Telegram/gyp/qt.gypi b/Telegram/gyp/qt.gypi
-index 24ededb..01ca8a4 100644
+index 24ededb..cdb18f5 100644
--- a/Telegram/gyp/qt.gypi
+++ b/Telegram/gyp/qt.gypi
@@ -38,7 +38,6 @@
@@ -114,9 +114,9 @@ index 24ededb..01ca8a4 100644
- 'xcb-xfixes',
- 'xcb-render',
- 'xcb-static',
-+ #'Qt5WaylandClient',
-+ #'qwayland-generic',
-+ #'qwayland-egl',
++ 'Qt5WaylandClient',
++ 'qwayland-generic',
++ 'qwayland-egl',
],
}],
],
@@ -128,7 +128,7 @@ index 24ededb..01ca8a4 100644
'<@(qt_libs_release)',
'<(linux_lib_ssl)',
'<(linux_lib_crypto)',
-@@ -221,12 +209,31 @@
+@@ -221,12 +209,32 @@
'gthread-2.0',
'glib-2.0',
'pthread',
@@ -150,6 +150,7 @@ index 24ededb..01ca8a4 100644
+ '<!(pkg-config 2> /dev/null --libs libjpeg)',
+ '<!(pkg-config 2> /dev/null --libs libwebp)',
+ '<!(pkg-config 2> /dev/null --libs xcb-shm xcb-xfixes xcb-render xcb-renderutil xcb-sync xcb-randr xcb-xinerama xcb-xkb xcb-icccm xcb-image xcb-shape xcb-keysyms xcb-util)',
++ '<!(pkg-config 2> /dev/null --libs wayland-client wayland-cursor)',
+ 'proxy',
+ 'GL',
],