summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Santini2023-05-07 21:04:45 +0200
committerGiovanni Santini2023-05-07 21:04:45 +0200
commit062065167af2f3f0a40ab7dc591a399fc55ea697 (patch)
treebebf700ac20907372c3fd972d02951b03fcbccce
parent9fff64c275a748ab63013aae8ec4b58c804f08d8 (diff)
downloadaur-062065167af2f3f0a40ab7dc591a399fc55ea697.tar.gz
upgpkg: telegram-desktop-dev 4.8.1-1
- Version bump. - Switch to newer OpenSSL. - Small tweaks to PKGBUILD.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef537f32e030..3758b757a700 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = telegram-desktop-dev
pkgdesc = Official Telegram Desktop client - development release
- pkgver = 4.7.1
+ pkgver = 4.8.1
pkgrel = 1
url = https://desktop.telegram.org/
arch = x86_64
@@ -37,13 +37,13 @@ pkgbase = telegram-desktop-dev
depends = jemalloc
depends = abseil-cpp
depends = libdispatch
- depends = openssl-1.1
+ depends = openssl
depends = protobuf
optdepends = webkit2gtk: embedded browser features
optdepends = xdg-desktop-portal: desktop integration
provides = telegram-desktop
conflicts = telegram-desktop
- source = tdesktop::git+https://github.com/telegramdesktop/tdesktop#tag=v4.7.1
+ source = tdesktop::git+https://github.com/telegramdesktop/tdesktop#tag=v4.8.1
source = ensure_qt6_build.patch
source = cld3::git+https://github.com/google/cld3.git
source = cmake::git+https://github.com/desktop-app/cmake_helpers.git
diff --git a/PKGBUILD b/PKGBUILD
index 89426a48f818..1725ff86054c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
# You can pass parameters to `ninja` via MAKEFLAGS
pkgname=telegram-desktop-dev
-pkgver=4.7.1
+pkgver=4.8.1
pkgrel=1
pkgdesc='Official Telegram Desktop client - development release'
arch=(x86_64)
@@ -24,7 +24,7 @@ license=('GPL3')
depends=('hunspell' 'ffmpeg' 'hicolor-icon-theme' 'lz4' 'minizip' 'openal' 'ttf-opensans'
'qt6-imageformats' 'qt6-svg' 'qt6-wayland' 'qt6-5compat' 'xxhash' 'glibmm-2.68'
'rnnoise' 'pipewire' 'libxtst' 'libxrandr' 'jemalloc' 'abseil-cpp' 'libdispatch'
- 'openssl-1.1' 'protobuf')
+ 'openssl' 'protobuf')
makedepends=('cmake' 'git' 'ninja' 'python' 'range-v3' 'tl-expected' 'microsoft-gsl' 'meson'
'extra-cmake-modules' 'wayland-protocols' 'plasma-wayland-protocols' 'libtg_owt')
optdepends=('webkit2gtk: embedded browser features'
@@ -37,7 +37,7 @@ _commit="tag=v$pkgver"
# These files might require modifications to be up-to-date.
# In such situation, extra patches will be added.
# An easy way to clone the repo since the last update is:
-# git clone --recurse-submodules --shallow-submodules --shallow-since vOLDVER --branch=vNEWVER https://github.com/telegramdesktop/tdesktop WORKDIR
+# git clone --recurse-submodules --shallow-submodules --shallow-since=vOLDVER --branch=vNEWVER https://github.com/telegramdesktop/tdesktop WORKDIR
source=(
"tdesktop::git+https://github.com/telegramdesktop/tdesktop#$_commit"
"ensure_qt6_build.patch"
@@ -184,6 +184,7 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DTDESKTOP_API_ID=611335 \
-DTDESKTOP_API_HASH=d524b414d21f4d37f08684c1df41ac9c
+ # Removed flag as useless:
# -DCMAKE_VERBOSE_MAKEFILE=ON \
cmake --build build -- $MAKEFLAGS
}