summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Santini2020-03-23 23:11:03 +0100
committerGiovanni Santini2020-03-23 23:11:03 +0100
commit6b7e5fa7d4b04c799284ea7832e05e9e58e3e28e (patch)
tree2e099b65b2d5099e0fc6c008f124ea7630b01c04
parent1ebac8f0a1ce8a95422136baab42dbbfdbe3830f (diff)
downloadaur-6b7e5fa7d4b04c799284ea7832e05e9e58e3e28e.tar.gz
upgpkg: telegram-desktop-dev 1.9.21-1
- Version bump.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD24
2 files changed, 14 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef7fe6fc8bce..b9ba58458d9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = telegram-desktop-dev
pkgdesc = Official Telegram Desktop client - development release
- pkgver = 1.9.16
+ pkgver = 1.9.21
pkgrel = 1
url = https://desktop.telegram.org/
arch = i686
@@ -12,11 +12,10 @@ pkgbase = telegram-desktop-dev
makedepends = python
makedepends = range-v3
makedepends = tl-expected
- depends = enchant
+ depends = hunspell
depends = ffmpeg
depends = hicolor-icon-theme
depends = libdbusmenu-qt5
- depends = libappindicator-gtk3
depends = lz4
depends = minizip
depends = openal
@@ -25,13 +24,14 @@ pkgbase = telegram-desktop-dev
optdepends = ttf-opensans: default Open Sans font family
provides = telegram-desktop
conflicts = telegram-desktop
- source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.9.16
+ source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.9.21
source = Catch::git+https://github.com/philsquared/Catch
source = GSL::git+https://github.com/Microsoft/GSL.git
source = QR::git+https://github.com/nayuki/QR-Code-generator
source = cmake::git+https://github.com/desktop-app/cmake_helpers.git
source = codegen::git+https://github.com/desktop-app/codegen.git
source = expected::git+https://github.com/TartanLlama/expected
+ source = hunspell::git+https://github.com/hunspell/hunspell
source = lib_base::git+https://github.com/desktop-app/lib_base.git
source = lib_crl::git+https://github.com/desktop-app/lib_crl.git
source = lib_lottie::git+https://github.com/desktop-app/lib_lottie.git
@@ -71,6 +71,7 @@ pkgbase = telegram-desktop-dev
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
+ sha512sums = SKIP
pkgname = telegram-desktop-dev
diff --git a/PKGBUILD b/PKGBUILD
index 44f94b022bd3..1bd0756c7984 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,14 @@
# https://github.com/mymedia2/tdesktop
pkgname=telegram-desktop-dev
-pkgver=1.9.16
+pkgver=1.9.21
pkgrel=1
pkgdesc='Official Telegram Desktop client - development release'
arch=('i686' 'x86_64')
url="https://desktop.telegram.org/"
license=('GPL3')
-depends=('enchant' 'ffmpeg' 'hicolor-icon-theme' 'libdbusmenu-qt5'
- 'libappindicator-gtk3' 'lz4' 'minizip' 'openal' 'qt5-imageformats'
- 'xxhash')
+depends=('hunspell' 'ffmpeg' 'hicolor-icon-theme' 'libdbusmenu-qt5' 'lz4'
+ 'minizip' 'openal' 'qt5-imageformats' 'xxhash')
makedepends=('cmake' 'git' 'microsoft-gsl' 'python' 'range-v3' 'tl-expected')
optdepends=('ttf-opensans: default Open Sans font family')
@@ -35,6 +34,7 @@ source=(
"cmake::git+https://github.com/desktop-app/cmake_helpers.git"
"codegen::git+https://github.com/desktop-app/codegen.git"
"expected::git+https://github.com/TartanLlama/expected"
+ "hunspell::git+https://github.com/hunspell/hunspell"
"lib_base::git+https://github.com/desktop-app/lib_base.git"
"lib_crl::git+https://github.com/desktop-app/lib_crl.git"
"lib_lottie::git+https://github.com/desktop-app/lib_lottie.git"
@@ -78,6 +78,7 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
prepare() {
@@ -90,6 +91,7 @@ prepare() {
git config submodule.Telegram/ThirdParty/GSL.url "$srcdir/GSL"
git config submodule.Telegram/ThirdParty/QR.url "$srcdir/QR"
git config submodule.Telegram/ThirdParty/expected.url "$srcdir/expected"
+ git config submodule.Telegram/ThirdParty/hunspell.url "$srcdir/hunspell"
git config submodule.Telegram/ThirdParty/libdbusmenu-qt.url "$srcdir/libdbusmenu-qt"
git config submodule.Telegram/ThirdParty/libtgvoip.url "$srcdir/libtgvoip"
git config submodule.Telegram/ThirdParty/lz4.url "$srcdir/lz4"
@@ -125,24 +127,17 @@ prepare() {
build() {
cd "$srcdir/tdesktop"
- export CXXFLAGS="$CXXFLAGS -ffile-prefix-map=$srcdir/tdesktop="
-
# Before were used:
# -DTDESKTOP_API_ID=17349
# -DTDESKTOP_API_HASH=344583e45741c457fe1862106095a5eb
-
+ # export CXXFLAGS="$CXXFLAGS -ffile-prefix-map=$srcdir/tdesktop="
cmake -B build -G "Unix Makefiles" . \
- -Ddisable_autoupdate=1 \
- -DCMAKE_INSTALL_PREFIX="$pkgdir/usr" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_BUILD_TYPE=Release \
-DTDESKTOP_API_TEST=ON \
- -DDESKTOP_APP_USE_GLIBC_WRAPS=OFF \
- -DDESKTOP_APP_USE_PACKAGED=ON \
-DDESKTOP_APP_USE_PACKAGED_RLOTTIE=OFF \
-DDESKTOP_APP_USE_PACKAGED_VARIANT=OFF \
- -DDESKTOP_APP_DISABLE_CRASH_REPORTS=ON \
-DTDESKTOP_DISABLE_REGISTER_CUSTOM_SCHEME=ON \
- -DTDESKTOP_DISABLE_DESKTOP_FILE_GENERATION=ON \
-DTDESKTOP_USE_PACKAGED_TGVOIP=OFF \
-DDESKTOP_APP_SPECIAL_TARGET="" \
-DTDESKTOP_LAUNCHER_BASENAME="telegram-desktop"
@@ -151,6 +146,5 @@ build() {
package() {
cd "$srcdir/tdesktop"
-
- make -C build install
+ DESTDIR="$pkgdir" make -C build install
}