summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Santini2022-11-25 23:21:24 +0100
committerGiovanni Santini2022-11-25 23:21:24 +0100
commit9ef91d992f5326d3241ce729fe9a617e1c08f81a (patch)
treedbb3fe4dc9ad7339b1946faf82e9e93a088aa16e
parente8eba3c68cb073a35e0721bf4d5f1d5da5ab35a2 (diff)
downloadaur-9ef91d992f5326d3241ce729fe9a617e1c08f81a.tar.gz
upgpkg: telegram-desktop-dev 4.3.1-1
- Version bump. - Improvements in the PKGBUILD, especially for maintainance commands.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD27
2 files changed, 23 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08e3fc6a79a6..30114e4e8bfa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = telegram-desktop-dev
pkgdesc = Official Telegram Desktop client - development release
- pkgver = 4.2.4
+ pkgver = 4.3.1
pkgrel = 1
url = https://desktop.telegram.org/
arch = x86_64
@@ -28,7 +28,7 @@ pkgbase = telegram-desktop-dev
depends = qt6-wayland
depends = qt6-5compat
depends = xxhash
- depends = glibmm
+ depends = glibmm-2.68
depends = rnnoise
depends = pipewire
depends = libxtst
@@ -36,11 +36,12 @@ pkgbase = telegram-desktop-dev
depends = jemalloc
depends = abseil-cpp
depends = libdispatch
+ depends = openssl-1.1
optdepends = webkit2gtk: embedded browser features
optdepends = xdg-desktop-portal: desktop integration
provides = telegram-desktop
conflicts = telegram-desktop
- source = tdesktop::git+https://github.com/telegramdesktop/tdesktop#tag=v4.2.4
+ source = tdesktop::git+https://github.com/telegramdesktop/tdesktop#tag=v4.3.1
source = tgcalls_type_fix.diff
source = cmake::git+https://github.com/desktop-app/cmake_helpers.git
source = codegen::git+https://github.com/desktop-app/codegen.git
diff --git a/PKGBUILD b/PKGBUILD
index 589b0b2e2740..8193269e307b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,16 @@
# Maintainer: silentnoodle <lonnqvistben at gmail dot com>
# Contributor: Sven-Hendrik Haase <svenstaro@archlinux.org>
# Contributor: hexchain <i@hexchain.org>
+
# Thanks Nicholas Guriev <guriev-ns@ya.ru> for the initial patches!
# https://github.com/mymedia2/tdesktop
+
+# Updated using:
+# https://raw.githubusercontent.com/archlinux/svntogit-community/packages/telegram-desktop/trunk/PKGBUILD
+# Thanks to the Arch maintainers :)
+
pkgname=telegram-desktop-dev
-pkgver=4.2.4
+pkgver=4.3.1
pkgrel=1
pkgdesc='Official Telegram Desktop client - development release'
arch=(x86_64)
@@ -14,8 +20,9 @@ license=('GPL3')
# Although not in order, keeping them in the same order of the standard package
# for my mental sanity.
depends=('hunspell' 'ffmpeg4.4' 'hicolor-icon-theme' 'lz4' 'minizip' 'openal' 'ttf-opensans'
- 'qt6-imageformats' 'qt6-svg' 'qt6-wayland' 'qt6-5compat' 'xxhash' 'glibmm'
- 'rnnoise' 'pipewire' 'libxtst' 'libxrandr' 'jemalloc' 'abseil-cpp' 'libdispatch')
+ 'qt6-imageformats' 'qt6-svg' 'qt6-wayland' 'qt6-5compat' 'xxhash' 'glibmm-2.68'
+ 'rnnoise' 'pipewire' 'libxtst' 'libxrandr' 'jemalloc' 'abseil-cpp' 'libdispatch'
+ 'openssl-1.1')
makedepends=('cmake' 'git' 'python' 'range-v3' 'tl-expected' 'microsoft-gsl' 'meson'
'extra-cmake-modules' 'wayland-protocols' 'plasma-wayland-protocols' 'libtg_owt')
optdepends=('webkit2gtk: embedded browser features'
@@ -28,13 +35,13 @@ _commit="tag=v$pkgver"
# These files might require modifications to be up-to-date.
# In such situation, extra patches will be added.
# An easy way to clone the repo since the last update is:
-# git clone --recurse-submodules --shallow-submodules --remote-submodules --shallow-since=vOLDVER https://github.com/telegramdesktop/tdesktop WORKDIR
-# All the submodules "source" definitions are generated them via:
-# git submodule foreach --quiet 'echo \"${name##*/}::git+`git remote get-url origin`\"' | sort
+# git clone --recurse-submodules --remote-submodules --shallow-submodules --shallow-since=vOLDVER --branch=vNEWVER https://github.com/telegramdesktop/tdesktop WORKDIR
source=(
"tdesktop::git+https://github.com/telegramdesktop/tdesktop#$_commit"
"tgcalls_type_fix.diff"
- # Here are all the repos. See the commands above for populating them
+ # Here are all the submodule repos.
+ # All the submodules "source" definitions are generated them via:
+ # git submodule foreach --quiet 'echo \"${name##*/}::git+`git remote get-url origin`\"' | sort
"cmake::git+https://github.com/desktop-app/cmake_helpers.git"
"codegen::git+https://github.com/desktop-app/codegen.git"
"dispatch::git+https://github.com/apple/swift-corelibs-libdispatch"
@@ -146,7 +153,11 @@ prepare() {
git config submodule.Telegram/ThirdParty/xxHash.url "$srcdir/xxHash"
# Magic is over!
- git submodule update
+ # We need the extra flag for this vulnerability:
+ # https://github.blog/2022-10-18-git-security-vulnerabilities-announced/#cve-2022-39253
+ # With the -c flag we enable the file cloning only for this command, as per guidelines:
+ # https://wiki.archlinux.org/title/VCS_package_guidelines#Git_submodules
+ git -c protocol.file.allow=always submodule update
# Cheating! Linking fixed patches to their usual place
#for fixed in $srcdir/*_fixed*