summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Santini2021-05-05 23:43:44 +0200
committerGiovanni Santini2021-05-05 23:43:44 +0200
commite510fb4d0e058355668a0e7530b729a32e494227 (patch)
tree1be9a703485a2812a9d7a743431645f78af25eb3
parent28098964f9a85376b02d5c3c7a6a7e90cbf49b50 (diff)
downloadaur-e510fb4d0e058355668a0e7530b729a32e494227.tar.gz
upgpkg: telegram-desktop-dev 2.7.4-1
- Version bump, tracking the official package.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 16 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6c2bab4eddd..b1e83adc48d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = telegram-desktop-dev
pkgdesc = Official Telegram Desktop client - development release
- pkgver = 2.6.1
+ pkgver = 2.7.4
pkgrel = 1
url = https://desktop.telegram.org/
arch = x86_64
@@ -25,9 +25,11 @@ pkgbase = telegram-desktop-dev
depends = libdbusmenu-qt5
depends = kwayland
depends = gtk3
+ depends = glibmm
+ depends = webkit2gtk
provides = telegram-desktop
conflicts = telegram-desktop
- source = tdesktop::git+https://github.com/telegramdesktop/tdesktop#tag=v2.6.1
+ source = tdesktop::git+https://github.com/telegramdesktop/tdesktop#tag=v2.7.4
source = Catch::git+https://github.com/philsquared/Catch
source = cmake::git+https://github.com/desktop-app/cmake_helpers.git
source = codegen::git+https://github.com/desktop-app/codegen.git
@@ -58,6 +60,7 @@ pkgbase = telegram-desktop-dev
source = rlottie::git+https://github.com/desktop-app/rlottie.git
source = tgcalls::git+https://github.com/TelegramMessenger/tgcalls.git
source = xxHash::git+https://github.com/Cyan4973/xxHash.git
+ source = https://github.com/archlinux/svntogit-community/raw/packages/telegram-desktop/trunk/fix-webview-includes.patch
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
@@ -89,6 +92,7 @@ pkgbase = telegram-desktop-dev
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
+ sha512sums = 5492c73f0b984da1e2d1f21c3a36c11c4b9ad511522dccd4d6440681f68d6ebc9e672806a534b1e551f736f080d3ef307c8ddd012e4646bd84d09c5e8fa85a40
pkgname = telegram-desktop-dev
diff --git a/PKGBUILD b/PKGBUILD
index 839b150bbfd3..d31cb1b077c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,16 @@
# Thanks Nicholas Guriev <guriev-ns@ya.ru> for the initial patches!
# https://github.com/mymedia2/tdesktop
pkgname=telegram-desktop-dev
-pkgver=2.6.1
+pkgver=2.7.4
pkgrel=1
pkgdesc='Official Telegram Desktop client - development release'
arch=(x86_64)
url="https://desktop.telegram.org/"
license=('GPL3')
+# Although not in order, keeping them in the same order of the standard package
+# for my mental sanity.
depends=('hunspell' 'ffmpeg' 'hicolor-icon-theme' 'lz4' 'minizip' 'openal' 'ttf-opensans'
- 'qt5-imageformats' 'xxhash' 'libdbusmenu-qt5' 'kwayland' 'gtk3')
+ 'qt5-imageformats' 'xxhash' 'libdbusmenu-qt5' 'kwayland' 'gtk3' 'glibmm' 'webkit2gtk')
makedepends=('cmake' 'git' 'ninja' 'python' 'range-v3' 'tl-expected' 'microsoft-gsl' 'libtg_owt')
provides=(telegram-desktop)
@@ -55,6 +57,7 @@ source=(
"rlottie::git+https://github.com/desktop-app/rlottie.git"
"tgcalls::git+https://github.com/TelegramMessenger/tgcalls.git"
"xxHash::git+https://github.com/Cyan4973/xxHash.git"
+ "https://github.com/archlinux/svntogit-community/raw/packages/telegram-desktop/trunk/fix-webview-includes.patch"
)
sha512sums=('SKIP'
'SKIP'
@@ -86,7 +89,8 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '5492c73f0b984da1e2d1f21c3a36c11c4b9ad511522dccd4d6440681f68d6ebc9e672806a534b1e551f736f080d3ef307c8ddd012e4646bd84d09c5e8fa85a40')
prepare() {
cd "$srcdir/tdesktop"
@@ -138,7 +142,10 @@ prepare() {
# Official package patches
cd cmake
+ # force webrtc link to libjpeg
echo "target_link_libraries(external_webrtc INTERFACE jpeg)" | tee -a external/webrtc/CMakeLists.txt
+ cd ../Telegram/lib_webview
+ patch -Np1 -i "$srcdir"/fix-webview-includes.patch
}
build() {