summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-07-18 21:55:42 +0800
committerlilac2021-07-18 21:55:42 +0800
commit144c2945a6471eb2e49c31b2ba159dc01134efbc (patch)
treee37b19fbe3d2850a590bf5ec215d1986a876daad
parenta91fa74f63595a38b0f3cd42eb8ad4d62d6f97c3 (diff)
downloadaur-144c2945a6471eb2e49c31b2ba159dc01134efbc.tar.gz
[lilac] updated to 2.8.11.r0.g77d8c7ce0-2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 34 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 045a6b8d06a5..2670732b9ebe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = telegram-desktop-git
pkgdesc = Official Telegram Desktop client
- pkgver = 2.6.1.r33.gb24cba99e
- pkgrel = 1
+ pkgver = 2.8.11.r0.g77d8c7ce0
+ pkgrel = 2
url = https://desktop.telegram.org/
arch = x86_64
license = GPL3
@@ -12,6 +12,8 @@ pkgbase = telegram-desktop-git
makedepends = range-v3
makedepends = tl-expected
makedepends = microsoft-gsl
+ makedepends = extra-cmake-modules
+ makedepends = jemalloc
makedepends = libtg_owt-git
depends = hunspell
depends = ffmpeg
@@ -19,12 +21,18 @@ pkgbase = telegram-desktop-git
depends = lz4
depends = minizip
depends = openal
+ depends = ttf-opensans
depends = qt5-imageformats
depends = xxhash
depends = libdbusmenu-qt5
depends = kwayland
depends = gtk3
depends = glibmm
+ depends = webkit2gtk
+ depends = rnnoise
+ depends = pipewire
+ depends = libxtst
+ depends = libxrandr
optdepends = ttf-opensans: default Open Sans font family
provides = telegram-desktop
conflicts = telegram-desktop
@@ -60,6 +68,7 @@ pkgbase = telegram-desktop-git
source = telegram-desktop-fcitx5-qt::git+https://github.com/fcitx/fcitx5-qt.git
source = telegram-desktop-lib_webrtc::git+https://github.com/desktop-app/lib_webrtc.git
source = telegram-desktop-tgcalls::git+https://github.com/TelegramMessenger/tgcalls.git
+ source = fix-webview-extern-C-linkage.patch::https://patch-diff.githubusercontent.com/raw/desktop-app/lib_webview/pull/9.patch
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
@@ -92,6 +101,6 @@ pkgbase = telegram-desktop-git
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
+ sha512sums = 6f405d48457f8839c9759ec1024db20251f0d42a3ec0026d1334d56511877f830213ac4b3c2396319dc8811e330324a4d62a0973221e280063aa69c18fd09a0e
pkgname = telegram-desktop-git
-
diff --git a/PKGBUILD b/PKGBUILD
index af61510cc8d4..62ef58cf5225 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,18 @@
# Maintainer: Sven-Hendrik Haase <svenstaro@gmail.com>
# Contributor: hexchain <i@hexchain.org>
pkgname=telegram-desktop-git
-pkgver=2.6.1.r33.gb24cba99e
-pkgrel=1
+pkgver=2.8.11.r0.g77d8c7ce0
+pkgrel=2
pkgdesc='Official Telegram Desktop client'
arch=('x86_64')
url="https://desktop.telegram.org/"
license=('GPL3')
-depends=('hunspell' 'ffmpeg' 'hicolor-icon-theme' 'lz4' 'minizip' 'openal'
- 'qt5-imageformats' 'xxhash' 'libdbusmenu-qt5' 'kwayland' 'gtk3' 'glibmm')
-makedepends=('cmake' 'git' 'ninja' 'python' 'range-v3' 'tl-expected' 'microsoft-gsl' 'libtg_owt-git')
+depends=('hunspell' 'ffmpeg' 'hicolor-icon-theme' 'lz4' 'minizip' 'openal' 'ttf-opensans'
+ 'qt5-imageformats' 'xxhash' 'libdbusmenu-qt5' 'kwayland' 'gtk3' 'glibmm'
+ 'webkit2gtk' 'rnnoise' 'pipewire' 'libxtst' 'libxrandr' )
+makedepends=('cmake' 'git' 'ninja' 'python' 'range-v3' 'tl-expected' 'microsoft-gsl'
+ 'extra-cmake-modules' 'jemalloc'
+ 'libtg_owt-git')
optdepends=('ttf-opensans: default Open Sans font family')
provides=("telegram-desktop")
conflicts=("telegram-desktop")
@@ -45,6 +48,7 @@ source=("tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=dev"
"telegram-desktop-fcitx5-qt::git+https://github.com/fcitx/fcitx5-qt.git"
"telegram-desktop-lib_webrtc::git+https://github.com/desktop-app/lib_webrtc.git"
"telegram-desktop-tgcalls::git+https://github.com/TelegramMessenger/tgcalls.git"
+ "fix-webview-extern-C-linkage.patch::https://patch-diff.githubusercontent.com/raw/desktop-app/lib_webview/pull/9.patch"
)
sha512sums=('SKIP'
'SKIP'
@@ -77,7 +81,8 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '6f405d48457f8839c9759ec1024db20251f0d42a3ec0026d1334d56511877f830213ac4b3c2396319dc8811e330324a4d62a0973221e280063aa69c18fd09a0e')
pkgver() {
cd "$srcdir/tdesktop"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
@@ -120,8 +125,18 @@ prepare() {
git submodule update
cd cmake
- # force webrtc link to libjpeg
+ # force webrtc link to libjpeg and X11 libs
echo "target_link_libraries(external_webrtc INTERFACE jpeg)" | tee -a external/webrtc/CMakeLists.txt
+ echo "find_package(X11 REQUIRED COMPONENTS Xcomposite Xdamage Xext Xfixes Xrender Xrandr Xtst)" | tee -a external/webrtc/CMakeLists.txt
+ echo "target_link_libraries(external_webrtc INTERFACE Xcomposite Xdamage Xext Xfixes Xrandr Xrender Xtst)" | tee -a external/webrtc/CMakeLists.txt
+
+ cd ..
+ # fix extern "C" linkage with lib_webview
+ patch -b -d Telegram/lib_webview/ -Np1 -i ${srcdir}/fix-webview-extern-C-linkage.patch
+
+ # cp libjemalloc from jemalloc package
+ mkdir -p external/jemalloc/jemalloc-prefix/src/jemalloc/lib/
+ cp /usr/lib/libjemalloc_pic.a external/jemalloc/jemalloc-prefix/src/jemalloc/lib/libjemalloc.a
}
build() {