summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLenovsky2018-08-11 11:38:58 +0200
committerLenovsky2018-08-11 11:38:58 +0200
commit2199e17d0f0f3aaad29b56b3dce70a5918c2bc41 (patch)
tree3381fb4c97561fe08e41228ec778924d85a02b25
parent99fb5f55f25c840c2c730b9166ddbff34b4873cb (diff)
downloadaur-2199e17d0f0f3aaad29b56b3dce70a5918c2bc41.tar.gz
Update submodules
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9179376f892f..5aa00c8eee4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -23,10 +23,11 @@ pkgbase = telegram-desktop-git
provides = telegram-desktop
conflicts = telegram-desktop
source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#branch=dev
- source = GSL::git+https://github.com/Microsoft/GSL.git
- source = libtgvoip::git+https://github.com/telegramdesktop/libtgvoip.git
- source = variant::git+https://github.com/mapbox/variant.git
source = Catch::git+https://github.com/philsquared/Catch
+ source = crl::git+https://github.com/telegramdesktop/crl.git
+ source = GSL::git+https://github.com/Microsoft/GSL.git
+ source = libtgvoip::git+https://github.com/telegramdesktop/libtgvoip
+ source = variant::git+https://github.com/mapbox/variant
source = CMakeLists.inj::https://git.archlinux.org/svntogit/community.git/plain/trunk/CMakeLists.inj?h=packages/telegram-desktop
source = tdesktop.patch::https://git.archlinux.org/svntogit/community.git/plain/trunk/tdesktop.patch?h=packages/telegram-desktop
source = libtgvoip.patch::https://git.archlinux.org/svntogit/community.git/plain/trunk/libtgvoip.patch?h=packages/telegram-desktop
@@ -36,6 +37,7 @@ pkgbase = telegram-desktop-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 28a25d482ae099077ff501d882408afe0aaf6fb45346bc3423c6de7c2ed4c437
sha256sums = e92e8bc6c84d783e2a5f8337628cfb345c06aa4e18778a84e29d4d6f8d83246e
sha256sums = 4dd2b1674b1a5bcfc5b640612278fe3a53b454192fbcc06b7476ff54ed6d2f6d
diff --git a/PKGBUILD b/PKGBUILD
index 8608e5d02e41..2e7a790fd665 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,10 +13,11 @@ optdepends=('libnotify: desktop notifications')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#branch=dev"
- "GSL::git+https://github.com/Microsoft/GSL.git"
- "libtgvoip::git+https://github.com/telegramdesktop/libtgvoip.git"
- "variant::git+https://github.com/mapbox/variant.git"
"Catch::git+https://github.com/philsquared/Catch"
+ "crl::git+https://github.com/telegramdesktop/crl.git"
+ "GSL::git+https://github.com/Microsoft/GSL.git"
+ "libtgvoip::git+https://github.com/telegramdesktop/libtgvoip"
+ "variant::git+https://github.com/mapbox/variant"
"CMakeLists.inj::https://git.archlinux.org/svntogit/community.git/plain/trunk/CMakeLists.inj?h=packages/telegram-desktop"
"tdesktop.patch::https://git.archlinux.org/svntogit/community.git/plain/trunk/tdesktop.patch?h=packages/telegram-desktop"
"libtgvoip.patch::https://git.archlinux.org/svntogit/community.git/plain/trunk/libtgvoip.patch?h=packages/telegram-desktop"
@@ -26,6 +27,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'28a25d482ae099077ff501d882408afe0aaf6fb45346bc3423c6de7c2ed4c437'
'e92e8bc6c84d783e2a5f8337628cfb345c06aa4e18778a84e29d4d6f8d83246e'
'4dd2b1674b1a5bcfc5b640612278fe3a53b454192fbcc06b7476ff54ed6d2f6d'
@@ -38,10 +40,11 @@ pkgver() {
prepare() {
cd "$srcdir/tdesktop"
git submodule init
+ git config submodule.Telegram/ThirdParty/Catch.url "$srcdir/Catch"
+ git config submodule.Telegram/ThirdParty/crl.url "$srcdir/crl"
git config submodule.Telegram/ThirdParty/GSL.url "$srcdir/GSL"
- git config submodule.Telegram/ThirdParty/variant.url "$srcdir/variant"
git config submodule.Telegram/ThirdParty/libtgvoip.url "$srcdir/libtgvoip"
- git config submodule.Telegram/ThirdParty/Catch.url "$srcdir/Catch"
+ git config submodule.Telegram/ThirdParty/variant.url "$srcdir/variant"
git submodule update
patch -Np1 -i "$srcdir/tdesktop.patch"