summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLenovsky2018-12-31 15:49:23 +0100
committerLenovsky2018-12-31 15:49:23 +0100
commit3c427f93d510add9d1dad2b5f92087d42e52fa49 (patch)
treede4eda59cc9d119a862fc5d1431aae728a727042
parent1d8d8b17c93b0be3d1ff631f047292acd9794c09 (diff)
downloadaur-3c427f93d510add9d1dad2b5f92087d42e52fa49.tar.gz
Set API_ID and API_HASH
Telegram requires to set API_ID and API_HASH but do not provide a way to receive a pair. The official API_ID seems to be 2040 while the API_HASH is "b18441a1ff607e10a989891a5462e627". Use the defaults for now but might at some point use the official ones as noted above. [1]: https://github.com/telegramdesktop/tdesktop/commit/65b2db216033aa08b7bc846df27843e566f08981 [2]: https://github.com/telegramdesktop/tdesktop/issues/4717
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 406b61171c0c..5deb11f30164 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -70,7 +70,10 @@ build() {
export EXTRA_FLAGS="-Winvalid-pch"
export CPPFLAGS="$CPPFLAGS $EXTRA_FLAGS"
export CXXFLAGS="$CXXFLAGS $EXTRA_FLAGS"
+
gyp \
+ -Dapi_id=17349 \
+ -Dapi_hash=344583e45741c457fe1862106095a5eb \
-Dbuild_defines=${GYP_DEFINES} \
-Gconfig=Release \
--depth=Telegram/gyp --generator-output=../.. -Goutput_dir=out Telegram/gyp/Telegram.gyp --format=cmake