summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbakatrouble2019-07-09 10:06:24 +0300
committerbakatrouble2019-07-09 10:06:24 +0300
commit7132cb99755a75ff4acdac3ec2f4968a7fbad643 (patch)
treedceeeae0734575dcff9e829a87bc26db88e9f614
parent7b1eeecc8e474bd734feb48a4eb8a0310782e701 (diff)
downloadaur-7132cb99755a75ff4acdac3ec2f4968a7fbad643.tar.gz
Update PKGBUILD
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 220adec721a1..edd2cbc04993 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# https://github.com/mymedia2/tdesktop
pkgname=telegram-desktop-git
-pkgver=1.7.10.r0.gadf5c8ec7
+pkgver=1.7.14.r1.g8008d8a3d
pkgrel=1
pkgdesc="Official Telegram Desktop client (dev branch)"
arch=('i686' 'x86_64')
@@ -25,7 +25,7 @@ source=("tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#branch=de
"GSL::git+https://github.com/Microsoft/GSL.git"
"crl::git+https://github.com/telegramdesktop/crl.git"
"xxHash::git+https://github.com/Cyan4973/xxHash.git"
- "qtlottie::git+https://github.com/telegramdesktop/qtlottie.git"
+ "rlottie::git+https://github.com/john-preston/rlottie.git"
"tg.protocol::https://git.archlinux.org/svntogit/community.git/plain/trunk/tg.protocol?h=packages/telegram-desktop"
"CMakeLists.inj::https://git.archlinux.org/svntogit/community.git/plain/trunk/CMakeLists.inj?h=packages/telegram-desktop"
"tdesktop.patch::https://git.archlinux.org/svntogit/community.git/plain/trunk/tdesktop.patch?h=packages/telegram-desktop"
@@ -34,7 +34,8 @@ source=("tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#branch=de
"demibold.patch::https://git.archlinux.org/svntogit/community.git/plain/trunk/demibold.patch?h=packages/telegram-desktop"
"Use-system-wide-font.patch::https://git.archlinux.org/svntogit/community.git/plain/trunk/Use-system-wide-font.patch?h=packages/telegram-desktop"
"tdesktop_lottie_animation_qtdebug.patch::https://git.archlinux.org/svntogit/community.git/plain/trunk/tdesktop_lottie_animation_qtdebug.patch?h=packages/telegram-desktop"
- "tdesktop_qtlottie_qtdebug.patch::https://git.archlinux.org/svntogit/community.git/plain/trunk/tdesktop_qtlottie_qtdebug.patch?h=packages/telegram-desktop")
+ "tdesktop-ffmpeg-fix-convertFromARGB32PM.patch::https://git.archlinux.org/svntogit/community.git/plain/trunk/tdesktop-ffmpeg-fix-convertFromARGB32PM.patch?h=packages/telegram-desktop"
+ "tdesktop-rlottie-static-qt.patch::https://git.archlinux.org/svntogit/community.git/plain/trunk/tdesktop-rlottie-static-qt.patch?h=packages/telegram-desktop")
sha512sums=('SKIP'
'SKIP'
'SKIP'
@@ -50,8 +51,9 @@ sha512sums=('SKIP'
'd60694dc701aa985b0e82a12c9732b945082470441c687b33167a94f94efcf253baf43bb7280ec160ba338485ee5c62de138e4804cae05f27cc5cf4298166d39'
'6d0bac5aa4c4992b5400a9a9318f7a4e92d5eab961917cf0b05cdd251ab66a77c52ec8fbef246e8019606a7624d7b5420b87f8153e071e9724c7d2f5c94e47c0'
'ce6be003220267bac5483caf8302b492e1581892bc36d35a61236ebf9f9d766b8bd2159557a1c36256aa85f461797a38bfaae57b12da7a72101b21c0b17ed653'
- '5703b8228ab26f736928b56b90947602e78774648ff354ae10a53ad4535289ac12c8b7a049cabaed7591909246987be403dc470d48dd72a9ec1ce776a2977a66'
- 'c101761ff0aa6d4be38d0159bee31d02f66cfda84dbfb614e35e8d1c8f73bd78346636764a823bf1ce33b5364e99ea71330de60e37190f78d55f25a183f0d0cc')
+ 'a83b80668b2dc2cc77c857069fdb45b487793fda01ad8a63bab66c6a1c71e5d032050e4ec7efb5b4c3216badc5377c856ef1f4a59c2e02b24ee53b1d83124bf3'
+ '0dec897774142a09835d36e4064132e92e9404081eb4cba33d7e2643de475ff195448b527181fdb444a15764960dfc55eb59964b77a09642310c7b8e8c236e73'
+ '1f7cecfc8698ff9e0abce87226e993e73fdf35111d037c2847f7a1f30e65483ab332e45a1bdb86f6ac4c420c1c1429ac20454655d0e982477e37b7c48f0b1599')
pkgver() {
cd "$srcdir/tdesktop"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
@@ -66,7 +68,7 @@ prepare() {
git config submodule.Telegram/ThirdParty/Catch.url "$srcdir/Catch2"
git config submodule.Telegram/ThirdParty/crl.url "$srcdir/crl"
git config submodule.Telegram/ThirdParty/xxHash.url "$srcdir/xxHash"
- git config submodule.Telegram/ThirdParty/qtlottie.url "$srcdir/qtlottie"
+ git config submodule.Telegram/ThirdParty/rlottie.url "$srcdir/rlottie"
git submodule update
patch -Np1 -i "$srcdir/tdesktop.patch"
@@ -74,10 +76,8 @@ prepare() {
patch -R -Np1 -i "$srcdir/demibold.patch"
patch -Np1 -i "$srcdir/Use-system-wide-font.patch"
patch -Np1 -i "$srcdir/tdesktop_lottie_animation_qtdebug.patch"
-
- cd "$srcdir/tdesktop"
- cd "Telegram/ThirdParty/qtlottie"
- patch -Np1 -i "$srcdir/tdesktop_qtlottie_qtdebug.patch"
+ patch -Np1 -i "$srcdir/tdesktop-ffmpeg-fix-convertFromARGB32PM.patch"
+ patch -Np1 -i "$srcdir/tdesktop-rlottie-static-qt.patch"
cd "$srcdir/tdesktop"
cd "Telegram/ThirdParty/libtgvoip"