summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2022-12-28 04:46:10 +0800
committerlilac2022-12-28 04:46:10 +0800
commitd0b0e41698a843d8639a7b99891397bbacb875db (patch)
tree273f00bce57f553c1758823a66aacec8bcc883ed
parent1f004ab99caf838fa55f1927bd53fbd5909abe52 (diff)
downloadaur-d0b0e41698a843d8639a7b99891397bbacb875db.tar.gz
[lilac] updated to 4.4.1.r107.g690e1013c-2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8571a248945b..335e53e93d44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = telegram-desktop-git
pkgdesc = Official Telegram Desktop client
- pkgver = 4.2.4.r1.g0fbb2e77f
- pkgrel = 1
+ pkgver = 4.4.1.r107.g690e1013c
+ pkgrel = 2
url = https://desktop.telegram.org/
arch = x86_64
license = GPL3
@@ -18,7 +18,7 @@ pkgbase = telegram-desktop-git
makedepends = plasma-wayland-protocols
makedepends = libtg_owt-git
depends = hunspell
- depends = ffmpeg4.4
+ depends = ffmpeg
depends = hicolor-icon-theme
depends = lz4
depends = minizip
@@ -29,7 +29,7 @@ pkgbase = telegram-desktop-git
depends = qt6-wayland
depends = qt6-5compat
depends = xxhash
- depends = glibmm
+ depends = glibmm-2.68
depends = rnnoise
depends = pipewire
depends = libxtst
@@ -37,6 +37,8 @@ pkgbase = telegram-desktop-git
depends = jemalloc
depends = abseil-cpp
depends = libdispatch
+ depends = openssl-1.1
+ depends = protobuf
optdepends = webkit2gtk: embedded browser features
optdepends = xdg-desktop-portal: desktop integration
provides = telegram-desktop
@@ -75,6 +77,8 @@ pkgbase = telegram-desktop-git
source = telegram-desktop-wayland-protocols::git+https://github.com/gitlab-freedesktop-mirrors/wayland-protocols.git
source = telegram-desktop-kimageformats::git+https://github.com/KDE/kimageformats.git
source = telegram-desktop-kcoreaddons::git+https://github.com/KDE/kcoreaddons.git
+ source = telegram-desktop-cld3::git+https://github.com/google/cld3.git
+ sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c13ffcfcef4c..20c71a462a5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Sven-Hendrik Haase <svenstaro@gmail.com>
# Contributor: hexchain <i@hexchain.org>
pkgname=telegram-desktop-git
-pkgver=4.2.4.r1.g0fbb2e77f
-pkgrel=1
+pkgver=4.4.1.r107.g690e1013c
+pkgrel=2
pkgdesc='Official Telegram Desktop client'
arch=('x86_64')
url="https://desktop.telegram.org/"
license=('GPL3')
-depends=('hunspell' 'ffmpeg4.4' 'hicolor-icon-theme' 'lz4' 'minizip' 'openal' 'ttf-opensans'
- 'qt6-imageformats' 'qt6-svg' 'qt6-wayland' 'qt6-5compat' 'xxhash' 'glibmm'
- 'rnnoise' 'pipewire' 'libxtst' 'libxrandr' 'jemalloc' 'abseil-cpp' 'libdispatch')
+depends=('hunspell' 'ffmpeg' 'hicolor-icon-theme' 'lz4' 'minizip' 'openal' 'ttf-opensans'
+ 'qt6-imageformats' 'qt6-svg' 'qt6-wayland' 'qt6-5compat' 'xxhash' 'glibmm-2.68'
+ 'rnnoise' 'pipewire' 'libxtst' 'libxrandr' 'jemalloc' 'abseil-cpp' 'libdispatch'
+ 'openssl-1.1' 'protobuf')
makedepends=('cmake' 'git' 'ninja' 'python' 'range-v3' 'tl-expected' 'microsoft-gsl' 'meson'
'extra-cmake-modules' 'wayland-protocols' 'plasma-wayland-protocols' 'libtg_owt-git')
optdepends=('webkit2gtk: embedded browser features'
'xdg-desktop-portal: desktop integration')
provides=("telegram-desktop")
conflicts=("telegram-desktop")
-_kcoreaddons_version="5.98.0"
## source array generated from:
# python -c 'import configparser, os.path; c=configparser.ConfigParser();c.read(".gitmodules"); print("\n".join(f"\t\"telegram-desktop-{path}::git+{u}\"" for s in c.sections() if (url:=c[s]["url"], path:=os.path.basename(c[s]["path"]), u:= url if url.endswith(".git") else url+".git")))'
source=("tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#branch=dev"
@@ -53,6 +53,7 @@ source=("tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#branch=de
"telegram-desktop-wayland-protocols::git+https://github.com/gitlab-freedesktop-mirrors/wayland-protocols.git"
"telegram-desktop-kimageformats::git+https://github.com/KDE/kimageformats.git"
"telegram-desktop-kcoreaddons::git+https://github.com/KDE/kcoreaddons.git"
+ "telegram-desktop-cld3::git+https://github.com/google/cld3.git"
)
sha512sums=('SKIP'
'SKIP'
@@ -87,6 +88,7 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
cd "$srcdir/tdesktop"
@@ -131,7 +133,8 @@ prepare() {
git config submodule.Telegram/ThirdParty/wayland-protocols.url "$srcdir/telegram-desktop-wayland-protocols"
git config submodule.Telegram/ThirdParty/kimageformats.url "$srcdir/telegram-desktop-kimageformats"
git config submodule.Telegram/ThirdParty/kcoreaddons.url "$srcdir/telegram-desktop-kcoreaddons"
- git submodule update
+ git config submodule.Telegram/ThirdParty/cld3.url "$srcdir/telegram-desktop-cld3"
+ git -c protocol.file.allow=always submodule update
}
build() {