summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHexchain Tong2017-02-21 12:42:55 +0800
committerHexchain Tong2017-02-21 12:42:55 +0800
commit0bca6bc5cf3c005985f6e21f6fdfc1c00bb7bf0e (patch)
tree11876469c73bc298ead61b9d245161c6faad02c5
parent952b9da77e5ffdbc55043a5772c35595c8fe978d (diff)
downloadaur-0bca6bc5cf3c005985f6e21f6fdfc1c00bb7bf0e.tar.gz
upgpkg
-rw-r--r--.SRCINFO14
-rw-r--r--Avoid-depending-on-static-libraries.patch4
-rw-r--r--Fix-desktop-integration-issues.patch13
-rw-r--r--PKGBUILD11
-rw-r--r--Reduce-number-of-libraries.patch104
5 files changed, 121 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae5b5d54c625..3f0741b64dfa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Feb 7 16:10:22 UTC 2017
+# Tue Feb 21 04:42:37 UTC 2017
pkgbase = telegram-desktop-systemqt
pkgdesc = Experimental build of Telegram Desktop (using system Qt)
- pkgver = 1.0.6
- pkgrel = 3
+ pkgver = 1.0.13
+ pkgrel = 1
url = https://desktop.telegram.org/
install = telegram-desktop.install
arch = i686
@@ -28,7 +28,7 @@ pkgbase = telegram-desktop-systemqt
optdepends = libappindicator-gtk3: AppIndicator tray icon
provides = telegram-desktop
conflicts = telegram-desktop
- source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.0.6
+ source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.0.13
source = telegramdesktop.desktop
source = tg.protocol
source = Avoid-depending-on-static-libraries.patch
@@ -36,15 +36,17 @@ pkgbase = telegram-desktop-systemqt
source = Flags-for-precompiled-header-and-MOC.patch
source = Fix-rcc-path.patch
source = Use-gtk3-headers.patch
+ source = Reduce-number-of-libraries.patch
source = CMakeLists.inj
sha256sums = SKIP
sha256sums = 41c22fae6ae757936741e63aec3d0f17cafe86b2d6153cdd1d01a5581e871f17
sha256sums = d4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb
- sha256sums = 386a9b3a68e82f6be5686f64736042c53eea398cc835f74bb198c34312198889
- sha256sums = 4e1c87bad5f2538bf9fce0b54e7f984d7f269e3b1f6e44e1097b8abcc28c68e0
+ sha256sums = 197159eca70fc4a3d55548842d3218bcd67394cb869f08825d8fc12cf7b050f8
+ sha256sums = 4e1938a5ddfcf8ac57bafa5f9ce80413665ac3b0ccd3c1853fe8f0835b91f468
sha256sums = 952c7590cb05354c70037745d980fa97c36e36f96a1fa7d0db29a5c6a1d8dbd1
sha256sums = cf4dbb293afdbfd226861a00a42790a15b23bea296eccf35853d104e07ea345a
sha256sums = 5f3ac7c08df0293bed626293dbfb6040764abf28899db7681572cfb1d8bcaa6e
+ sha256sums = 0442af5365a31de5a8e15de8a94f5c1192775fc4460b74c4045da99e548f045a
sha256sums = 7a06af83609168a8eaec59a65252caa41dcd0ecc805225886435eb65073e9c82
pkgname = telegram-desktop-systemqt
diff --git a/Avoid-depending-on-static-libraries.patch b/Avoid-depending-on-static-libraries.patch
index 64d580fa714d..afb0232f5e4d 100644
--- a/Avoid-depending-on-static-libraries.patch
+++ b/Avoid-depending-on-static-libraries.patch
@@ -146,12 +146,12 @@ diff --git a/Telegram/gyp/Telegram.gyp b/Telegram/gyp/Telegram.gyp
index 2503f1e..92415ea 100644
--- a/Telegram/gyp/Telegram.gyp
+++ b/Telegram/gyp/Telegram.gyp
-@@ -79,20 +79,16 @@
+@@ -79,20 +80,16 @@
],
'defines': [
- 'AL_LIBTYPE_STATIC',
- '<!@(python -c "for s in \'<(travis_defines)\'.split(\',\'): print(s)")',
+ '<!@(python -c "for s in \'<(build_defines)\'.split(\',\'): print(s)")',
+ 'TDESKTOP_DISABLE_AUTOUPDATE',
+ 'TDESKTOP_DISABLE_CRASH_REPORTS',
+ 'TDESKTOP_DISABLE_REGISTER_CUSTOM_SCHEME',
diff --git a/Fix-desktop-integration-issues.patch b/Fix-desktop-integration-issues.patch
index 277962a0dc8c..374c581a77f2 100644
--- a/Fix-desktop-integration-issues.patch
+++ b/Fix-desktop-integration-issues.patch
@@ -2,19 +2,6 @@ Description: Fix some problems with desktop integration which relate to names of
Author: Nicholas Guriev <guriev-ns@ya.ru>
Last-Update: 2017-01-26
-diff --git a/Telegram/SourceFiles/historywidget.cpp b/Telegram/SourceFiles/historywidget.cpp
-index 52c9add..78af10a 100644
---- a/Telegram/SourceFiles/historywidget.cpp
-+++ b/Telegram/SourceFiles/historywidget.cpp
-@@ -189,7 +189,7 @@ namespace {
- // is applied once for blocks list in a history and once for items list in the found block
- template <bool TopToBottom, typename T>
- int binarySearchBlocksOrItems(const T &list, int edge) {
-- auto start = 0, end = list.size();
-+ size_t start = 0, end = list.size();
- while (end - start > 1) {
- auto middle = (start + end) / 2;
- auto top = list[middle]->y;
diff --git a/Telegram/SourceFiles/pspecific_linux.cpp b/Telegram/SourceFiles/pspecific_linux.cpp
index 8b21afe..258b5bd 100644
--- a/Telegram/SourceFiles/pspecific_linux.cpp
diff --git a/PKGBUILD b/PKGBUILD
index 3398b94a4afb..b5a57f80d2f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# https://github.com/mymedia2/tdesktop
pkgname=telegram-desktop-systemqt
-pkgver=1.0.6
-pkgrel=3
+pkgver=1.0.13
+pkgrel=1
pkgdesc='Experimental build of Telegram Desktop (using system Qt)'
arch=('i686' 'x86_64')
url="https://desktop.telegram.org/"
@@ -25,16 +25,18 @@ source=(
"Flags-for-precompiled-header-and-MOC.patch"
"Fix-rcc-path.patch"
"Use-gtk3-headers.patch"
+ "Reduce-number-of-libraries.patch"
"CMakeLists.inj"
)
sha256sums=('SKIP'
'41c22fae6ae757936741e63aec3d0f17cafe86b2d6153cdd1d01a5581e871f17'
'd4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb'
- '386a9b3a68e82f6be5686f64736042c53eea398cc835f74bb198c34312198889'
- '4e1c87bad5f2538bf9fce0b54e7f984d7f269e3b1f6e44e1097b8abcc28c68e0'
+ '197159eca70fc4a3d55548842d3218bcd67394cb869f08825d8fc12cf7b050f8'
+ '4e1938a5ddfcf8ac57bafa5f9ce80413665ac3b0ccd3c1853fe8f0835b91f468'
'952c7590cb05354c70037745d980fa97c36e36f96a1fa7d0db29a5c6a1d8dbd1'
'cf4dbb293afdbfd226861a00a42790a15b23bea296eccf35853d104e07ea345a'
'5f3ac7c08df0293bed626293dbfb6040764abf28899db7681572cfb1d8bcaa6e'
+ '0442af5365a31de5a8e15de8a94f5c1192775fc4460b74c4045da99e548f045a'
'7a06af83609168a8eaec59a65252caa41dcd0ecc805225886435eb65073e9c82')
prepare() {
@@ -44,6 +46,7 @@ prepare() {
git apply "$srcdir/Flags-for-precompiled-header-and-MOC.patch"
git apply "$srcdir/Fix-rcc-path.patch"
git apply "$srcdir/Use-gtk3-headers.patch"
+ git apply "$srcdir/Reduce-number-of-libraries.patch"
}
build() {
diff --git a/Reduce-number-of-libraries.patch b/Reduce-number-of-libraries.patch
new file mode 100644
index 000000000000..a782e1c730c4
--- /dev/null
+++ b/Reduce-number-of-libraries.patch
@@ -0,0 +1,104 @@
+Description: Remove linking of unused libraries
+Author: Nicholas Guriev <guriev-ns@ya.ru>
+Last-Update: 2017-02-18
+
+diff --git a/Telegram/gyp/Telegram.gyp b/Telegram/gyp/Telegram.gyp
+index 603264b..830df69 100644
+--- a/Telegram/gyp/Telegram.gyp
++++ b/Telegram/gyp/Telegram.gyp
+@@ -76,7 +76,6 @@
+ 'codegen.gyp:codegen_style',
+ 'codegen.gyp:codegen_numbers',
+ 'codegen.gyp:MetaLang',
+- 'utils.gyp:Updater',
+ ],
+
+ 'defines': [
+diff --git a/Telegram/gyp/qt.gypi b/Telegram/gyp/qt.gypi
+index 1db05de..d322153 100644
+--- a/Telegram/gyp/qt.gypi
++++ b/Telegram/gyp/qt.gypi
+@@ -32,6 +32,5 @@
+ ],
+ },
+ 'qt_libs': [
+- 'Qt5PrintSupport',
+ 'Qt5Network',
+ 'Qt5Widgets',
+@@ -81,21 +80,8 @@
+ 'qt_lib_debug_postfix': '',
+ 'qt_lib_release_postfix': '',
+ 'qt_libs': [
+- 'Qt5XcbQpa',
+ '<@(qt_libs)',
+- 'Qt5DBus',
+ 'Qt5Core',
+- 'Xi',
+- 'Xext',
+- 'Xfixes',
+- 'SM',
+- 'ICE',
+- 'fontconfig',
+- 'expat',
+- 'freetype',
+- 'xcb-shm',
+- 'xcb-xfixes',
+- 'xcb-render',
+ ],
+ }],
+ ],
+@@ -120,11 +106,6 @@
+ 'qt_loc': '<(qt_loc_unix)',
+ }],
+ ],
+-
+- 'linux_path_xkbcommon%': '/usr/local',
+- 'linux_lib_ssl%': 'ssl',
+- 'linux_lib_crypto%': 'crypto',
+- 'linux_lib_icu%': 'icutu icui18n icuuc icudata',
+ },
+
+ 'configurations': {
+@@ -200,17 +181,9 @@
+ '<(qt_loc)/plugins/platforminputcontexts',
+ ],
+ 'libraries': [
+- 'xkbcommon',
+ '<@(qt_libs_release)',
+- '<(linux_lib_ssl)',
+- '<(linux_lib_crypto)',
+- '<!@(python -c "for s in \'<(linux_lib_icu)\'.split(\' \'): print(s)")',
+- 'xcb',
++ 'crypto',
+ 'X11',
+- 'X11-xcb',
+- 'dbus-1',
+- 'dl',
+- 'gthread-2.0',
+ 'glib-2.0',
+ 'pthread',
+ ],
+diff --git a/Telegram/gyp/telegram_linux.gypi b/Telegram/gyp/telegram_linux.gypi
+index 29386a9..63d26e4 100644
+--- a/Telegram/gyp/telegram_linux.gypi
++++ b/Telegram/gyp/telegram_linux.gypi
+@@ -50,19 +50,12 @@
+ '<(linux_path_breakpad)/lib',
+ ],
+ 'libraries': [
+- 'lzma',
+ 'openal',
+ 'avformat',
+ 'avcodec',
+ 'swresample',
+ 'swscale',
+ 'avutil',
+- 'opus',
+- 'va-x11',
+- 'va-drm',
+- 'va',
+- 'vdpau',
+- 'drm',
+ 'z',
+ 'minizip',
+ # '<!(pkg-config 2> /dev/null --libs <@(pkgconfig_libs))',