summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHexchain Tong2017-04-09 13:55:31 +0800
committerHexchain Tong2017-04-09 13:55:31 +0800
commit181edfccb921f80825c69592ff6c6a55f4ab0fce (patch)
treeb84b576618ef0edccfb835f3862ef189f2dc3ac3
parent6edc63b25be2f81c08d38461fcfcc57deb3e269e (diff)
downloadaur-181edfccb921f80825c69592ff6c6a55f4ab0fce.tar.gz
fix build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD3
-rw-r--r--aur-build-fixes.patch42
3 files changed, 20 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 905e7ef8ac74..43e676273f66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Apr 8 15:49:13 UTC 2017
+# Sun Apr 9 05:55:25 UTC 2017
pkgbase = telegram-desktop-systemqt
pkgdesc = Experimental build of Telegram Desktop (using system Qt)
pkgver = 1.0.29
@@ -44,7 +44,7 @@ pkgbase = telegram-desktop-systemqt
sha256sums = 41c22fae6ae757936741e63aec3d0f17cafe86b2d6153cdd1d01a5581e871f17
sha256sums = d4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb
sha256sums = 7a06af83609168a8eaec59a65252caa41dcd0ecc805225886435eb65073e9c82
- sha256sums = a3723a51c60417c4a0e0cf92976eaedc46cc448d81e6bb0fdd33a622c4a1b819
+ sha256sums = 25482c53c4596fe33f8a3ecde48a9ab008e425023168896c7102e3e8625cc75e
pkgname = telegram-desktop-systemqt
diff --git a/PKGBUILD b/PKGBUILD
index 2cddeac1b7f4..129752f8f332 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -34,7 +34,7 @@ sha256sums=('SKIP'
'41c22fae6ae757936741e63aec3d0f17cafe86b2d6153cdd1d01a5581e871f17'
'd4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb'
'7a06af83609168a8eaec59a65252caa41dcd0ecc805225886435eb65073e9c82'
- 'a3723a51c60417c4a0e0cf92976eaedc46cc448d81e6bb0fdd33a622c4a1b819')
+ '25482c53c4596fe33f8a3ecde48a9ab008e425023168896c7102e3e8625cc75e')
prepare() {
cd "$srcdir/tdesktop"
@@ -53,6 +53,7 @@ build() {
export CPPFLAGS="$CPPFLAGS $EXTRA_FLAGS"
export CXXFLAGS="$CXXFLAGS $EXTRA_FLAGS"
gyp \
+ -Dbuild_defines=${GYP_DEFINES:1} \
-Gconfig=Release \
--depth=Telegram/gyp --generator-output=../.. -Goutput_dir=out Telegram/gyp/Telegram.gyp --format=cmake
NUM=$((`wc -l < out/Release/CMakeLists.txt` - 2))
diff --git a/aur-build-fixes.patch b/aur-build-fixes.patch
index ce194471d44c..5dbaee6f306d 100644
--- a/aur-build-fixes.patch
+++ b/aur-build-fixes.patch
@@ -228,7 +228,7 @@ index 5d6830e9..c3f08d3f 100644
IMPLICIT_DEPENDS CXX "${_pch_header}"
COMMENT "Precompiling ${_name} for ${_target} (C++)")
diff --git a/Telegram/gyp/Telegram.gyp b/Telegram/gyp/Telegram.gyp
-index fb22932c..f4743e15 100644
+index a1805ebd..2ebb6d35 100644
--- a/Telegram/gyp/Telegram.gyp
+++ b/Telegram/gyp/Telegram.gyp
@@ -78,24 +78,16 @@
@@ -258,7 +258,7 @@ index fb22932c..f4743e15 100644
'<(submodules_loc)/GSL/include',
'<(submodules_loc)/variant/include',
diff --git a/Telegram/gyp/qt.gypi b/Telegram/gyp/qt.gypi
-index a3212210..213723c5 100644
+index c12e450b..7356778e 100644
--- a/Telegram/gyp/qt.gypi
+++ b/Telegram/gyp/qt.gypi
@@ -27,25 +27,21 @@
@@ -289,7 +289,7 @@ index a3212210..213723c5 100644
}]
]
},
-@@ -85,31 +81,11 @@
+@@ -85,32 +81,12 @@
],
}],
[ 'build_linux', {
@@ -325,7 +325,7 @@ index a3212210..213723c5 100644
],
}],
],
-@@ -139,11 +116,6 @@
+@@ -140,11 +116,6 @@
# '<!@(python <(DEPTH)/list_sources.py [sources] <(qt_moc_list_sources_arg))'
# where [sources] contains all your source files
'qt_moc_list_sources_arg': '--moc-prefix SHARED_INTERMEDIATE_DIR/<(_target_name)/moc/moc_',
@@ -337,7 +337,7 @@ index a3212210..213723c5 100644
},
'configurations': {
-@@ -192,13 +164,13 @@
+@@ -193,13 +164,13 @@
},
'include_dirs': [
@@ -351,14 +351,14 @@ index a3212210..213723c5 100644
+ '/usr/include/qt',
+ '/usr/include/qt/QtCore',
+ '/usr/include/qt/QtGui',
-+ '/usr/include/qt/QtCore/<(qt_version)/',
-+ '/usr/include/qt/QtGui/<(qt_version)/',
++ '/usr/include/qt/QtCore/<(qt_version)',
++ '/usr/include/qt/QtGui/<(qt_version)',
+ '/usr/include/qt/QtCore/<(qt_version)/QtCore',
+ '/usr/include/qt/QtGui/<(qt_version)/QtGui',
],
'library_dirs': [
'<(qt_loc)/lib',
-@@ -219,17 +191,9 @@
+@@ -220,11 +191,8 @@
'<(qt_loc)/plugins/platforminputcontexts',
],
'libraries': [
@@ -367,17 +367,11 @@ index a3212210..213723c5 100644
- '<(linux_lib_ssl)',
- '<(linux_lib_crypto)',
- '<!@(python -c "for s in \'<(linux_lib_icu)\'.split(\' \'): print(s)")',
-- 'xcb',
+ 'crypto',
+ 'xcb',
'X11',
-- 'X11-xcb',
-- 'dbus-1',
-- 'dl',
-- 'gthread-2.0',
- 'glib-2.0',
- 'pthread',
- ],
-@@ -237,7 +201,6 @@
+ 'X11-xcb',
+@@ -238,7 +206,6 @@
'<(qt_loc)/mkspecs/linux-g++',
],
'ldflags': [
@@ -385,7 +379,7 @@ index a3212210..213723c5 100644
'-pthread',
'-g',
'-rdynamic',
-@@ -259,11 +222,12 @@
+@@ -260,7 +227,7 @@
'<(SHARED_INTERMEDIATE_DIR)/<(_target_name)/moc/moc_<(RULE_INPUT_ROOT).cpp',
],
'action': [
@@ -394,11 +388,6 @@ index a3212210..213723c5 100644
# Silence "Note: No relevant classes found. No output generated."
'--no-notes',
-
-+ '<!@(echo $CPPFLAGS | grep -Po "[-]([IDU]\s*\S*|E)")',
- '<!@(python -c "for s in \'<@(_defines)\'.split(\' \'): print(\'-D\' + s)")',
- # '<!@(python -c "for s in \'<@(_include_dirs)\'.split(\' \'): print(\'-I\' + s)")',
- '<(RULE_INPUT_PATH)',
diff --git a/Telegram/gyp/qt_rcc.gypi b/Telegram/gyp/qt_rcc.gypi
index eebc6967..19a346fe 100644
--- a/Telegram/gyp/qt_rcc.gypi
@@ -433,7 +422,7 @@ index fde88dcd..ca149b85 100644
],
'cflags_c': [
diff --git a/Telegram/gyp/telegram_linux.gypi b/Telegram/gyp/telegram_linux.gypi
-index b42e7443..71e39897 100644
+index b42e7443..43163a4c 100644
--- a/Telegram/gyp/telegram_linux.gypi
+++ b/Telegram/gyp/telegram_linux.gypi
@@ -35,12 +35,14 @@
@@ -451,7 +440,7 @@ index b42e7443..71e39897 100644
'/usr/local/lib',
'<(linux_path_ffmpeg)/lib',
'<(linux_path_openal)/lib',
-@@ -50,30 +52,18 @@
+@@ -50,30 +52,19 @@
'<(linux_path_breakpad)/lib',
],
'libraries': [
@@ -480,6 +469,7 @@ index b42e7443..71e39897 100644
+ 'swscale',
+ 'avutil',
+ 'minizip',
++ 'z',
# '<!(pkg-config 2> /dev/null --libs <@(pkgconfig_libs))',
],
'cflags_cc': [
@@ -491,7 +481,7 @@ index b42e7443..71e39897 100644
],
'configurations': {
diff --git a/Telegram/gyp/telegram_sources.txt b/Telegram/gyp/telegram_sources.txt
-index 01f08e35..51c72634 100644
+index 6fa7b704..431fadd6 100644
--- a/Telegram/gyp/telegram_sources.txt
+++ b/Telegram/gyp/telegram_sources.txt
@@ -522,14 +522,7 @@