summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHaochen Tong2017-11-16 11:48:20 +0800
committerHaochen Tong2017-11-16 11:48:20 +0800
commit2df7857b346582f0f79b6cad48f17538b04f3876 (patch)
tree1d53b4c8ac0f3eb2e7f402e5ff684323bf5350e2
parent193829902c906e95537e15fbdb1f0aebba37db4a (diff)
downloadaur-2df7857b346582f0f79b6cad48f17538b04f3876.tar.gz
Backport IME fix
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--fix-ime-interrupt.patch31
3 files changed, 40 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b317297fc98a..af954a5e4d49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Oct 22 05:21:50 UTC 2017
+# Thu Nov 16 03:48:04 UTC 2017
pkgbase = telegram-desktop-systemqt
pkgdesc = Experimental build of Telegram Desktop (using system Qt)
pkgver = 1.1.23
- pkgrel = 1
+ pkgrel = 2
url = https://desktop.telegram.org/
install = telegram-desktop.install
arch = i686
@@ -40,6 +40,7 @@ pkgbase = telegram-desktop-systemqt
source = CMakeLists.inj
source = tdesktop.patch
source = libtgvoip.patch
+ source = fix-ime-interrupt.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -49,6 +50,7 @@ pkgbase = telegram-desktop-systemqt
sha256sums = 7a06af83609168a8eaec59a65252caa41dcd0ecc805225886435eb65073e9c82
sha256sums = 6ff8119878ada407605fad8ca6cee7292e0d29e8a72b4a243a2bb7e2b5fd4c9b
sha256sums = 0e55b150b91aeeddcb813fb242a62fe4d1977bcac457eb9d65997faef643f075
+ sha256sums = 024b365d0bc925e6435ef6dd64da66c93ed9f79ac368e7412c1d7bb153edafd6
pkgname = telegram-desktop-systemqt
diff --git a/PKGBUILD b/PKGBUILD
index cbb4be60e7d1..5ce2d88816f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=telegram-desktop-systemqt
pkgver=1.1.23
-pkgrel=1
+pkgrel=2
pkgdesc='Experimental build of Telegram Desktop (using system Qt)'
arch=('i686' 'x86_64')
url="https://desktop.telegram.org/"
@@ -29,6 +29,7 @@ source=(
"CMakeLists.inj"
"tdesktop.patch"
"libtgvoip.patch"
+ "fix-ime-interrupt.patch"
)
sha256sums=('SKIP'
'SKIP'
@@ -38,7 +39,8 @@ sha256sums=('SKIP'
'd4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb'
'7a06af83609168a8eaec59a65252caa41dcd0ecc805225886435eb65073e9c82'
'6ff8119878ada407605fad8ca6cee7292e0d29e8a72b4a243a2bb7e2b5fd4c9b'
- '0e55b150b91aeeddcb813fb242a62fe4d1977bcac457eb9d65997faef643f075')
+ '0e55b150b91aeeddcb813fb242a62fe4d1977bcac457eb9d65997faef643f075'
+ '024b365d0bc925e6435ef6dd64da66c93ed9f79ac368e7412c1d7bb153edafd6')
prepare() {
cd "$srcdir/tdesktop"
@@ -48,6 +50,7 @@ prepare() {
git config submodule.Telegram/ThirdParty/libtgvoip.url "$srcdir/libtgvoip"
git submodule update
patch -Np1 -i "$srcdir/tdesktop.patch"
+ patch -Np1 -i "$srcdir/fix-ime-interrupt.patch"
cd "Telegram/ThirdParty/libtgvoip"
patch -Np1 -i "$srcdir/libtgvoip.patch"
diff --git a/fix-ime-interrupt.patch b/fix-ime-interrupt.patch
new file mode 100644
index 000000000000..535ff015f41a
--- /dev/null
+++ b/fix-ime-interrupt.patch
@@ -0,0 +1,31 @@
+From 11a46a1072114a20258cf4da849e66787c8d046d Mon Sep 17 00:00:00 2001
+From: Yonsh Lin <yonsh@live.com>
+Date: Thu, 7 Sep 2017 21:39:12 +0800
+Subject: [PATCH] Fix IME being interrupted after reconnection Signed-off-by:
+ Yonsh Lin <yonsh@live.com> (github: yonsh)
+
+---
+ Telegram/SourceFiles/mainwindow.cpp | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Telegram/SourceFiles/mainwindow.cpp b/Telegram/SourceFiles/mainwindow.cpp
+index 0798d184d..00682cbea 100644
+--- a/Telegram/SourceFiles/mainwindow.cpp
++++ b/Telegram/SourceFiles/mainwindow.cpp
+@@ -460,6 +460,7 @@ void MainWindow::ui_hideMediaPreview() {
+ void MainWindow::showConnecting(const QString &text, const QString &reconnect) {
+ if (_connecting) {
+ _connecting->set(text, reconnect);
++ _connecting->show();
+ } else {
+ _connecting.create(bodyWidget(), text, reconnect);
+ _connecting->show();
+@@ -470,7 +471,7 @@ void MainWindow::showConnecting(const QString &text, const QString &reconnect) {
+
+ void MainWindow::hideConnecting() {
+ if (_connecting) {
+- _connecting.destroyDelayed();
++ _connecting->hide();
+ }
+ }
+