summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHexchain Tong2017-05-15 14:22:09 +0800
committerHexchain Tong2017-05-15 14:38:28 +0800
commit4377c457507c52d9d88151a02e05575674477ef5 (patch)
tree4917b3451aebf44c22975a33ca829bec22f78578
parent536d94ec8f04218cdf18bba4a3ed202f75de4cd2 (diff)
downloadaur-4377c457507c52d9d88151a02e05575674477ef5.tar.gz
upgpkg
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
-rw-r--r--libtgvoip.patch13
-rw-r--r--tdesktop.patch (renamed from aur-build-fixes.patch)37
4 files changed, 59 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f5a99ccfa18..db68c6cc0d7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Apr 15 06:35:37 UTC 2017
+# Mon May 15 06:38:18 UTC 2017
pkgbase = telegram-desktop-systemqt
pkgdesc = Experimental build of Telegram Desktop (using system Qt)
- pkgver = 1.0.32
+ pkgver = 1.1.0
pkgrel = 1
url = https://desktop.telegram.org/
install = telegram-desktop.install
@@ -31,20 +31,24 @@ pkgbase = telegram-desktop-systemqt
optdepends = libappindicator-gtk3: AppIndicator tray icon
provides = telegram-desktop
conflicts = telegram-desktop
- source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.0.32
+ source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.1.0
source = GSL::git+https://github.com/Microsoft/GSL.git
+ source = libtgvoip::git+https://github.com/telegramdesktop/libtgvoip.git
source = variant::git+https://github.com/mapbox/variant.git
source = telegramdesktop.desktop
source = tg.protocol
source = CMakeLists.inj
- source = aur-build-fixes.patch
+ source = tdesktop.patch
+ source = libtgvoip.patch
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 41c22fae6ae757936741e63aec3d0f17cafe86b2d6153cdd1d01a5581e871f17
sha256sums = d4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb
sha256sums = 7a06af83609168a8eaec59a65252caa41dcd0ecc805225886435eb65073e9c82
- sha256sums = 25482c53c4596fe33f8a3ecde48a9ab008e425023168896c7102e3e8625cc75e
+ sha256sums = 64356cbf94dd13cc81df1f8c3cb48a51a0f9b05a3c6b112ad452252c7348cfec
+ sha256sums = 3d72e09b9054ff75785a85c9f24ee82d48a2b9bf0ce8515156717b20157a45b3
pkgname = telegram-desktop-systemqt
diff --git a/PKGBUILD b/PKGBUILD
index e11ece7f2082..971dd4044878 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# https://github.com/mymedia2/tdesktop
pkgname=telegram-desktop-systemqt
-pkgver=1.0.32
+pkgver=1.1.0
pkgrel=1
pkgdesc='Experimental build of Telegram Desktop (using system Qt)'
arch=('i686' 'x86_64')
@@ -22,27 +22,35 @@ install="telegram-desktop.install"
source=(
"tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v$pkgver"
"GSL::git+https://github.com/Microsoft/GSL.git"
+ "libtgvoip::git+https://github.com/telegramdesktop/libtgvoip.git"
"variant::git+https://github.com/mapbox/variant.git"
"telegramdesktop.desktop"
"tg.protocol"
"CMakeLists.inj"
- "aur-build-fixes.patch"
+ "tdesktop.patch"
+ "libtgvoip.patch"
)
sha256sums=('SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'41c22fae6ae757936741e63aec3d0f17cafe86b2d6153cdd1d01a5581e871f17'
'd4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb'
'7a06af83609168a8eaec59a65252caa41dcd0ecc805225886435eb65073e9c82'
- '25482c53c4596fe33f8a3ecde48a9ab008e425023168896c7102e3e8625cc75e')
+ '64356cbf94dd13cc81df1f8c3cb48a51a0f9b05a3c6b112ad452252c7348cfec'
+ '3d72e09b9054ff75785a85c9f24ee82d48a2b9bf0ce8515156717b20157a45b3')
prepare() {
cd "$srcdir/tdesktop"
git submodule init
- git config submodule.third_party/GSL.url "$srcdir/GSL"
- git config submodule.third_party/variant.url "$srcdir/variant"
+ git config submodule.Telegram/ThirdParty/GSL.url "$srcdir/GSL"
+ git config submodule.Telegram/ThirdParty/variant.url "$srcdir/variant"
+ git config submodule.Telegram/ThirdParty/libtgvoip.url "$srcdir/libtgvoip"
git submodule update
- patch -Np1 -i "../aur-build-fixes.patch"
+ patch -Np1 -i "$srcdir/tdesktop.patch"
+
+ cd "Telegram/ThirdParty/libtgvoip"
+ patch -Np1 -i "$srcdir/libtgvoip.patch"
}
build() {
diff --git a/libtgvoip.patch b/libtgvoip.patch
new file mode 100644
index 000000000000..afb96146ef40
--- /dev/null
+++ b/libtgvoip.patch
@@ -0,0 +1,13 @@
+diff --git a/libtgvoip.gyp b/libtgvoip.gyp
+index 58dc6bf..98a09d7 100644
+--- a/libtgvoip.gyp
++++ b/libtgvoip.gyp
+@@ -13,7 +13,7 @@
+ 'variables': {
+ 'tgvoip_src_loc': '.',
+ 'official_build_target%': '',
+- 'linux_path_opus_include%': '<(DEPTH)/../../../Libraries/opus/include',
++ 'linux_path_opus_include%': '/usr/include/opus',
+ },
+ 'include_dirs': [
+ '<(tgvoip_src_loc)/webrtc_dsp',
diff --git a/aur-build-fixes.patch b/tdesktop.patch
index 3616792b5479..9e3684f8aeff 100644
--- a/aur-build-fixes.patch
+++ b/tdesktop.patch
@@ -158,7 +158,7 @@ index 1d4896a6..f2f876b3 100644
-Q_IMPORT_PLUGIN(QFcitxPlatformInputContextPlugin)
#endif // Q_OS_WIN | Q_OS_MAC | Q_OS_LINUX
diff --git a/Telegram/SourceFiles/ui/text/text.cpp b/Telegram/SourceFiles/ui/text/text.cpp
-index 089a17ff..a3b979c4 100644
+index dbc2b0db..61fa93c9 100644
--- a/Telegram/SourceFiles/ui/text/text.cpp
+++ b/Telegram/SourceFiles/ui/text/text.cpp
@@ -1692,11 +1692,11 @@ private:
@@ -190,10 +190,10 @@ index f89644e1..35230cfc 100644
layout.createLine();
diff --git a/Telegram/SourceFiles/ui/twidget.cpp b/Telegram/SourceFiles/ui/twidget.cpp
-index abfcd27e..1e1049b2 100644
+index 04fad32b..688cd8e0 100644
--- a/Telegram/SourceFiles/ui/twidget.cpp
+++ b/Telegram/SourceFiles/ui/twidget.cpp
-@@ -107,9 +107,9 @@ void sendSynteticMouseEvent(QWidget *widget, QEvent::Type type, Qt::MouseButton
+@@ -187,9 +187,9 @@ void sendSynteticMouseEvent(QWidget *widget, QEvent::Type type, Qt::MouseButton
, button
, QGuiApplication::mouseButtons() | button
, QGuiApplication::keyboardModifiers()
@@ -228,21 +228,23 @@ index 5d6830e9..c3f08d3f 100644
IMPLICIT_DEPENDS CXX "${_pch_header}"
COMMENT "Precompiling ${_name} for ${_target} (C++)")
diff --git a/Telegram/gyp/Telegram.gyp b/Telegram/gyp/Telegram.gyp
-index 5b7ead4d..ecf80a6a 100644
+index 80160d16..8789e874 100644
--- a/Telegram/gyp/Telegram.gyp
+++ b/Telegram/gyp/Telegram.gyp
-@@ -78,24 +78,16 @@
+@@ -78,12 +78,10 @@
'codegen.gyp:codegen_lang',
'codegen.gyp:codegen_numbers',
'codegen.gyp:codegen_style',
- 'utils.gyp:Updater',
+ '../ThirdParty/libtgvoip/libtgvoip.gyp:libtgvoip',
],
'defines': [
- 'AL_LIBTYPE_STATIC',
+ 'AL_ALEXT_PROTOTYPES',
+ 'TGVOIP_USE_CXX11_LIB',
'<!@(python -c "for s in \'<(build_defines)\'.split(\',\'): print(s)")',
- ],
-
+@@ -92,14 +90,7 @@
'include_dirs': [
'<(src_loc)',
'<(SHARED_INTERMEDIATE_DIR)',
@@ -252,13 +254,14 @@ index 5b7ead4d..ecf80a6a 100644
- '<(libs_loc)/zlib-1.2.8',
- '<(libs_loc)/ffmpeg',
- '<(libs_loc)/openal-soft/include',
+- '<(libs_loc)/opus/include',
- '<(minizip_loc)',
+ '/usr/include/minizip',
'<(sp_media_key_tap_loc)',
'<(submodules_loc)/GSL/include',
'<(submodules_loc)/variant/include',
diff --git a/Telegram/gyp/qt.gypi b/Telegram/gyp/qt.gypi
-index c12e450b..7356778e 100644
+index 81c13a18..1af2e86e 100644
--- a/Telegram/gyp/qt.gypi
+++ b/Telegram/gyp/qt.gypi
@@ -27,25 +27,21 @@
@@ -422,25 +425,30 @@ index fde88dcd..ca149b85 100644
],
'cflags_c': [
diff --git a/Telegram/gyp/telegram_linux.gypi b/Telegram/gyp/telegram_linux.gypi
-index b42e7443..e2da0f31 100644
+index b8866ec2..b505a67d 100644
--- a/Telegram/gyp/telegram_linux.gypi
+++ b/Telegram/gyp/telegram_linux.gypi
-@@ -35,12 +35,14 @@
+@@ -33,9 +33,10 @@
+ 'linux_path_va%': '/usr/local',
+ 'linux_path_vdpau%': '/usr/local',
'linux_path_breakpad%': '<(libs_loc)/breakpad',
+- 'linux_path_opus_include%': '<(libs_loc)/opus/include',
++ 'linux_path_opus_include%': '/usr/include/opus',
},
'include_dirs': [
+ '/usr/include/openssl-1.0',
'/usr/local/include',
'<(linux_path_ffmpeg)/include',
'<(linux_path_openal)/include',
- '<(linux_path_breakpad)/include/breakpad',
+@@ -43,6 +44,7 @@
+ '<(linux_path_opus_include)',
],
'library_dirs': [
+ '/usr/lib/openssl-1.0',
'/usr/local/lib',
'<(linux_path_ffmpeg)/lib',
'<(linux_path_openal)/lib',
-@@ -50,30 +52,19 @@
+@@ -52,30 +54,20 @@
'<(linux_path_breakpad)/lib',
],
'libraries': [
@@ -469,6 +477,7 @@ index b42e7443..e2da0f31 100644
+ 'swscale',
+ 'avutil',
+ 'minizip',
++ 'opus',
+ 'z',
# '<!(pkg-config 2> /dev/null --libs <@(pkgconfig_libs))',
],
@@ -481,10 +490,10 @@ index b42e7443..e2da0f31 100644
],
'configurations': {
diff --git a/Telegram/gyp/telegram_sources.txt b/Telegram/gyp/telegram_sources.txt
-index a08b77b7..fa91d444 100644
+index c970f984..cb5f225c 100644
--- a/Telegram/gyp/telegram_sources.txt
+++ b/Telegram/gyp/telegram_sources.txt
-@@ -534,14 +534,7 @@
+@@ -552,14 +552,7 @@
<(src_loc)/structs.cpp
<(src_loc)/structs.h