summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHaochen Tong2017-08-06 17:25:34 +0800
committerHaochen Tong2017-08-06 17:25:34 +0800
commita4ba392309116003bc2b75c1c4c12dc733168d6f (patch)
tree0564ece87e4c8678235ff2e78036b7e5e5ae4d80
parent8862fba0378a4dad2644df59bf0a9120e9a1066c (diff)
downloadaur-a4ba392309116003bc2b75c1c4c12dc733168d6f.tar.gz
upgpkg
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--libtgvoip.patch2
-rw-r--r--tdesktop.patch24
4 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e7a926e268e..429cbe4bd9a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Jul 31 03:24:59 UTC 2017
+# Sun Aug 6 09:24:54 UTC 2017
pkgbase = telegram-desktop-systemqt
pkgdesc = Experimental build of Telegram Desktop (using system Qt)
- pkgver = 1.1.18
+ pkgver = 1.1.19
pkgrel = 1
url = https://desktop.telegram.org/
install = telegram-desktop.install
@@ -31,7 +31,7 @@ pkgbase = telegram-desktop-systemqt
optdepends = libappindicator-gtk3: AppIndicator tray icon
provides = telegram-desktop
conflicts = telegram-desktop
- source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.1.18
+ source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.1.19
source = GSL::git+https://github.com/Microsoft/GSL.git
source = libtgvoip::git+https://github.com/telegramdesktop/libtgvoip.git
source = variant::git+https://github.com/mapbox/variant.git
@@ -47,8 +47,8 @@ pkgbase = telegram-desktop-systemqt
sha256sums = 41c22fae6ae757936741e63aec3d0f17cafe86b2d6153cdd1d01a5581e871f17
sha256sums = d4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb
sha256sums = 7a06af83609168a8eaec59a65252caa41dcd0ecc805225886435eb65073e9c82
- sha256sums = 6d54c8b51b2224c75c15d1e147855a6f22b96848ca3413330882ca6243dd05cb
- sha256sums = 640ef297f5977de78dab17789390e628b8f7a8a495529c24da8a43693f3fae23
+ sha256sums = 8532262ca8876bed0b347115fb87453885e6150ebc3995e2daa5d38a4f318ae5
+ sha256sums = 0e55b150b91aeeddcb813fb242a62fe4d1977bcac457eb9d65997faef643f075
pkgname = telegram-desktop-systemqt
diff --git a/PKGBUILD b/PKGBUILD
index 1eac4bcfd5be..634f7610295b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# https://github.com/mymedia2/tdesktop
pkgname=telegram-desktop-systemqt
-pkgver=1.1.18
+pkgver=1.1.19
pkgrel=1
pkgdesc='Experimental build of Telegram Desktop (using system Qt)'
arch=('i686' 'x86_64')
@@ -37,8 +37,8 @@ sha256sums=('SKIP'
'41c22fae6ae757936741e63aec3d0f17cafe86b2d6153cdd1d01a5581e871f17'
'd4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb'
'7a06af83609168a8eaec59a65252caa41dcd0ecc805225886435eb65073e9c82'
- '6d54c8b51b2224c75c15d1e147855a6f22b96848ca3413330882ca6243dd05cb'
- '640ef297f5977de78dab17789390e628b8f7a8a495529c24da8a43693f3fae23')
+ '8532262ca8876bed0b347115fb87453885e6150ebc3995e2daa5d38a4f318ae5'
+ '0e55b150b91aeeddcb813fb242a62fe4d1977bcac457eb9d65997faef643f075')
prepare() {
cd "$srcdir/tdesktop"
diff --git a/libtgvoip.patch b/libtgvoip.patch
index 91c3740bfcc9..6bd2aebb419b 100644
--- a/libtgvoip.patch
+++ b/libtgvoip.patch
@@ -1,5 +1,5 @@
diff --git a/libtgvoip.gyp b/libtgvoip.gyp
-index 58dc6bf..98a09d7 100644
+index 52fbea1..9a4dfb7 100644
--- a/libtgvoip.gyp
+++ b/libtgvoip.gyp
@@ -13,11 +13,12 @@
diff --git a/tdesktop.patch b/tdesktop.patch
index be5edec2e756..7921721e3eff 100644
--- a/tdesktop.patch
+++ b/tdesktop.patch
@@ -159,10 +159,10 @@ index b975c7a8..f2f876b3 100644
-Q_IMPORT_PLUGIN(QHimePlatformInputContextPlugin)
#endif // Q_OS_WIN | Q_OS_MAC | Q_OS_LINUX
diff --git a/Telegram/SourceFiles/ui/text/text.cpp b/Telegram/SourceFiles/ui/text/text.cpp
-index 044f8716..0865a5bb 100644
+index d18a8ea5..2c58287e 100644
--- a/Telegram/SourceFiles/ui/text/text.cpp
+++ b/Telegram/SourceFiles/ui/text/text.cpp
-@@ -1692,11 +1692,11 @@ private:
+@@ -1689,11 +1689,11 @@ private:
if (item == -1)
return;
@@ -175,8 +175,8 @@ index 044f8716..0865a5bb 100644
-#endif // OS_MAC_OLD
+#endif
- int blockIndex = _lineStartBlock;
- ITextBlock *currentBlock = _t->_blocks[blockIndex];
+ auto blockIndex = _lineStartBlock;
+ auto currentBlock = _t->_blocks[blockIndex].get();
diff --git a/Telegram/SourceFiles/ui/text/text_block.cpp b/Telegram/SourceFiles/ui/text/text_block.cpp
index f89644e1..35230cfc 100644
--- a/Telegram/SourceFiles/ui/text/text_block.cpp
@@ -229,10 +229,10 @@ index 5d6830e9..c3f08d3f 100644
IMPLICIT_DEPENDS CXX "${_pch_header}"
COMMENT "Precompiling ${_name} for ${_target} (C++)")
diff --git a/Telegram/gyp/Telegram.gyp b/Telegram/gyp/Telegram.gyp
-index 80160d16..8789e874 100644
+index 9d92b817..e5c81e12 100644
--- a/Telegram/gyp/Telegram.gyp
+++ b/Telegram/gyp/Telegram.gyp
-@@ -78,12 +78,10 @@
+@@ -79,12 +79,10 @@
'codegen.gyp:codegen_lang',
'codegen.gyp:codegen_numbers',
'codegen.gyp:codegen_style',
@@ -245,7 +245,7 @@ index 80160d16..8789e874 100644
'AL_ALEXT_PROTOTYPES',
'TGVOIP_USE_CXX11_LIB',
'<!@(python -c "for s in \'<(build_defines)\'.split(\',\'): print(s)")',
-@@ -92,14 +90,7 @@
+@@ -93,14 +91,7 @@
'include_dirs': [
'<(src_loc)',
'<(SHARED_INTERMEDIATE_DIR)',
@@ -259,8 +259,8 @@ index 80160d16..8789e874 100644
- '<(minizip_loc)',
+ '/usr/include/minizip',
'<(sp_media_key_tap_loc)',
+ '<(emoji_suggestions_loc)',
'<(submodules_loc)/GSL/include',
- '<(submodules_loc)/variant/include',
diff --git a/Telegram/gyp/qt.gypi b/Telegram/gyp/qt.gypi
index 81c13a18..99af0edb 100644
--- a/Telegram/gyp/qt.gypi
@@ -492,12 +492,12 @@ index 2c464928..b505a67d 100644
],
'configurations': {
diff --git a/Telegram/gyp/telegram_sources.txt b/Telegram/gyp/telegram_sources.txt
-index fbe63ec5..475210b3 100644
+index 40556793..b42767e3 100644
--- a/Telegram/gyp/telegram_sources.txt
+++ b/Telegram/gyp/telegram_sources.txt
-@@ -580,14 +580,7 @@
- <(src_loc)/structs.cpp
- <(src_loc)/structs.h
+@@ -587,14 +587,7 @@
+ <(emoji_suggestions_loc)/emoji_suggestions.cpp
+ <(emoji_suggestions_loc)/emoji_suggestions.h
-platforms: !win
-<(minizip_loc)/crypt.h