summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHaochen Tong2017-07-07 00:43:09 +0800
committerHaochen Tong2017-07-07 00:43:09 +0800
commite59a888c2da666c157719b5bbad5a7ee7d5072fb (patch)
tree9990e63b4a98d1293133be2432ec79d334542f0d
parent3367092f4830301d9c802023cb4e9bf8a7429989 (diff)
downloadaur-e59a888c2da666c157719b5bbad5a7ee7d5072fb.tar.gz
upgpkg
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rw-r--r--tdesktop.patch24
3 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a6ec27f1b69..c49f4962e94d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Jun 13 02:36:57 UTC 2017
+# Thu Jul 6 16:43:06 UTC 2017
pkgbase = telegram-desktop-systemqt
pkgdesc = Experimental build of Telegram Desktop (using system Qt)
- pkgver = 1.1.7
+ pkgver = 1.1.9
pkgrel = 1
url = https://desktop.telegram.org/
install = telegram-desktop.install
@@ -31,7 +31,7 @@ pkgbase = telegram-desktop-systemqt
optdepends = libappindicator-gtk3: AppIndicator tray icon
provides = telegram-desktop
conflicts = telegram-desktop
- source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.1.7
+ source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.1.9
source = GSL::git+https://github.com/Microsoft/GSL.git
source = libtgvoip::git+https://github.com/telegramdesktop/libtgvoip.git
source = variant::git+https://github.com/mapbox/variant.git
@@ -47,7 +47,7 @@ pkgbase = telegram-desktop-systemqt
sha256sums = 41c22fae6ae757936741e63aec3d0f17cafe86b2d6153cdd1d01a5581e871f17
sha256sums = d4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb
sha256sums = 7a06af83609168a8eaec59a65252caa41dcd0ecc805225886435eb65073e9c82
- sha256sums = 9d1e3c21fc21ba59f57bad64f320b32f21ffc4915841634175ccb46c60d4af9f
+ sha256sums = 0aa02c2dc2cb4a32519de43a9f188d924b9a3458fdd941e733a17d54ec3db8ed
sha256sums = 3d72e09b9054ff75785a85c9f24ee82d48a2b9bf0ce8515156717b20157a45b3
pkgname = telegram-desktop-systemqt
diff --git a/PKGBUILD b/PKGBUILD
index 1a7a6645128f..032d8304234d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# https://github.com/mymedia2/tdesktop
pkgname=telegram-desktop-systemqt
-pkgver=1.1.7
+pkgver=1.1.9
pkgrel=1
pkgdesc='Experimental build of Telegram Desktop (using system Qt)'
arch=('i686' 'x86_64')
@@ -37,7 +37,7 @@ sha256sums=('SKIP'
'41c22fae6ae757936741e63aec3d0f17cafe86b2d6153cdd1d01a5581e871f17'
'd4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb'
'7a06af83609168a8eaec59a65252caa41dcd0ecc805225886435eb65073e9c82'
- '9d1e3c21fc21ba59f57bad64f320b32f21ffc4915841634175ccb46c60d4af9f'
+ '0aa02c2dc2cb4a32519de43a9f188d924b9a3458fdd941e733a17d54ec3db8ed'
'3d72e09b9054ff75785a85c9f24ee82d48a2b9bf0ce8515156717b20157a45b3')
prepare() {
diff --git a/tdesktop.patch b/tdesktop.patch
index 7e904cc7150c..3cc78e087422 100644
--- a/tdesktop.patch
+++ b/tdesktop.patch
@@ -141,10 +141,10 @@ index 00000000..4a722b8d
+ flags |= QTextItem::StrikeOut;
+}
diff --git a/Telegram/SourceFiles/qt_static_plugins.cpp b/Telegram/SourceFiles/qt_static_plugins.cpp
-index 1d4896a6..f2f876b3 100644
+index b975c7a8..f2f876b3 100644
--- a/Telegram/SourceFiles/qt_static_plugins.cpp
+++ b/Telegram/SourceFiles/qt_static_plugins.cpp
-@@ -28,12 +28,4 @@ Q_IMPORT_PLUGIN(QWebpPlugin)
+@@ -28,13 +28,4 @@ Q_IMPORT_PLUGIN(QWebpPlugin)
Q_IMPORT_PLUGIN(QCocoaIntegrationPlugin)
Q_IMPORT_PLUGIN(QGenericEnginePlugin)
#elif defined Q_OS_LINUX // Q_OS_WIN | Q_OS_MAC
@@ -156,9 +156,10 @@ index 1d4896a6..f2f876b3 100644
-Q_IMPORT_PLUGIN(QComposePlatformInputContextPlugin)
-Q_IMPORT_PLUGIN(QIbusPlatformInputContextPlugin)
-Q_IMPORT_PLUGIN(QFcitxPlatformInputContextPlugin)
+-Q_IMPORT_PLUGIN(QHimePlatformInputContextPlugin)
#endif // Q_OS_WIN | Q_OS_MAC | Q_OS_LINUX
diff --git a/Telegram/SourceFiles/ui/text/text.cpp b/Telegram/SourceFiles/ui/text/text.cpp
-index dbc2b0db..61fa93c9 100644
+index 044f8716..0865a5bb 100644
--- a/Telegram/SourceFiles/ui/text/text.cpp
+++ b/Telegram/SourceFiles/ui/text/text.cpp
@@ -1692,11 +1692,11 @@ private:
@@ -190,10 +191,10 @@ index f89644e1..35230cfc 100644
layout.createLine();
diff --git a/Telegram/SourceFiles/ui/twidget.cpp b/Telegram/SourceFiles/ui/twidget.cpp
-index 04fad32b..688cd8e0 100644
+index e9848ef2..dcee47ee 100644
--- a/Telegram/SourceFiles/ui/twidget.cpp
+++ b/Telegram/SourceFiles/ui/twidget.cpp
-@@ -187,9 +187,9 @@ void sendSynteticMouseEvent(QWidget *widget, QEvent::Type type, Qt::MouseButton
+@@ -191,9 +191,9 @@ void sendSynteticMouseEvent(QWidget *widget, QEvent::Type type, Qt::MouseButton
, button
, QGuiApplication::mouseButtons() | button
, QGuiApplication::keyboardModifiers()
@@ -261,7 +262,7 @@ index 80160d16..8789e874 100644
'<(submodules_loc)/GSL/include',
'<(submodules_loc)/variant/include',
diff --git a/Telegram/gyp/qt.gypi b/Telegram/gyp/qt.gypi
-index 81c13a18..1af2e86e 100644
+index 81c13a18..56066400 100644
--- a/Telegram/gyp/qt.gypi
+++ b/Telegram/gyp/qt.gypi
@@ -27,25 +27,21 @@
@@ -269,7 +270,7 @@ index 81c13a18..1af2e86e 100644
'qt_version%': '5.3.2',
}, {
- 'qt_version%': '5.6.2',
-+ 'qt_version%': '5.9.0',
++ 'qt_version%': '5.9.1',
}]
],
},
@@ -425,7 +426,7 @@ index fde88dcd..ca149b85 100644
],
'cflags_c': [
diff --git a/Telegram/gyp/telegram_linux.gypi b/Telegram/gyp/telegram_linux.gypi
-index b8866ec2..b505a67d 100644
+index 2c464928..b505a67d 100644
--- a/Telegram/gyp/telegram_linux.gypi
+++ b/Telegram/gyp/telegram_linux.gypi
@@ -33,9 +33,10 @@
@@ -448,7 +449,7 @@ index b8866ec2..b505a67d 100644
'/usr/local/lib',
'<(linux_path_ffmpeg)/lib',
'<(linux_path_openal)/lib',
-@@ -52,30 +54,20 @@
+@@ -52,31 +54,20 @@
'<(linux_path_breakpad)/lib',
],
'libraries': [
@@ -456,6 +457,7 @@ index b8866ec2..b505a67d 100644
- 'composeplatforminputcontextplugin',
- 'ibusplatforminputcontextplugin',
- 'fcitxplatforminputcontextplugin',
+- 'himeplatforminputcontextplugin',
- 'liblzma.a',
- 'libopenal.a',
- 'libavformat.a',
@@ -490,10 +492,10 @@ index b8866ec2..b505a67d 100644
],
'configurations': {
diff --git a/Telegram/gyp/telegram_sources.txt b/Telegram/gyp/telegram_sources.txt
-index c970f984..cb5f225c 100644
+index bfc18fdc..5d210e9f 100644
--- a/Telegram/gyp/telegram_sources.txt
+++ b/Telegram/gyp/telegram_sources.txt
-@@ -552,14 +552,7 @@
+@@ -578,14 +578,7 @@
<(src_loc)/structs.cpp
<(src_loc)/structs.h