summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHaochen Tong2017-12-16 21:03:56 +0800
committerHaochen Tong2017-12-16 21:03:56 +0800
commitf4eb7839929684edc7103ec909249cb30178c72f (patch)
treead8893e66958fe895d5a18f5bf6fdf07e7635697
parent741127c21357fcfdb3059d4484beb0466a8b8d6f (diff)
downloadaur-f4eb7839929684edc7103ec909249cb30178c72f.tar.gz
upgpkg
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--tdesktop.patch47
3 files changed, 32 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 665ddbeb10e3..3afa953edf5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Dec 12 08:06:38 UTC 2017
+# Sat Dec 16 13:03:45 UTC 2017
pkgbase = telegram-desktop-systemqt
pkgdesc = Experimental build of Telegram Desktop (using system Qt)
- pkgver = 1.2.0
- pkgrel = 2
+ pkgver = 1.2.1
+ pkgrel = 1
url = https://desktop.telegram.org/
install = telegram-desktop.install
arch = i686
@@ -31,7 +31,7 @@ pkgbase = telegram-desktop-systemqt
optdepends = libappindicator-gtk3: AppIndicator tray icon
provides = telegram-desktop
conflicts = telegram-desktop
- source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.2.0
+ source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.2.1
source = GSL::git+https://github.com/Microsoft/GSL.git
source = libtgvoip::git+https://github.com/telegramdesktop/libtgvoip.git
source = variant::git+https://github.com/mapbox/variant.git
@@ -49,7 +49,7 @@ pkgbase = telegram-desktop-systemqt
sha256sums = e9f0cf7553e0700285ed38f342c4d5e8ec436d3f5d11b10abe4f1f3f432fb86c
sha256sums = d4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb
sha256sums = 7a06af83609168a8eaec59a65252caa41dcd0ecc805225886435eb65073e9c82
- sha256sums = 1eb2ff167b08fa9fab4026eca0eabbb85918a3c156b490b9a02f8126bbe6d896
+ sha256sums = 35ca9d917254ee71141ebfbae1b8447b8d3a5601f8d3a78db2cceedfe83c54f2
sha256sums = 0e55b150b91aeeddcb813fb242a62fe4d1977bcac457eb9d65997faef643f075
pkgname = telegram-desktop-systemqt
diff --git a/PKGBUILD b/PKGBUILD
index 48e763b879cb..c1b441d65b58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# https://github.com/mymedia2/tdesktop
pkgname=telegram-desktop-systemqt
-pkgver=1.2.0
-pkgrel=2
+pkgver=1.2.1
+pkgrel=1
pkgdesc='Experimental build of Telegram Desktop (using system Qt)'
arch=('i686' 'x86_64')
url="https://desktop.telegram.org/"
@@ -36,7 +36,7 @@ sha256sums=('SKIP'
'e9f0cf7553e0700285ed38f342c4d5e8ec436d3f5d11b10abe4f1f3f432fb86c'
'd4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb'
'7a06af83609168a8eaec59a65252caa41dcd0ecc805225886435eb65073e9c82'
- '1eb2ff167b08fa9fab4026eca0eabbb85918a3c156b490b9a02f8126bbe6d896'
+ '35ca9d917254ee71141ebfbae1b8447b8d3a5601f8d3a78db2cceedfe83c54f2'
'0e55b150b91aeeddcb813fb242a62fe4d1977bcac457eb9d65997faef643f075')
prepare() {
diff --git a/tdesktop.patch b/tdesktop.patch
index 37de539b5606..93db8f85b3c2 100644
--- a/tdesktop.patch
+++ b/tdesktop.patch
@@ -8,25 +8,25 @@ index 0554fa179..3ea027406 100644
- <file alias="etc/qt.conf">../etc/qt_linux.conf</file>
</qresource>
</RCC>
-diff --git a/Telegram/SourceFiles/main.cpp b/Telegram/SourceFiles/main.cpp
-index 6e85f27dc..3c7912020 100644
---- a/Telegram/SourceFiles/main.cpp
-+++ b/Telegram/SourceFiles/main.cpp
-@@ -23,9 +23,10 @@ Copyright (c) 2014-2017 John Preston, https://desktop.telegram.org
- #include "storage/localstorage.h"
+diff --git a/Telegram/SourceFiles/core/launcher.cpp b/Telegram/SourceFiles/core/launcher.cpp
+index c05915976..9b19941df 100644
+--- a/Telegram/SourceFiles/core/launcher.cpp
++++ b/Telegram/SourceFiles/core/launcher.cpp
+@@ -43,9 +43,10 @@ void Launcher::init() {
- int main(int argc, char *argv[]) {
--#ifndef Q_OS_MAC // Retina display support is working fine, others are not.
+ QCoreApplication::setApplicationName(qsl("TelegramDesktop"));
+
+-#ifndef OS_MAC_OLD
+#if !defined(Q_OS_MAC) && QT_VERSION >= QT_VERSION_CHECK(5, 6, 0)
+ // Retina display support is working fine, others are not.
QCoreApplication::setAttribute(Qt::AA_DisableHighDpiScaling, true);
--#endif // Q_OS_MAC
+-#endif // OS_MAC_OLD
+#endif // not defined Q_OS_MAC and QT_VERSION >= 5.6.0
- QCoreApplication::setApplicationName(qsl("TelegramDesktop"));
- InitFromCommandLine(argc, argv);
-@@ -39,6 +40,13 @@ int main(int argc, char *argv[]) {
- Logs::start(); // must be started before Platform is started
+ initHook();
+ }
+@@ -63,6 +64,13 @@ int Launcher::exec() {
+ Logs::start(this); // must be started before Platform is started
Platform::start(); // must be started before QApplication is created
+ // I don't know why path is not in QT_PLUGIN_PATH by default
@@ -36,9 +36,9 @@ index 6e85f27dc..3c7912020 100644
+ // Telegram doesn't start when extraordinary theme is set, see launchpad.net/bugs/1680943
+ unsetenv("QT_QPA_PLATFORMTHEME");
+
- int result = 0;
+ auto result = 0;
{
- Application app(argc, argv);
+ Application app(this, _argc, _argv);
diff --git a/Telegram/SourceFiles/platform/linux/linux_libs.h b/Telegram/SourceFiles/platform/linux/linux_libs.h
index e9e349be9..d82963fa2 100644
--- a/Telegram/SourceFiles/platform/linux/linux_libs.h
@@ -190,11 +190,11 @@ index 710277fe2..5eb4465d6 100644
auto blockIndex = _lineStartBlock;
auto currentBlock = _t->_blocks[blockIndex].get();
diff --git a/Telegram/SourceFiles/ui/text/text_block.cpp b/Telegram/SourceFiles/ui/text/text_block.cpp
-index f89644e1d..35230cfc6 100644
+index e435b50dc..893496b4f 100644
--- a/Telegram/SourceFiles/ui/text/text_block.cpp
+++ b/Telegram/SourceFiles/ui/text/text_block.cpp
-@@ -330,7 +330,7 @@ TextBlock::TextBlock(const style::font &font, const QString &str, QFixed minResi
- SignalHandlers::setCrashAnnotationRef("CrashString", &part);
+@@ -332,7 +332,7 @@ TextBlock::TextBlock(const style::font &font, const QString &str, QFixed minResi
+ CrashReports::SetAnnotationRef("CrashString", &part);
QStackTextEngine engine(part, blockFont->f);
- QTextLayout layout(&engine);
@@ -288,7 +288,7 @@ index 07a8276f0..99ac4cacb 100644
'../SourceFiles/platform/linux/linux_glibc_wraps_64.c',
],
diff --git a/Telegram/gyp/qt.gypi b/Telegram/gyp/qt.gypi
-index dea127a33..2b225b127 100644
+index dea127a33..62c95e682 100644
--- a/Telegram/gyp/qt.gypi
+++ b/Telegram/gyp/qt.gypi
@@ -27,25 +27,21 @@
@@ -473,7 +473,7 @@ index b93bace41..0fcdfd566 100644
],
'cflags_c': [
diff --git a/Telegram/gyp/telegram_linux.gypi b/Telegram/gyp/telegram_linux.gypi
-index f6918c224..583602662 100644
+index f6918c224..50f0d8c7c 100644
--- a/Telegram/gyp/telegram_linux.gypi
+++ b/Telegram/gyp/telegram_linux.gypi
@@ -33,10 +33,11 @@
@@ -541,7 +541,8 @@ index f6918c224..583602662 100644
# 32 bit version can't be linked with debug info or LTO,
# virtual memory exhausted :(
'cflags_c': [ '-g' ],
-@@ -119,8 +111,7 @@
+@@ -118,9 +110,8 @@
+ ],
}], ['not_need_gtk!="True"', {
'cflags_cc': [
- '<!(pkg-config 2> /dev/null --cflags appindicator-0.1)',
@@ -553,10 +554,10 @@ index f6918c224..583602662 100644
],
}]
diff --git a/Telegram/gyp/telegram_sources.txt b/Telegram/gyp/telegram_sources.txt
-index e90614dae..0e4d82d69 100644
+index bbf2b2ade..2d380810f 100644
--- a/Telegram/gyp/telegram_sources.txt
+++ b/Telegram/gyp/telegram_sources.txt
-@@ -680,14 +680,7 @@
+@@ -693,14 +693,7 @@
<(emoji_suggestions_loc)/emoji_suggestions.cpp
<(emoji_suggestions_loc)/emoji_suggestions.h