summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Wild2018-11-16 23:04:52 -0500
committerAllen Wild2018-11-16 23:04:52 -0500
commit2369dc3f102393fda72b672c257b07877c4e2c1e (patch)
tree290c963131039072efd9e6803d1775eafff994d9
parent7c96745e59c448389b7a3bb4c768623f894dca19 (diff)
downloadaur-2369dc3f102393fda72b672c257b07877c4e2c1e.tar.gz
1.4.4-2: fix emoji replacement, now using redesigned Noto Color Emoji
In 1.4.3, Telegram heavily refactored how they handle the emoji spritemaps. Now they only include one size and scale/cache it internally, and the sprite maps is broken into five 32x16 sheets. Because of this, I had to actually learn how to generate the sprite sheets, which was an adventure that's documented on https://github.com/aswild/telegram-emoji-gen. The latest commits in the noto emoji repository are the redesigned style for Unicode 11, and there were a lot of SVGs missing in the older commits. Presumably there's some magic way to extract them from a compiled font, but that's not something I have the willpower to dig into right now. The flags are also ugly and not stylized, but oh well.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03b08ac6a37b..4ad546257065 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = telegram-desktop-systemqt-notoemoji
pkgdesc = Official Telegram Desktop client (with noto emoji)
pkgver = 1.4.4
- pkgrel = 1
+ pkgrel = 2
url = https://desktop.telegram.org/
arch = x86_64
license = GPL3
@@ -28,7 +28,7 @@ pkgbase = telegram-desktop-systemqt-notoemoji
source = GSL::git+https://github.com/Microsoft/GSL.git
source = crl::git+https://github.com/telegramdesktop/crl.git
source = xxHash::git+https://github.com/Cyan4973/xxHash.git
- source = https://s3.amazonaws.com/aur-telegram-desktop-notoemoji/noto-emoji-v1.tar.xz
+ source = telegram-emoji-gen-v1.0.tar.xz::https://github.com/aswild/telegram-emoji-gen/archive/v1.0.tar.gz
source = build-time-optimize.patch.in
source = tg.protocol
source = CMakeLists.inj
@@ -42,7 +42,7 @@ pkgbase = telegram-desktop-systemqt-notoemoji
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = 376a4860e37b0f60892f362e954f976a563c632579167003b4aacbb24b6fea6aabb4e6952baf6d1a546b961936935cc49cf0e0ce9570320245b6bb326cb149e5
+ sha512sums = c0983a175b5bab3c2fbc9717bd16233188fc7e6e60e0744682a17b7d41b748400924682811f6b04f88e2c0721754466a2496ccc595f7d34a45f69bd0063757f6
sha512sums = fa7042f370ae4e2e14d083395743cdee25bfedc39ab5273b5d1ab12fb074757cf76dab065f2abcb44cad018920e711142fbf24a2b9cd30f517c5a5b46d6a6182
sha512sums = b87414ceaae19185a8a5749cea1f6d9f3fc3c69b8dd729e3db8790cde00b987c3c827cd30baf0eac579d1884e34aa2f37bb90778c3c0bc9ca211d75a82891b9d
sha512sums = b20674f61ff6378749d1f59a6a0da194d33ccc786bd783f6ed62027924a3a8a8d27c9763bf376480432d6536896b0c7eeb8c495c5b8cefff7cf5fe84da50947e
diff --git a/PKGBUILD b/PKGBUILD
index 71e8ab949159..c03d54312861 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=telegram-desktop-systemqt-notoemoji
pkgver=1.4.4
-pkgrel=1
+pkgrel=2
pkgdesc='Official Telegram Desktop client (with noto emoji)'
arch=('x86_64')
url="https://desktop.telegram.org/"
@@ -18,7 +18,7 @@ optdepends=('libnotify: desktop notifications')
conflicts=('telegram-desktop')
provides=('telegram-desktop')
-_emojiver="v1"
+_emojiver="v1.0"
source=(
"tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v$pkgver"
"libtgvoip::git+https://github.com/telegramdesktop/libtgvoip"
@@ -27,7 +27,7 @@ source=(
"GSL::git+https://github.com/Microsoft/GSL.git"
"crl::git+https://github.com/telegramdesktop/crl.git"
"xxHash::git+https://github.com/Cyan4973/xxHash.git"
- "https://s3.amazonaws.com/aur-telegram-desktop-notoemoji/noto-emoji-${_emojiver}.tar.xz"
+ "telegram-emoji-gen-${_emojiver}.tar.xz::https://github.com/aswild/telegram-emoji-gen/archive/${_emojiver}.tar.gz"
"build-time-optimize.patch.in"
"tg.protocol"
"CMakeLists.inj"
@@ -42,7 +42,7 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '376a4860e37b0f60892f362e954f976a563c632579167003b4aacbb24b6fea6aabb4e6952baf6d1a546b961936935cc49cf0e0ce9570320245b6bb326cb149e5'
+ 'c0983a175b5bab3c2fbc9717bd16233188fc7e6e60e0744682a17b7d41b748400924682811f6b04f88e2c0721754466a2496ccc595f7d34a45f69bd0063757f6'
'fa7042f370ae4e2e14d083395743cdee25bfedc39ab5273b5d1ab12fb074757cf76dab065f2abcb44cad018920e711142fbf24a2b9cd30f517c5a5b46d6a6182'
'b87414ceaae19185a8a5749cea1f6d9f3fc3c69b8dd729e3db8790cde00b987c3c827cd30baf0eac579d1884e34aa2f37bb90778c3c0bc9ca211d75a82891b9d'
'b20674f61ff6378749d1f59a6a0da194d33ccc786bd783f6ed62027924a3a8a8d27c9763bf376480432d6536896b0c7eeb8c495c5b8cefff7cf5fe84da50947e'
@@ -71,9 +71,7 @@ prepare() {
cd "Telegram/ThirdParty/libtgvoip"
patch -Np1 -i "$srcdir/libtgvoip.patch"
- for x in "" "_125x" "_150x" "_200x" "_250x"; do
- cp -vf "$srcdir/noto-emoji-${_emojiver}/emoji$x.webp" "$srcdir/tdesktop/Telegram/Resources/art/emoji$x.webp"
- done
+ cp -vf "$srcdir/telegram-emoji-gen-${_emojiver#v}/telegram-noto-emoji/"*.webp "$srcdir/tdesktop/Telegram/Resources/emoji"
}
build() {