summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorudf2020-06-18 18:45:39 +0200
committerudf2020-06-18 18:45:39 +0200
commit53c98ad139b07a4c6df8a3fbb3b2cc5e69a923ac (patch)
tree9af8bc7f585b108d2ade374c8aab024ce4028938
parent5ada9cd9657f03234b5f4c67645947b32d28000a (diff)
downloadaur-53c98ad139b07a4c6df8a3fbb3b2cc5e69a923ac.tar.gz
Add patch to force GTK file chooser
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--force_gtk_integration.patch15
3 files changed, 22 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40d06d3dfb23..0e655b010133 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = telegram-desktop-udf-patched
pkgdesc = Telegram Desktop client with several personal patches
pkgver = 2.1.11
- pkgrel = 2
+ pkgrel = 3
url = https://desktop.telegram.org/
arch = x86_64
license = GPL3
@@ -29,11 +29,13 @@ pkgbase = telegram-desktop-udf-patched
source = always_clear_history_for_everyone.patch
source = always_pin_without_notify.patch
source = always_send_as_photo_or_album.patch
+ source = force_gtk_integration.patch
sha512sums = 9f2fba2814a5ab64f946913e32fce66dbc842d9607cbaee00994689ef6a661a04c2a8de5e075fc532e7d8926b51432c06c2b1510b019d729eef40da373d91d42
sha512sums = e88fa96024efc6176c818d0a46684e0ee1fb3a7bdadb323ad3b29f736209c80b6c31b135cf84389e7e2bbd614e57b241e4437c94b6fd114e73cfc418bf130015
sha512sums = 4a7e9de924bbf32fb4cd24ffa2764bcf49e0540bba649829b180da20a62810d4a21ebf11529d4eca22c9ceaa93b434ca3fbfd0b636795f8109ea4e1eddbff8f3
sha512sums = b4eeeb4b2801f3edcc7423f28403b1dfabd3f3869425e4f102a2a4554bde93e63bd73d2d4dbf3e5748ce831b570e441d3917f532fc5cceac1ee5e8fd0832cb30
sha512sums = 1fb1e4d9dcf0d54f98b2cf47a3a0cc6e6eed649617efab0e5631d9760b42eb85c7c421ba659656405f0f1d1087a80090baebb9f5f1154f4d0da9493dfa4a13c3
+ sha512sums = 17faeff3ee56edd63be658c3730dbbed26437cb9bf0a9890d16cae26fd500aaab738b66de57b573903a5bd727dafe65105e151b08d7a6d8c426c148e754a7114
pkgname = telegram-desktop-udf-patched
diff --git a/PKGBUILD b/PKGBUILD
index dce720a8a16e..a115ea023918 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
pkgname=telegram-desktop-udf-patched
pkgver=2.1.11
-pkgrel=2
+pkgrel=3
pkgdesc='Telegram Desktop client with several personal patches'
arch=('x86_64')
url="https://desktop.telegram.org/"
@@ -32,6 +32,7 @@ source=(
"always_clear_history_for_everyone.patch"
"always_pin_without_notify.patch"
"always_send_as_photo_or_album.patch"
+ "force_gtk_integration.patch"
)
sha512sums=(
'9f2fba2814a5ab64f946913e32fce66dbc842d9607cbaee00994689ef6a661a04c2a8de5e075fc532e7d8926b51432c06c2b1510b019d729eef40da373d91d42'
@@ -40,6 +41,7 @@ sha512sums=(
'4a7e9de924bbf32fb4cd24ffa2764bcf49e0540bba649829b180da20a62810d4a21ebf11529d4eca22c9ceaa93b434ca3fbfd0b636795f8109ea4e1eddbff8f3'
'b4eeeb4b2801f3edcc7423f28403b1dfabd3f3869425e4f102a2a4554bde93e63bd73d2d4dbf3e5748ce831b570e441d3917f532fc5cceac1ee5e8fd0832cb30'
'1fb1e4d9dcf0d54f98b2cf47a3a0cc6e6eed649617efab0e5631d9760b42eb85c7c421ba659656405f0f1d1087a80090baebb9f5f1154f4d0da9493dfa4a13c3'
+ '17faeff3ee56edd63be658c3730dbbed26437cb9bf0a9890d16cae26fd500aaab738b66de57b573903a5bd727dafe65105e151b08d7a6d8c426c148e754a7114'
)
prepare() {
@@ -50,6 +52,7 @@ prepare() {
patch -Np1 -i "$srcdir/always_clear_history_for_everyone.patch"
patch -Np1 -i "$srcdir/always_pin_without_notify.patch"
patch -Np1 -i "$srcdir/always_send_as_photo_or_album.patch"
+ patch -Np1 -i "$srcdir/force_gtk_integration.patch"
}
build() {
diff --git a/force_gtk_integration.patch b/force_gtk_integration.patch
new file mode 100644
index 000000000000..d6db92459ab3
--- /dev/null
+++ b/force_gtk_integration.patch
@@ -0,0 +1,15 @@
+Description: Forces GTK integration so the GTK file picker is always used.
+
+diff --git a/Telegram/SourceFiles/platform/linux/specific_linux.cpp b/Telegram/SourceFiles/platform/linux/specific_linux.cpp
+index 340afda80..d94f5cb03 100644
+--- a/Telegram/SourceFiles/platform/linux/specific_linux.cpp
++++ b/Telegram/SourceFiles/platform/linux/specific_linux.cpp
+@@ -310,6 +310,8 @@ bool UseGtkIntegration() {
+ }
+
+ bool IsGtkIntegrationForced() {
++ return true;
++
+ #ifndef TDESKTOP_DISABLE_GTK_INTEGRATION
+ static const auto Result = [&] {
+ return PlatformThemes.contains(qstr("gtk3"), Qt::CaseInsensitive)