summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaladinDev2023-06-17 16:09:44 +0300
committerPaladinDev2023-06-17 16:09:44 +0300
commit0bca7e1eda34c7ed3c93c8ab332616e6606556ca (patch)
treed8ade060e2bb6c2766d315b09103377e6934181f
downloadaur-0bca7e1eda34c7ed3c93c8ab332616e6606556ca.tar.gz
Initial publish to aur
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77b77c1f5ef9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = telegram-glib
+ pkgdesc = Telegram bot API written in Vala
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/vala-lang/vala-language-server
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = vala
+ makedepends = valadoc
+ makedepends = gobject-introspection
+ depends = glibc
+ depends = glib2
+ depends = libsoup3
+ depends = json-glib
+ source = https://github.com/SpikedPaladin/TelegramGLib/archive/0.3.0.tar.gz
+ sha256sums = eca6188b5c7b9b808f0850af12ee22c283d96a8c244fc1b8097310083ea139bf
+
+pkgname = telegram-glib
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02c500ca9fea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: PaladinDev <paladingames1@gmail.com>
+_pkgname=TelegramGLib
+pkgname=telegram-glib
+_pkgver=0.3.0
+pkgver=${_pkgver/-/+}
+pkgrel=1
+pkgdesc='Telegram bot API written in Vala'
+arch=('x86_64')
+url="https://github.com/vala-lang/vala-language-server"
+license=('GPL3')
+depends=(glibc glib2 libsoup3 json-glib)
+makedepends=(git meson vala valadoc gobject-introspection)
+source=("https://github.com/SpikedPaladin/TelegramGLib/archive/$_pkgver.tar.gz")
+sha256sums=('eca6188b5c7b9b808f0850af12ee22c283d96a8c244fc1b8097310083ea139bf')
+
+prepare() {
+ cd "$_pkgname-$_pkgver"
+}
+
+build() {
+ cd "$_pkgname-$_pkgver"
+ arch-meson build
+ ninja -C build
+}
+
+package() {
+ cd "$_pkgname-$_pkgver"
+ DESTDIR="${pkgdir}" ninja -C build install
+}