summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorj.r2021-12-05 17:56:54 +0100
committerj.r2021-12-05 17:56:54 +0100
commit23e67a21e4af77c9e24d59385b2930524ff37042 (patch)
treefd6b33803f0108815d5e9f369827d69c6786a841
parent988f5ca2632f655f6a90a72189090c81a57c6ca3 (diff)
downloadaur-23e67a21e4af77c9e24d59385b2930524ff37042.tar.gz
telegram-tg: use latest python-telegram
-rw-r--r--.SRCINFO7
-rw-r--r--0001-Change-setup.py-to-accept-new-python-telegram-ver.patch23
-rw-r--r--PKGBUILD20
3 files changed, 41 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 413ae522bc5f..d3593e2f90d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = telegram-tg
pkgdesc = terminal telegram client that really works
pkgver = 0.17.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/paul-nameless/tg
arch = any
license = Unlicense
- depends = python-telegram=0.14.0
+ depends = python-telegram=0.15.0
depends = python3
depends = python-setuptools
optdepends = libnotify: for notifications, you could also use other programs: see config
@@ -16,7 +16,8 @@ pkgbase = telegram-tg
optdepends = fzf: to create groups and secret chats, used for single and multiple user selection
conflicts = telegram-tg-git
source = telegram-tg-0.17.0.tar.gz::https://github.com/paul-nameless/tg/archive/v0.17.0.tar.gz
+ source = 0001-Change-setup.py-to-accept-new-python-telegram-ver.patch
md5sums = a9b619805bf79f6f92093e3f96e54125
+ md5sums = 1977134e8c8fcd093d7081877711255d
pkgname = telegram-tg
-
diff --git a/0001-Change-setup.py-to-accept-new-python-telegram-ver.patch b/0001-Change-setup.py-to-accept-new-python-telegram-ver.patch
new file mode 100644
index 000000000000..ca6006a6572c
--- /dev/null
+++ b/0001-Change-setup.py-to-accept-new-python-telegram-ver.patch
@@ -0,0 +1,23 @@
+From ac8b551d16feb2fd9dbc5b1bfac4057ce6e9ef87 Mon Sep 17 00:00:00 2001
+From: "j.r" <j.r@jugendhacker.de>
+Date: Tue, 29 Dec 2020 14:44:26 +0100
+Subject: [PATCH] Change setup.py to accept new python-telegram ver
+
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 2455e78..011eed7 100644
+--- a/setup.py
++++ b/setup.py
+@@ -22,5 +22,5 @@ setup(
+ packages=["tg"],
+ entry_points={"console_scripts": ["tg = tg.__main__:main"]},
+ python_requires=">=3.8",
+- install_requires=["python-telegram==0.14.0"],
++ install_requires=["python-telegram==0.15.0"],
+ )
+--
+2.34.1
+
diff --git a/PKGBUILD b/PKGBUILD
index c555c32ca02b..32b94b99f121 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
_pkgname=tg
pkgname=telegram-$_pkgname
pkgver=0.17.0
-pkgrel=2
+pkgrel=3
pkgdesc="terminal telegram client that really works"
arch=('any')
url="https://github.com/paul-nameless/tg"
license=('Unlicense')
-depends=('python-telegram=0.14.0' 'python3' 'python-setuptools')
+depends=('python-telegram=0.15.0' 'python3' 'python-setuptools')
optdepends=(
'libnotify: for notifications, you could also use other programs: see config'
'ffmpeg: to record voice msgs and upload videos correctly'
@@ -17,17 +17,25 @@ optdepends=(
'fzf: to create groups and secret chats, used for single and multiple user selection'
)
conflicts=('telegram-tg-git')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-md5sums=('a9b619805bf79f6f92093e3f96e54125')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+ "0001-Change-setup.py-to-accept-new-python-telegram-ver.patch")
+md5sums=('a9b619805bf79f6f92093e3f96e54125'
+ '1977134e8c8fcd093d7081877711255d')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ patch -p1 -i "$srcdir/0001-Change-setup.py-to-accept-new-python-telegram-ver.patch"
+}
build() {
- cd "$_pkgname-$pkgver"
+ cd "$srcdir/$_pkgname-$pkgver"
python3 setup.py build
}
package() {
- cd "$_pkgname-$pkgver"
+ cd "$srcdir/$_pkgname-$pkgver"
python3 setup.py install --root="$pkgdir" --optimize=1 --skip-build
}