summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorj.r2022-07-07 13:30:06 +0200
committerj.r2022-07-07 13:30:06 +0200
commit2aad7f6d3f29db80ad6d0e75cdc4cba052914308 (patch)
tree72cbd6f041b6691c721322efd72f55d266953fbb
parentd26d05bdba4828ca51485fc33063455e145dd26b (diff)
downloadaur-2aad7f6d3f29db80ad6d0e75cdc4cba052914308.tar.gz
Use python standard way for building
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89f0b91d4d35..72a6a9d5f013 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,14 @@
pkgbase = telegram-tg
pkgdesc = terminal telegram client that really works
pkgver = 0.19.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/paul-nameless/tg
arch = any
license = Unlicense
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-poetry
depends = python-telegram=0.15.0
depends = python3
depends = python-setuptools
diff --git a/PKGBUILD b/PKGBUILD
index ed2b2cfb9cc9..b4a8b1cceb4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
_pkgname=tg
pkgname=telegram-$_pkgname
pkgver=0.19.0
-pkgrel=1
+pkgrel=2
pkgdesc="terminal telegram client that really works"
arch=('any')
url="https://github.com/paul-nameless/tg"
license=('Unlicense')
depends=('python-telegram=0.15.0' 'python3' 'python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-poetry')
optdepends=(
'libnotify: for notifications, you could also use other programs: see config'
'ffmpeg: to record voice msgs and upload videos correctly'
@@ -23,11 +24,11 @@ md5sums=('8ce8894aa02552526f912954e33c2174')
build() {
cd "$srcdir/$_pkgname-$pkgver"
- python3 setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/$_pkgname-$pkgver"
- python3 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}