summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorj.r2020-06-29 00:13:14 +0200
committerj.r2020-06-29 00:13:14 +0200
commit75dcdb5847fa9823f07540c047f061f10c4fdda8 (patch)
tree528eec290f0cd87b41ab8521a94758b33fdd2d47
downloadaur-75dcdb5847fa9823f07540c047f061f10c4fdda8.tar.gz
Init with version 0.1.3
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b77451a9d77c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = telegram-tg
+ pkgdesc = terminal telegram client that really works
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/paul-nameless/tg
+ arch = any
+ license = Unlicense
+ makedepends = python-dephell
+ depends = python-telegram
+ depends = python3
+ optdepends = libnotify: for notifications, you could also use other programs: see config
+ optdepends = ffmpeg: to record voice msgs and upload videos correctly
+ optdepends = urlview: to choose urls when there is multiple in message, use URL_VIEW in config file to use another app, it should accept urls in stdin
+ conflicts = telegram-tg-git
+ source = telegram-tg-0.1.3.tar.gz::https://github.com/paul-nameless/tg/archive/v0.1.3.tar.gz
+ md5sums = c40a1446ddac757d7e1469d0192cd915
+
+pkgname = telegram-tg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f1347925092
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: j.r <j.r@jugendhacker.de>
+_pkgname=tg
+pkgname=telegram-$_pkgname
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="terminal telegram client that really works"
+arch=('any')
+url="https://github.com/paul-nameless/tg"
+license=('Unlicense')
+depends=('python-telegram' 'python3')
+makedepends=('python-dephell')
+optdepends=(
+ 'libnotify: for notifications, you could also use other programs: see config'
+ 'ffmpeg: to record voice msgs and upload videos correctly'
+ 'urlview: to choose urls when there is multiple in message, use URL_VIEW in config file to use another app, it should accept urls in stdin'
+)
+conflicts=('telegram-tg-git')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+md5sums=('c40a1446ddac757d7e1469d0192cd915')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+
+ dephell deps convert --from pyproject.toml --to setup.py
+}
+
+build() {
+ cd "$_pkgname-$pkgver"
+
+ python3 setup.py build
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+
+ python3 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}