summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorj.r2022-09-04 23:53:30 +0200
committerj.r2022-09-04 23:53:30 +0200
commit3841d53dd0d1903a2c4300c2978bf6840f5fbe46 (patch)
tree6719a306e341f40031ae947f72a3f6f4bce6c649
parent7be2e2dd46464400b7d7c7582118ae8c99fbcbe8 (diff)
downloadaur-3841d53dd0d1903a2c4300c2978bf6840f5fbe46.tar.gz
Allow python-telegram 0.16.0
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Allow-newer-python-telegram.patch23
-rw-r--r--PKGBUILD16
3 files changed, 39 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 239a59d3ff80..e03c32c658a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = telegram-tg-git
pkgdesc = terminal telegram client that really works
- pkgver = 0.19.0.r2.49981d1
+ pkgver = 0.19.0.r3.2b0c0cf
pkgrel = 1
url = https://github.com/paul-nameless/tg
arch = any
license = Unlicense
makedepends = git
- depends = python-telegram=0.15.0
+ depends = python-telegram>=0.15.0
depends = python3
depends = python-setuptools
optdepends = libnotify: for notifications, you could also use other programs: see config
@@ -18,6 +18,8 @@ pkgbase = telegram-tg-git
provides = telegram-tg
conflicts = telegram-tg
source = telegram-tg::git+https://github.com/paul-nameless/tg.git
+ source = 0001-Allow-newer-python-telegram.patch
md5sums = SKIP
+ md5sums = d036364babd1f2cb63693c7df6b4946e
pkgname = telegram-tg-git
diff --git a/0001-Allow-newer-python-telegram.patch b/0001-Allow-newer-python-telegram.patch
new file mode 100644
index 000000000000..d3e8085eeb52
--- /dev/null
+++ b/0001-Allow-newer-python-telegram.patch
@@ -0,0 +1,23 @@
+From 21bd3e168d33ae7d11aad4ed0c6c23eef027e3c3 Mon Sep 17 00:00:00 2001
+From: "j.r" <j.r@jugendhacker.de>
+Date: Sun, 4 Sep 2022 23:45:12 +0200
+Subject: [PATCH] Allow newer python-telegram
+
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index f6b2e37..5be5d12 100644
+--- a/setup.py
++++ b/setup.py
+@@ -23,5 +23,5 @@ setup(
+ packages=["tg"],
+ entry_points={"console_scripts": ["tg = tg.__main__:main"]},
+ python_requires=">=3.8",
+- install_requires=["python-telegram==0.15.0"],
++ install_requires=["python-telegram>=0.15.0"],
+ )
+--
+2.37.3
+
diff --git a/PKGBUILD b/PKGBUILD
index 3288f3b7311e..2ac6ef1136e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: j.r <j.r@jugendhacker.de>
_pkgname=telegram-tg
pkgname=$_pkgname-git
-pkgver=0.19.0.r2.49981d1
+pkgver=0.19.0.r3.2b0c0cf
pkgrel=1
pkgdesc="terminal telegram client that really works"
arch=(any)
url="https://github.com/paul-nameless/tg"
license=('Unlicense')
-depends=('python-telegram=0.15.0' 'python3' 'python-setuptools')
+depends=('python-telegram>=0.15.0' 'python3' 'python-setuptools')
makedepends=('git')
optdepends=(
'libnotify: for notifications, you could also use other programs: see config'
@@ -19,8 +19,10 @@ optdepends=(
)
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$_pkgname::git+https://github.com/paul-nameless/tg.git")
-md5sums=('SKIP')
+source=("$_pkgname::git+https://github.com/paul-nameless/tg.git"
+ "0001-Allow-newer-python-telegram.patch")
+md5sums=('SKIP'
+ 'd036364babd1f2cb63693c7df6b4946e')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -28,6 +30,12 @@ pkgver() {
printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/\(v\)\(.*\)/\2/')"
}
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ patch -p1 -i "${srcdir}/0001-Allow-newer-python-telegram.patch"
+}
+
build() {
cd "$srcdir/$_pkgname"