summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Puertas2017-05-20 11:59:48 +0200
committerKevin Puertas2017-05-20 11:59:48 +0200
commit926fc224ed4d55588140e4c9e356a023739a7740 (patch)
tree31ab4e77df9d43ceafe6d9377ca3ee29ceb1b7d6
downloadaur-926fc224ed4d55588140e4c9e356a023739a7740.tar.gz
Version 1.0.7
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD23
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86fa734d8c45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = telepad
+ pkgdesc = Telepad desktop application. This software communicates with the Telepad mobile application in order to use a mobile/tablet as a remote mouse and keyboard.
+ pkgver = 1.0.7
+ pkgrel = 1
+ url = https://archlinuxarm.org/wiki/Distcc_Cross-Compiling
+ arch = x86_64
+ arch = i686
+ license = custom
+ depends = bluez-libs
+ depends = libx11
+ depends = libxext
+ depends = libxtst
+ depends = jre8-openjdk
+ provides = telepad
+ provides = telepad-app
+ options = !emptydirs
+ source = https://launchpad.net/~pelle-vincent-n/+archive/ubuntu/telepad-ppa/+files/telepad_1.0.7.orig.tar.xz
+ md5sums = 9bd69e4f4757ff61683d17da044c2453
+
+pkgname = telepad
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5cf5ac43842
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: JKA Network (JoseluCross, Kprkpr, Yukialba) <contacto@jkanetwork.com>
+pkgname=telepad
+pkgver=1.0.7
+pkgrel=1
+pkgdesc="Telepad desktop application. This software communicates with the Telepad mobile application in order to use a mobile/tablet as a remote mouse and keyboard."
+arch=('x86_64' 'i686')
+url="https://archlinuxarm.org/wiki/Distcc_Cross-Compiling"
+license=('custom')
+provides=('telepad' 'telepad-app')
+depends=('bluez-libs' 'libx11' 'libxext' 'libxtst' 'jre8-openjdk')
+options=(!emptydirs)
+source=("https://launchpad.net/~pelle-vincent-n/+archive/ubuntu/telepad-ppa/+files/${pkgname}_${pkgver}.orig.tar.xz")
+md5sums=('9bd69e4f4757ff61683d17da044c2453')
+build() {
+ cd "${pkgname}-${pkgver}.orig"
+ ./configure
+ make
+}
+package() {
+ cd "${pkgname}-${pkgver}.orig"
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 debian/copyright "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}