summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorK9002016-03-03 19:39:51 +0300
committerK9002016-03-03 19:39:51 +0300
commit10b2efa77e98741fac03aec0a7025554785aa4a3 (patch)
tree754a42ada006ffbd0e49f6eb80f31e4761c9d9ea
downloadaur-10b2efa77e98741fac03aec0a7025554785aa4a3.tar.gz
First commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD45
-rw-r--r--cisco-jabber-workaround.patch12
-rw-r--r--telepathy-gabble.install13
4 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a11d11096c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = telepathy-gabble-cisco
+ pkgdesc = A Jabber/XMPP connection manager for Telepathy, patched to connect to Cisco Jabber servers
+ pkgver = 0.18.3
+ pkgrel = 1
+ url = http://telepathy.freedesktop.org
+ install = telepathy-gabble.install
+ arch = i686
+ arch = x86_64
+ groups = telepathy
+ license = LGPL2.1
+ makedepends = libxslt
+ makedepends = python2
+ depends = telepathy-glib
+ depends = libsoup
+ depends = libnice
+ depends = sqlite
+ provides = telepathy-gabble
+ conflicts = telepathy-gabble
+ options = !emptydirs
+ source = http://telepathy.freedesktop.org/releases/telepathy-gabble/telepathy-gabble-0.18.3.tar.gz
+ source = cisco-jabber-workaround.patch
+ md5sums = 40f2fbabc4e6e147258c83ed697f2fcf
+ md5sums = 23b47ce24f3701133cf806c06d73e79d
+
+pkgname = telepathy-gabble-cisco
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..318e010a678f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# $Id$
+# Maintainer : Ionut Biru <ibiru@archlinux.org>
+# Contributor: Daniel Balieiro <daniel@balieiro.com>
+# Contributor: Rodrigo L. M. Flores <mail@rodrigoflores.org>
+# Contributor: K900 <me@0upti.me>
+# Original patch by Leonid Evdokimov
+# https://launchpad.net/~darkk/+archive/ubuntu/cisco-gabble
+_pkgname=telepathy-gabble
+pkgname=$_pkgname-cisco
+pkgver=0.18.3
+pkgrel=1
+pkgdesc="A Jabber/XMPP connection manager for Telepathy, patched to connect to Cisco Jabber servers"
+arch=('i686' 'x86_64')
+url="http://telepathy.freedesktop.org"
+groups=('telepathy')
+license=('LGPL2.1')
+depends=('telepathy-glib' 'libsoup' 'libnice' 'sqlite')
+makedepends=('libxslt' 'python2')
+options=('!emptydirs')
+source=(
+ http://telepathy.freedesktop.org/releases/$_pkgname/$_pkgname-$pkgver.tar.gz
+ cisco-jabber-workaround.patch
+)
+install=telepathy-gabble.install
+md5sums=('40f2fbabc4e6e147258c83ed697f2fcf'
+ '23b47ce24f3701133cf806c06d73e79d')
+
+provides=('telepathy-gabble')
+conflicts=('telepathy-gabble')
+
+build() {
+ cd $_pkgname-$pkgver
+
+ patch -p1 -i $srcdir/cisco-jabber-workaround.patch
+
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr \
+ --libexecdir=/usr/lib/telepathy --with-tls=openssl
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ sed -i "s|#!/usr/bin/env python|#!/usr/bin/env python2|" "$pkgdir/usr/bin/telepathy-gabble-xmpp-console"
+}
diff --git a/cisco-jabber-workaround.patch b/cisco-jabber-workaround.patch
new file mode 100644
index 000000000000..fd669e8a7ece
--- /dev/null
+++ b/cisco-jabber-workaround.patch
@@ -0,0 +1,12 @@
+--- telepathy-gabble-0.18.3.orig/lib/ext/wocky/wocky/wocky-c2s-porter.c
++++ telepathy-gabble-0.18.3/lib/ext/wocky/wocky/wocky-c2s-porter.c
+@@ -857,6 +857,9 @@ check_spoofing (WockyC2SPorter *self,
+ {
+ if (stanza_is_from_server (self, nfrom))
+ goto finally;
++ /* that's buggy Cisco jabber */
++ if (/* is_tls(self) && */ g_str_has_prefix(from, "privacy-cm."))
++ goto finally;
+ }
+
+ /* If we sent an IQ to the server itself, allow it to
diff --git a/telepathy-gabble.install b/telepathy-gabble.install
new file mode 100644
index 000000000000..87d7838b83c8
--- /dev/null
+++ b/telepathy-gabble.install
@@ -0,0 +1,13 @@
+post_install() {
+ killall -HUP dbus-daemon 2>&1
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et: