summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Scheirer2016-01-26 15:40:59 -0500
committerMatt Scheirer2016-01-26 15:40:59 -0500
commit6be934d9780485daca75afe1fc2a71d0d8b2cd40 (patch)
treee222c172bfd582488c9484947476c1e97d923bff
parentc0370ed30ffc9dd5ca11e2fb7d8b476396d85a8f (diff)
downloadaur-6be934d9780485daca75afe1fc2a71d0d8b2cd40.tar.gz
Changed versions to use long tags
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18e6375d7f13..55c981b42da5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Jan 26 20:40:19 UTC 2016
pkgbase = telepathy-kde-accounts-kcm-git
pkgdesc = KCM Module for configuring Telepathy Instant Messaging Accounts
- pkgver = r1109.608947e
+ pkgver = v15.07.80.r12.gbe4a1e0
pkgrel = 1
url = http://community.kde.org/Real-Time_Communication_and_Collaboration
arch = i686
arch = x86_64
license = GPL
makedepends = extra-cmake-modules
- makedepends = git
makedepends = intltool
depends = telepathy-qt5
- depends = kaccounts-integration-git
+ depends = kaccounts-integration
conflicts = telepathy-kde-accounts-kcm
- replaces = telepathy-kde-accounts-kcm-frameworks-git
- source = git://anongit.kde.org/ktp-accounts-kcm.git
+ source = git://anongit.kde.org/ktp-accounts-kcm
sha256sums = SKIP
pkgname = telepathy-kde-accounts-kcm-git
diff --git a/PKGBUILD b/PKGBUILD
index 2e0fc5dd0b71..d4b4a42f6515 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
+# Maintainer: Zanny <lordzanny@gmail.com>
# Maintainer: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
# Author: Antonio Rojas <arojas@archlinux.org>
+_gitname=ktp-accounts-kcm
pkgname=telepathy-kde-accounts-kcm-git
-pkgver=r1109.608947e
+pkgver=v15.07.80.r12.gbe4a1e0
pkgrel=1
pkgdesc='KCM Module for configuring Telepathy Instant Messaging Accounts'
arch=('i686' 'x86_64')
url='http://community.kde.org/Real-Time_Communication_and_Collaboration'
license=('GPL')
-depends=('telepathy-qt5' 'kaccounts-integration-git')
-makedepends=('extra-cmake-modules' 'git' 'intltool')
+depends=('telepathy-qt5' 'kaccounts-integration')
+makedepends=('extra-cmake-modules' 'intltool')
conflicts=('telepathy-kde-accounts-kcm')
-replaces=('telepathy-kde-accounts-kcm-frameworks-git')
-source=("git://anongit.kde.org/ktp-accounts-kcm.git")
+source=("git://anongit.kde.org/$_gitname")
sha256sums=('SKIP')
pkgver() {
- cd ktp-accounts-kcm
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$_gitname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
@@ -26,7 +27,7 @@ prepare() {
build() {
cd build
- cmake ../ktp-accounts-kcm \
+ cmake ../$_gitname \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DLIB_INSTALL_DIR=lib \