summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Scheirer2016-01-26 15:49:21 -0500
committerMatt Scheirer2016-01-26 15:49:21 -0500
commit6714f3c4a9c2ab807101697e1accbb91780f0fce (patch)
tree4b021b4a781a3b9e59c893c9d8bb0cc84bc752f1
parent76e68589065258fb680c62cfb67763227f2c2ce9 (diff)
downloadaur-6714f3c4a9c2ab807101697e1accbb91780f0fce.tar.gz
Changed versions to use long tags
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d036361bb358..72c8c670a3b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Tue Jan 26 20:49:14 UTC 2016
pkgbase = telepathy-kde-integration-module-git
pkgdesc = Sits in KDED and takes care of various bits of system integration like setting user to auto-away or handling connection errors
- pkgver = r329.af3187d
+ pkgver = v15.07.80.r1.gc360f7e
pkgrel = 1
url = http://community.kde.org/Real-Time_Communication_and_Collaboration
arch = i686
@@ -11,9 +13,9 @@ pkgbase = telepathy-kde-integration-module-git
makedepends = kdoctools
makedepends = python
depends = telepathy-kde-common-internals-git
+ depends = kidletime
conflicts = telepathy-kde-integration-module
- replaces = telepathy-kde-integration-module-frameworks-git
- source = git://anongit.kde.org/ktp-kded-module.git
+ source = git://anongit.kde.org/ktp-kded-module
sha256sums = SKIP
pkgname = telepathy-kde-integration-module-git
diff --git a/PKGBUILD b/PKGBUILD
index 1f0440eb2b5b..31ee62e57ad0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
+# Maintainer Zanny <lordzanny@gmail.com>
# Maintainer: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
# Author: Antonio Rojas <arojas@archlinux.org>
+_gitname=ktp-kded-module
pkgname=telepathy-kde-integration-module-git
-pkgver=r329.af3187d
+pkgver=v15.07.80.r1.gc360f7e
pkgrel=1
pkgdesc='Sits in KDED and takes care of various bits of system integration like setting user to auto-away or handling connection errors'
arch=('i686' 'x86_64')
url='http://community.kde.org/Real-Time_Communication_and_Collaboration'
license=('GPL')
-depends=('telepathy-kde-common-internals-git')
+depends=('telepathy-kde-common-internals-git' 'kidletime')
makedepends=('extra-cmake-modules' 'git' 'kdoctools' 'python')
conflicts=('telepathy-kde-integration-module')
-replaces=('telepathy-kde-integration-module-frameworks-git')
-source=("git://anongit.kde.org/ktp-kded-module.git")
+source=("git://anongit.kde.org/$_gitname")
sha256sums=('SKIP')
pkgver() {
- cd ktp-kded-module
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$_gitname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
@@ -26,7 +27,7 @@ prepare() {
build() {
cd build
- cmake ../ktp-kded-module \
+ cmake ../$_gitname \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DLIB_INSTALL_DIR=lib \
@@ -36,5 +37,5 @@ build() {
package() {
cd build
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="$pkgdir" install
}